Android OS Forum banner
1 - 8 of 8 Posts

·
Android Apprentice
Joined
·
25 Posts
Discussion Starter · #1 ·
When using cm4dx or aosp Liberty my 3g data connection fails to function even though it shows signal so I am unable to send or receive emails, get on the internet, etc but txt messenging and phone calls are uneffected. Liberty, (not the aosp flavor), gingerbread (both rooted and non-rooted) and froyo (rooted and non-rooted) all function correctly. Anyone have any suggestions on how to correct this?

@scr34m1n6mu73
 
G

·
5cr34m1n6mu73 said:
When using cm4dx or aosp Liberty my 3g data connection fails to function even though it shows signal so I am unable to send or receive emails, get on the internet, etc but txt messenging and phone calls are uneffected. Liberty, (not the aosp flavor), gingerbread (both rooted and non-rooted) and froyo (rooted and non-rooted) all function correctly. Anyone have any suggestions on how to correct this?

@scr34m1n6mu73
Try flashing this while using CM4DX and see if it fixes your data issues. It's the .07 radio zip. A couple people have flashed it after flashing CM7 and have managed to fix any problems they were having. Since CM4DX uses the .07 radio anyway, you won't be harming anything (yes, I know it's flashing .07 over .07 :p).
 

·
Crack Flasher
Joined
·
423 Posts
Root Call Blocker was causing me to lose data connection. Had to toggle airplane mode to get it to connect. Maybe you have a bad app?
 

·
Android Apprentice
Joined
·
25 Posts
Discussion Starter · #4 ·
xmike said:
Root Call Blocker was causing me to lose data connection. Had to toggle airplane mode to get it to connect. Maybe you have a bad app?
Hmm I do use root call blocker, I wonder...

@scr34m1n6mu73
 

·
Supporting Member
Joined
·
88 Posts
i use root call blocker but have only had a 3G problem since flashing cm7, but even then, all i have to do is turn on wifi and then turn it off and 3G works again.
i don't think many people with dx on cm7 have the problem; haven't seen it discussed much.
 

·
Android Beginner
Joined
·
12 Posts
I was having this problem also. Especially coming off of wifi. Check in your wireless network settings. Click mobile networks and see if your data enabled box is selected. Seemed to work for me unless I flash a nightly.
 
1 - 8 of 8 Posts
Top