Android OS Forum banner
1 - 9 of 9 Posts

·
Android Beginner
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi everyone,
i have encountered a problem with my htc glacier (Tmobile mytouch4G) and was hoping maybe somone could help or point me in the right direction. Here is some info and what is happening. I got a new mytouch4g through insurance and wanted to root and sim unlock it, as i already have a perfectly working (rooted with s-off) mytouch4g. When i got the new one, i rooted it using the gfree method and everything worked out great. Had my s-off and sim unlock. Everything was working fine for a few weeks and then i flashed a CM nightly to update from a previous version, and the phone started bootlooping. I thought, ok, not a problem, been through this before. So i figure let me get back to cwr, I'll wipe and reflash. I was able to get into cwr, but as soon as i did, i got the following message:
E: can't mount cache (or something along those lines). Everytime i tried to do something in cwr, i always got that message. Couldnt wipe the phone, couldnt flash anything, nothing. I tried to factory reset through the bootloader, and that let me do it, but when i rebooted i was stuck back in a bootloop again. Tried to go back to cwr, and got the same message. so now i figure, ok let me reflash the 2.2.1 image through the bootloader and ill start from scratch all over again. When i got into the bootloader again to do that, it read the image and began the update. at step 2 (i believe it has something to do with the data partition), it said "failed pu" or something along those lines. Everytime i tried to flash that image, i always got the same error. I think something may be wrong with my data partition but i am not exactly sure. I am not a noob per say, but i am also not advanced as some users may be. I am familiar with how to root ( ive done it to a ton of devices) as well as how to use adb. I have that setup at work and home. i also do not have the part7 backup that gfree automatically creates. my sdcard that it was on failed and i wasnt able to pull anything from it. As of now here is where i stand:

1. CM nightly on phone (had no issues flashing any other versions and all were running fine)
2. cwr on phone. can access recovery (so i dont think im totally bricked hopefully) but keep getting an error message any time i try to execute any command.
3. flashing 2.2.1 image from bootloader does not work and gives me an error message when it gets to the data partition point (Step 2)
4. phone now does not go past splash screen when turned on.

any and all help would be greatly appreciated. this is the first time ive ever encountered a problem like this. usually i am able to work through my issues with research and digging around, but i havent been able to find anything that can help me, so im hoping someone from this wonderful site will be able to. I thank you in advance and if you need any other info or whatever please let me know. id like to hopefully fix the phone if possible. Thanks again and also btw, this type of forum is an awesome idea and kudos to the creative minds that thought it up :^)
 

·
I just hide here
Joined
·
2,237 Posts
Thanks again and also btw, this type of forum is an awesome idea and kudos to the creative minds that thought it up :^)
U can thank our fearless leader b16 for this subforum :-D lol. glad its here so we can help out people in these situations.

Now was 2.2.1 the version you were on before? Im not a HTC person. but i have had problems flashing SBF's for moto phones. That failed because i was using the wrong one. What utility are you using to flash through the bootloader? and also have you used that particular 2.2.1 file to flash through the bootloader before? And did it work before?
 

·
Android Apprentice
Joined
·
20 Posts
Maybe your SD card has become corrupted. Make sure your phone if completely powered down, place it in a card reader copy contents to your computor, reformat FAT32, reload contents. Good luck.

P.S. There is a SD card standards site that that had a low level formatting tool that might fix a corrupted card.

Sent from my Inspire 4G using RootzWiki Forums
 

·
Android Beginner
Joined
·
17 Posts
vinylfreak89 said:
try booting in to fastboot, then type "fastboot flash erase data" and "fastboot flash erase cache". then try to reflash the RUU. if that doesn't work, you may have a damaged EMMC.
ok I'm having a similar problem, can't get my MT4g to go into recovery from bootloader screen or RM, how do I get to fastboot in adb to type those commands in?
 

·
Android Apprentice
Joined
·
11 Posts
OldManRiver said:
ok I'm having a similar problem, can't get my MT4g to go into recovery from bootloader screen or RM, how do I get to fastboot in adb to type those commands in?
I would flash a new recovery - get the recovery for your phone and from command/terminal

fastboot flash recovery nameofrecovery.img

Then you should be able to get into hboot and then select recovery

Then you will have a recovery
 

·
Developer
Joined
·
140 Posts
OldManRiver said:
ok I'm having a similar problem, can't get my MT4g to go into recovery from bootloader screen or RM, how do I get to fastboot in adb to type those commands in?
run fastboot commands from inside the bootloader. make sure it says fastboot usb

Sent from my ADR6400L using Tapatalk
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top