Android OS Forum banner
1 - 5 of 5 Posts

·
Android Beginner
Joined
·
1 Posts
Sorry I post this here but there's no Sony Ericsson thread and I'm into a huge mess.

My xperia X10 is not answering to anything, when I turn it on it just displays the "sony ericsson" white letters and nothing more, I was trying to install a rom via xrecovery but I got the error "Cant unmount SD" and when I rebooted I got surprised by this.

Any help??

Thanx
 

·
Average Android
Joined
·
74 Posts
I am not familiar with Sony but if you can get into recovery... then try a wipe and see what happens. It works.with.some Roms that I ran on my Galaxy Tab.
 

·
Android Beginner
Joined
·
1 Posts
Most likely your rom didn't flash correctly. Don't panic though! If you can access xrecovery you can try to flash another one or restore the phone to factory settings with the Sony Ericsson Pc Companion (http://www.sonyericsson.com/cws/sup...subject/pccompanion/xperiax10mini?cc=gb&lc=en)

Unfortunately you need a windows machine to do this

Once you open the program click on Support Zone > Phone Software Update then it will tell you that it cannot find the phone, click on repair phone and follow the on screen instructions (they basically make you press the back button while the phone is off and connect the usb, this puts the xperia in flash mode)

If you're a more advanced user you can also use the FlashTool application that you can find on the xda forum (http://forum.xda-developers.com/showthread.php?t=920746)

Good luck!
 
1 - 5 of 5 Posts
Top