Android OS Forum banner
1 - 20 of 168 Posts

·
Premium Member
Joined
·
909 Posts
Here I want to track the state of the AVRCP 1.3 / MAP implementation.

Please enter your setup in the linked Google Docs Form: here

Music apps verified to work (as of b33 ml-2):
  • Android Stock Music App / Google Play Music
  • Winamp
  • Player Pro
  • Amazon Music App
  • PowerAmp (enable scrobbling in the settings)
  • BeyondPod (using Scrobble Droid api)
  • BubbleUPnP (using Scrobble Droid api)
  • MortPlayer (using Scrobble Droid api)
  • Doubletwist (enable Last.fm scrobbling)
  • Anything that supports "Last.fm" scrobbling
  • Anything that supports "A simple last.fm scrobbler" scrobbling
  • Anything that supports "Scrobble Droid" scrobbling
The following music players *MAY* work:
  • HTC Music App
  • MIUI Music App
  • Sony Ericson Music App
  • Samsung Music App
  • Rhapsody
The following will *NOT* work as they dont send the events with the meta data:
  • N7 Player
  • Audiogalaxy
  • Pandora
  • DoggCatcher
  • RDIO
Track time is not supported (same for the CM9 implementation).

Test builds: http://db.tt/iYTPO5Sr

Please try to get a logcat if you run into issues. A good app is aLogcat from the market. Then paste it on http://logcat.aokp.co/

Marc
 

·
Premium Member
Joined
·
909 Posts
Discussion Starter · #4 ·
New builds are up that have some more logging.

I also added Doubletwist for real this time - no idea how some of you got it working


Please post your logcat to pastebin.com to help me track down any problems.
 

·
Android Beginner
Joined
·
42 Posts
Still the save behavior for me.

Only audio i get through BT it's through stock player.

In the log, i played the stock player, then poweramp, then Google Play Music, then the stock player again.

Hope this helps getting it working.

http://pastebin.com/vN7AzkQy

Sent from my Galaxy Nexus using Tapatalk 2
 

·
Premium Member
Joined
·
909 Posts
Still the save behavior for me.

Only audio i get through BT it's through stock player.

In the log, i played the stock player, then poweramp, then Google Play Music, then the stock player again.

Hope this helps getting it working.

http://pastebin.com/vN7AzkQy

Sent from my Galaxy Nexus using Tapatalk 2
Did you enable scrobbling in the poweramp settings? Or do you see the info and you just have no audio?
 

·
Android Beginner
Joined
·
42 Posts
Did you enable scrobbling in the poweramp settings? Or do you see the info and you just have no audio?
Only info i receive is from the stock player. When i switch players i get a blank screen.

Scrobbling was not enabled. Should i try?
Sent from my Galaxy Nexus using Tapatalk 2
 

·
Premium Member
Joined
·
909 Posts
Discussion Starter · #8 ·
Only info i receive is from the stock player. When i switch players i get a blank screen.

Scrobbling was not enabled. Should i try?
Sent from my Galaxy Nexus using Tapatalk 2
yes - you have to enable it to get poweramp send the meta data.
 

·
Premium Member
Joined
·
909 Posts
Discussion Starter · #9 ·
build 32 ml4 is ready to be tested.

I added support for players that send their meta data through the scrobble droid api. See the first post what I already tested.
 

·
Android Beginner
Joined
·
42 Posts
build 32 ml4 is ready to be tested.

I added support for players that send their meta data through the scrobble droid api. See the first post what I already tested.
I will try new build with Scrobbling enabled.

Sent from my Galaxy Nexus using Tapatalk 2
 

·
Registered
Joined
·
110 Posts
turned on scrobbing in playerpro and it works!!!

the only thing, is, my signal bars are always gray on this build. they never go blue. so is my phone not registered to sync on the network or something
 

·
Android Entropy
Joined
·
112 Posts
turned on scrobbing in playerpro and it works!!!

the only thing, is, my signal bars are always gray on this build. they never go blue. so is my phone not registered to sync on the network or something
Strange, maybe try opening the Play Store? That might connect you to Google's servers (which is what causes the bars to go blue).
 

·
Registered
Joined
·
110 Posts
well i am not sure what i did, but i got it all working haha. i messed around with settings here and there and boom, im good.
 

·
Registered
Joined
·
182 Posts
I still cannot get this working. I'm on AOKP 32 Galaxy Nexus. I own a compatible Double Dun unit in my car. I'm using Player Pro srobbling through simple scrobbler.

Ideas?
 

·
Premium Member
Joined
·
909 Posts
I am really happy that this works better now. Can someone who uses Player Pro post a logcat export on patebin.com? I want to verify something.

I am aware of the issue with doubletwist rebooting the phone and will try to hunt down the root cause.
 
1 - 20 of 168 Posts
Top