Android OS Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
33 Posts
Discussion Starter · #1 ·
Hello All,

I have forked AOKP's (and PipelinerArd from xda) AOKP build - to build on my phone. I have successfully built it ONLY ONCE. I am currently running that build on my phone, and it's awesome and smooth. But now, I cannot build at all, as I always get this at the end of the build (looks like it's just echoing the build script), which just stops the build and drops me to the terminal prompt:
Code:
<br />
LD [M] drivers/net/wireless/bcmdhd/bcmdhd.ko<br />
make[1]: Leaving directory `/home/martin/SchutzhundAOKP/kernel/htc/KangBanged-7x30'<br />
make -C kernel/htc/KangBanged-7x30 O=/home/martin/SchutzhundAOKP/out/target/product/ace/obj/KERNEL_OBJ INSTALL_MOD_PATH=../../system ARCH=arm CROSS_COMPILE="/home/martin/SchutzhundAOKP/prebuilts/misc/linux-x86/ccache/ccache /home/martin/SchutzhundAOKP/prebuilt/linux-x86/toolchain/arm-eabi-4.7/bin/arm-eabi-" modules_install<br />
make[1]: Entering directory `/home/martin/SchutzhundAOKP/kernel/htc/KangBanged-7x30'<br />
INSTALL drivers/net/wireless/bcmdhd/bcmdhd.ko<br />
INSTALL drivers/scsi/scsi_wait_scan.ko<br />
DEPMOD 3.0.69KangBang-Kernel-gd621d2f<br />
make[1]: Leaving directory `/home/martin/SchutzhundAOKP/kernel/htc/KangBanged-7x30'<br />
mdpath=`find /home/martin/SchutzhundAOKP/out/target/product/ace/system/lib/modules -type f -name modules.order`; if [ "$mdpath" != "" ];then mpath=`dirname $mdpath`; ko=`find $mpath/kernel -type f -name *.ko`; for i in $ko; do /home/martin/SchutzhundAOKP/prebuilts/gcc/linux-x86/arm/arm-eabi-4.6/bin/arm-eabi-strip --strip-unneeded $i; mv $i /home/martin/SchutzhundAOKP/out/target/product/ace/system/lib/modules/; done; fi<br />
mdpath=`find /home/martin/SchutzhundAOKP/out/target/product/ace/system/lib/modules -type f -name modules.order`; if [ "$mdpath" != "" ];then mpath=`dirname $mdpath`; rm -rf $mpath; fi<br />
[email protected]:~/SchutzhundAOKP$<br />
I can, however, build CM 10.1 fine (I've tried multiple times to build CM to see if it was my build environment that was at fault, and CM builds every time, so that's not the issue.)

So I've tried to make this work by adding the kernel_manifest (and support file "manual_add_kernel_manifest.sh") per AOKP's git repo's readme, and that "repo sync" is fine. Everything syncs perfect, but again, I get that "error" at the end of every "mka bacon".

History:
Anyway - after my first and only time building successfully, I tried to pull some Cyanogenmod's MMS repos (as tests to see if I could), as well as try to add in Proximity Recalibrater as a Prebuilt, into my build. And since then, I haven't been able to build at all anymore. I've even "rm -rf" my sokp folder, and started fresh, but I still get that same issue that happens, no build and that kernel stuff dumped to terminal before it ends.

So - since I still can build CM every time (and they boot up on my phone lol), it has to be something really stupid I'm doing with my aokp stuff... So, what's your thoughts?
 

·
Registered
Joined
·
33 Posts
Discussion Starter · #3 ·
Builds have failed once again (due to repos being taken down/changed). So I've pulled from AOKP and HTC Ace device-specific repos (CM and such), but I get this error on build:
Code:
<br />
/home/espmartin/SchutzhundAOKP/out/host/linux-x86/bin/acp -fp /home/espmartin/SchutzhundAOKP/out/target/product/ace/obj/lib/libOmxCore.so /home/espmartin/SchutzhundAOKP/out/target/product/ace/system/lib/libOmxCore.so<br />
make: *** No rule to make target `/home/espmartin/SchutzhundAOKP/out/target/product/ace/obj/SHARED_LIBRARIES/libgenlock_intermediates/export_includes', needed by `/home/espmartin/SchutzhundAOKP/out/target/product/ace/obj/SHARED_LIBRARIES/libOmxVdec_intermediates/import_includes'.  Stop.<br />
Any thoughts?
 

·
Registered
Joined
·
33 Posts
Discussion Starter · #5 ·
I just wanted to update this thread with new details:

I have completely redone my AOKP build on ace. Everything pulls from source, and my own customizations, as well as cherry-picks, are done to my forked repos. It has been a real learning experience, but I am glad that I had all those initial build errors, because I have been forced to learn how to "fix" things by hand....

My build is complete and very fast :) I will be posting it here on RootzWiki soon!
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top