Android OS Forum banner
1 - 20 of 43 Posts

·
Smartass in Chief
Joined
·
1,318 Posts
Discussion Starter · #1 ·
Someone asked in the CM9 Development thread about starting a new discussion thread for the CM10 JB port JT started on. I didn't see anyone start one, so here it is. Use this to thread to discuss anything about the CM10 JB port in order to keep the development thread strictly to actual development issues, discussion, etc.
 
  • Like
Reactions: jco23 and Aquila76

·
Registered
Joined
·
253 Posts
thanks - i would have started, but I'm the furthest thing from a developer, so I did not feel comfortable starting a thread in the development section on JB.

but linked below is the ported JB for the charge (thanks to JT):

USE AT YOUR OWN RISK - I (AND NOBODY ELSE ON THIS PLANET) IS RESPONSIBLE FOR WHAT YOU DO TO YOUR PHONE.

http://www.mediafire...jzjop6b8lo2iphp
google apps: http://d-h.st/rDK

instructions for installation (thanks to Orionis) are:

  • Copy ROM and GApps to your sdcard
  • Boot into clockworkmod recovery
  • WIPE DATA
  • Flash ROM zip
  • Go to "mounts and storage" and mount system
  • Flash GApps
  • Reboot
  • you'll probably boot loop at the animation screen - from that point, simply perform a battery pull, then boot back into CWM (will be version 6.x), mount system, wipe cache/dalvik, flash ROM, mount system again, flash gapps, reboot (thanks to unleeshd)
wifi did work, but camera, phone, mobile data did NOT work. the system was a bit laggy, but I really did not give it all that much time to play around with it.

good luck to all!
 

·
Registered
Joined
·
7 Posts
If you restart the phone after running it for the first time the lag is gone. Also, to get signal bars to appear you have cycle lte and lte/cdma options for it to show.

Sent from my SCH-I510 using RootzWiki
 

·
Registered
Joined
·
253 Posts
Probably so, but I tried that and could not get it to work for me.
I did NOT try it with fp5 though, so wondering if that could make a difference.

tappin' that....
 

·
Android Army/Themer
Joined
·
235 Posts
Someone asked in the CM9 Development thread about starting a new discussion thread for the CM10 JB port JT started on. I didn't see anyone start one, so here it is. Use this to thread to discuss anything about the CM10 JB port in order to keep the development thread strictly to actual development issues, discussion, etc.
Thank you.

My inner demons and I have come to an agreement.
 

·
Registered
Joined
·
47 Posts
Probably so, but I tried that and could not get it to work for me.
I did NOT try it with fp5 though, so wondering if that could make a difference.

tappin' that....
It works just fine with FP1. Make sure you cycle between "CDMA only" and whatever the initial option is. Don't mess with the 2 top options as I do not think they help you out in booting your radios. Hope this helps!
 

·
Android Army/Themer
Joined
·
235 Posts

·
Registered
Joined
·
18 Posts
found this looking for RIL maybe it will help maybe not. http://pastebin.com/uHPCJXdJ
Unfortunately this doesn't help much. This just looks like some kind of library 'manifest'. The RIL requires really 2 things. One the binary radio files from Samsung (and / or Open Source RIL drivers), and the Android interface which is written in some form of Java. They might be able to take the binaries from the Nexus radio as they are very similar as far as the architecture/model. Might. Even if we get those working significant work will still have to be done to 'translate' the 'calls' to the radio for Android itself. Not a small job and unfortunately not many developers capable of doing it.

It's times like these that I wish I knew a lot more about kernel hacking and Java.
 

·
Android Beginner
Joined
·
20 Posts
Any suggestions, got stuck in boot loop and I can't get back into cwm recovery. Tried pulling battery and volume up + power + home and keeps going through boot loop.
 

·
Registered
Joined
·
253 Posts
might have to odin CWM again (unless you are not releasing the power button after seeing the samsung logo).

did you re-install the ROM again via CWM?
 

·
Registered
Joined
·
47 Posts
Any suggestions, got stuck in boot loop and I can't get back into cwm recovery. Tried pulling battery and volume up + power + home and keeps going through boot loop.
I assume you were giving up on booting into recovery as soon as you saw the Galaxy S boot screen after the Samsung. You should keep the Volume Down & Home button pressed until it boots into recovery, because it will show 2 boot images, which may throw you off. But if this still doesn't work, you should re-flash the latest Charge recovery. Then try re-installing.
 

·
Android Army/Themer
Joined
·
235 Posts
Code: github.com/ius/samsung_h1_libmsm Can someone take a look at this someone else was trying to reverse the ril ,I dont know enough to say this will or will not help.
 

·
Registered
Joined
·
6 Posts
Flashed per instructions could not get data too come on...soooooo I proceeded too create a nandroid backup of cm-9.
It was at the very end and failed too complete. Soooooo I just went ahead and tried to restore my nandroid backup of
Eclipse 2.0 it ran thru smooth then BOOT LOOP FROM HELL will not let me boot into recovery all I get is Sammy splash screen then
Galaxy s cyanogen mod splash screen....
What do I do??? Oden a new recovery ???or do I have too Odin a whole package plus tar.
Please let me know
 

·
most interesting mutha$@&*# in android
Joined
·
122 Posts
Start from scratch. There is a stock FP5 file to be flashed with Odin floating around

Sent from my SCH-I510 using RootzWiki
 

·
Android Apprentice
Joined
·
285 Posts
Flashed per instructions could not get data too come on...soooooo I proceeded too create a nandroid backup of cm-9.
It was at the very end and failed too complete. Soooooo I just went ahead and tried to restore my nandroid backup of
Eclipse 2.0 it ran thru smooth then BOOT LOOP FROM HELL will not let me boot into recovery all I get is Sammy splash screen then
Galaxy s cyanogen mod splash screen....
What do I do??? Oden a new recovery ???or do I have too Odin a whole package plus tar.
Please let me know
You have to reflash your CWM because the one that comes with CM10(and CM9) won't work with GB ROMs.

Sent from my Galaxy Nexus using RootzWiki
 
1 - 20 of 43 Posts
Top