Android OS Forum banner

1 - 14 of 14 Posts

·
Android Apprentice
Joined
·
27 Posts
Discussion Starter · #1 ·
So I got thru all the steps to root and install CM7 on my DX. But now my phone is stuck looping the CM& logo animation! This is my first time rooting and I've no idea how to fix this. Any help would be hugely appreciated.
 

·
Sourcerizer
Joined
·
819 Posts
choonami said:
So I got thru all the steps to root and install CM7 on my DX. But now my phone is stuck looping the CM& logo animation! This is my first time rooting and I've no idea how to fix this. Any help would be hugely appreciated.
My first suggestion would be boot into standard recovery and wipe data
-turn phone off
-hold home button while pressing power
-once it starts up, you can release power
-You'll see an android guy with an exclamation mark
-Press both volume keys at the same time
-use volume keys to move cursor and select "wipe data/cache factory reset" (can't remember exact wording)
-press the power button to select that choice
-you'll be presented with a list of no's with one yes. use volume keys to select yes, then use power button to confirm
-let it do it's thing, then you'll be back at the first menu
-select restart phone, and use power button to confirm

If that doesn't work, you'll have to sbf back to froyo, root with z4root, install droid 2 bootstrap, and try installing cm7 again.

good luck.

PS. If you do have to sbf and start again, make sure you follow the install steps for cm7 step by step, it's easy to forget to format something, or forget to mount system...
 

·
Android Apprentice
Joined
·
27 Posts
Discussion Starter · #4 ·
Okay new issues; CM7 is running! But now the market isn't working and the gmail app is missing. I ran the gapp zip file to no avail. Any thoughts?
 

·
Sourcerizer
Joined
·
819 Posts
choonami said:
Okay new issues; CM7 is running! But now the market isn't working and the gmail app is missing. I ran the gapp zip file to no avail. Any thoughts?
depends what you mean by "market isn't working" Does it force close on you? Does it just open then immediately close?

Gmail needs to be downloaded from the market. So you'll need that fixed first. Since you're up and running (kind of), you can reboot into recovery (press power button and select restart, then recovery), and install cm7 and gapps again. Since you're not set up yet, you've got nothing to loose but 10 minutes..

In recovery, I'd go to mounts and storage and format system, data, cache, dalvik, then mount system and then install the cm zips.
 

·
Android Apprentice
Joined
·
27 Posts
Discussion Starter · #6 ·
It says theres no valid account attached, but in accounts its showing my gmail. I'm going thru the steps you mentioned. will update this.
 

·
Android Apprentice
Joined
·
27 Posts
Discussion Starter · #7 ·
Okay I ran thru everything you listed, reinstalled cm7 and gapps. but the market keeps closing itself. I run it, says Loading, then just closes. thats where I'm at now.
 

·
Sourcerizer
Joined
·
819 Posts
"choonami said:
Okay I ran thru everything you listed, reinstalled cm7 and gapps. but the market keeps closing itself. I run it, says Loading, then just closes. thats where I'm at now.
Now you got me stumped, i remember having a similar issue, but after trying to open it like 4 times it just strayed working.

Only suggestion I can think of its go to settings - applications - find market, and delete data for it, then if the option is available, force close it. Then try again.
 

·
I just hide here
Joined
·
2,237 Posts
choonami said:
Okay I ran thru everything you listed, reinstalled cm7 and gapps. but the market keeps closing itself. I run it, says Loading, then just closes. thats where I'm at now.
Also goto rom manager, and goto download rom, and choose google apps and download then newest gapps off of there. and see if it works. if not u could try out the newest market that was just released. you can find it here http://rootzwiki.com/showthread.php?1370-APP-New-Vending.apk. And lastly do u have titanium backup?
 

·
Android Apprentice
Joined
·
27 Posts
Discussion Starter · #11 ·
Okay I'm not sure what happened, but I went thru ROM Manager, accidentally clicked the Rate button, and the Market started working! Also downloaded Gmail and got it to finally sync my google account. Thanks for the help guys!
 

·
I just hide here
Joined
·
2,237 Posts
lol np man. glad it somehow worked...but u can still follow that link i sent u to get the new market if u want it. its pretty neat. eventually it will automatically roll out to ur phone anyway tho.
 
1 - 14 of 14 Posts
Top