Android OS Forum banner
1 - 15 of 15 Posts

·
Android Beginner
Joined
·
86 Posts
Hey everyone, I've noticed a lot of people seem to have similar problems with the latest CM9 update (and possibly in other areas too), and I would like to get a good FAQ going for new users and those who don't want to wade through nearly 4000 posts.

The main recurring questions I have found popping up in the thread include (but are certainly not limited to):
[hide='Does the camera work?']Yes. It does. Thank Jonman409.[/hide]
[hide='Why can I only take 5MP pictures? The back of my phone clearly says it's 8MP']You're right, the DX is capable of 8MP, but the Moto Gapps camera only can handle going up to 5MP. There is a fix mentioned here if 5MP isn't high enough for ya.[/hide]
[hide='What about the camera's flash?']The camera flash isn't working. On the other hand, the torch does work. Turn torch on, take your picture, and then turn it back off.[/hide]
[hide='Why won't my MMS send?']Good question. Appears to be a missing setting in CM9 APNs that can be easily re-added.
To generate the missing setting, go to:
Code:
System Settings => Wireless & Networks => More... => Mobile Networks => Access Point Names
and add the following:

Verizon US
  • Name: Verizon
  • APN: internet
  • Proxy:
  • Port:
  • Username:
  • Password:
  • Server:
  • MMSC: http://mms.vtext.com/servlets/mms
  • MMS Proxy:
  • MMS Port:
  • MCC:
  • MNC:
  • Authentication type:
  • APN Type:
Then save and reboot.

Also, GoSMS has been suggested as an alternative to the stock SMS app, but some reports suggest Handcent is broken.

source[/hide]
[hide='Multitouch seems sluggish...']source[/hide]
[hide='How do I stop the data usage warnings?']
  1. Use Root Explorer to navigate to /data/system/
  2. Open netpolicy.xml in a text editor.
  3. Change the warningBytes number to anything higher than it is right now (recommended: just add a 0 to the end)
  4. Save and delete the backup
  5. Reboot
source[/hide]
[hide='My Chrome Browser isn't working, what should I do?']As mentioned in the OP, Chrome browser is broken for now, the devs are aware and working on it. Your best option is to simply try a different browser.[/hide]
[hide='Does HDMI audio work? or My HDMI audio doesn't work']HDMI audio isn't currently implemented, though video works, and an audio workaround has been found.
source[/hide]
[hide='Are all of the settings supposed to be working?']Well of course they're all supposed to be working BUT...
Settings->Theme not enabled as of yet.
Settings->System->Lock Screen options not implemented yet
Settings->System->Status Bar->Alternate signal display options do not work
Settings->Battery Stats not reporting app usage

Thanks bobcaruso[/hide]
[hide='What ROM and Gapps should I use?']CM9 3.19 Release with 3.17 ICS-Gapps from http://goo-inside.me/gapps is the crowd favorite
source[/hide]
[hide='What OC tool should I use for stable OCing?]QuickClock Advanced [URL="http://rootzwiki.com/topic/18589-cyanogenmod-9-unofficial-beta/page__view__findpost__p__563308"]source[/URL]
Android Overclock (AOC) works as well but it doesn't find stable levels. [URL="http://rootzwiki.com/topic/18589-cyanogenmod-9-unofficial-beta/page__view__findpost__p__563404"]source[/URL][/hide]
[hide='My YouTubes are running poorly, what should I do?']Try setting YouTube to use high quality video. Seems to fix the problem.
source[/hide]
[hide='What should I wipe? Data? Cache?']It is always safer to wipe data/factory reset to prevent the most errors. That being said, some people have good results wiping just cache ONLY when coming from other CM9 builds released by x13thangelx. Wiping data will clear pretty much everything not on your SD card, so don't forget to backup anything you'll miss (I recommend making several Nandroid backups as you progress through your ROM-flashing career.[/hide]
[hide='Why does my phone battery jump from 70% to 40%?']
...Its a problem with 1% battery. Try letting your battery discharge all the way down then charge up. Fixed it for me.
This is not a guaranteed fix, and it is typically only a problem on older batteries. Consider investing the $4 for a new one on Amazon (thanks for the tip JagoX).
source[/hide]
[hide='How do I get into CWM Recovery/Stock Recovery']Stock recovery can be accessed by holding down the home and power buttons while booting. CWM Recovery should be accessible under the power menu => reboot => recovery. If not, using ROM Manager, flash the 2nd-init CWM recovery and try rebooting through ROM Manager (please someone else confirm this).[/hide]
[hide='Does this ROM work with BootManager']I have heard mixed reviews about BootManager compatibility, but rumor has it that this ROM can work, and some people have had success with things like SMS syncing, with little to no direct intervention, while others haven't.[/hide]
[hide='My bluetooth/speakerphone sound bad. What should I do?']Coming soon. From what I've heard there's not currently a workaround for this, but the issue is known and being investigated.[/hide]
[hide='What's all this I've been hearing about Gummy ROM on the DX? Or, What about (error) on Gummy?']This thread is for x13thangelx's CM9 build, not Gummy, for questions on that I suggest this thread.[/hide]
[hide='What about (other bug)?']Try checking the Google Doc bug list here, but I can't guarantee it will be an easy read. Gets a little chaotic at times, and should be updated to only show bugs/workarounds from the latest build, moving old ones to the bottom, out of the way. Just sayin
[/hide]
[hide='Who should I thank?'] x13thangelx, Jonman409, INt_Rnd_Pooka, and the entire rest of the RootzWiki community for helping keep the DX futureproof. This is by far one of the best and most helpful ROM communities.[/hide]

Don't hesitate to ask questions if there's something you don't understand, I know I've asked plenty. I'm sure there are more questions out there, and I would like to get as many covered as possible in this post so that I have less (spam?) to read through each afternoon. Any feedback is appreciated. PM me, or just post in here if there's a question you think should be included. I am in no way an expert, so if you think something is incorrect in my post, let me know, I'll fix it for you.

-Matt
 

·
Android Beginner
Joined
·
86 Posts
Discussion Starter · #5 ·
The MMS APN fix doesn't work for me, neither does goSMS. Any other suggestions for what the problem could be? Also tried *228+ activation.
I'm not sure what to suggest, the APN fix worked flawlessly for me after I rebooted. My current best suggestion would be to back up your stuff, re-download 3/19 and the 3/13 gapps, check the MD5s for safety's sake, reflash the rom and try again... Something must have gone funky on your install...
 

·
OMGWTFBBQ!
Joined
·
190 Posts
...Its a problem with 1% battery. Try letting your battery discharge all the way down then charge up. Fixed it for me.
The discharge/recharge thing doesn't always work. I did that multiple times on different ROMS and it did nothing. I ended up buying another battery ($4.00) from Amazon and I'm now I get the proper 1% drop without the skip.
 

·
Android Beginner
Joined
·
86 Posts
Discussion Starter · #7 ·
The discharge/recharge thing doesn't always work. I did that multiple times on different ROMS and it did nothing. I ended up buying another battery ($4.00) from Amazon and I'm now I get the proper 1% drop without the skip.
Fixed to include your suggestion
 

·
Registered
Joined
·
38 Posts
You wouldn't happen to be on a carrier other than Verizon,would you? Naturally, they'd have different MMS settings.
I'm on Verizon. Also tried redownloading and reflashing. I still can't send or download received MMS. GoSMS works using its web upload thing, but in that case I might as well email it. Everything else is great, including battery life.
 

·
Registered
Joined
·
164 Posts
I'm on Verizon. Also tried redownloading and reflashing. I still can't send or download received MMS. GoSMS works using its web upload thing, but in that case I might as well email it. Everything else is great, including battery life.
Something missing above, or at least, I didn't see it when I checked, is that after adding the APN, you have to activate it. Once added it'll show up in the APNs list, you need to click on the dot to make sure it's lit up. Oddly, I can't seem to uncheck mine now, but I think that might be what you're missing?
 

·
Registered
Joined
·
38 Posts
Something missing above, or at least, I didn't see it when I checked, is that after adding the APN, you have to activate it. Once added it'll show up in the APNs list, you need to click on the dot to make sure it's lit up. Oddly, I can't seem to uncheck mine now, but I think that might be what you're missing?
Thanks for the suggestion, but I did that, too. Does anyone know if gummy has the MMS problem?

Edit: Switched to gummy, no more MMS problem.
 

·
Registered
Joined
·
1 Posts
Thanks for the suggestion, but I did that, too. Does anyone know if gummy has the MMS problem?

Edit: Switched to gummy, no more MMS problem.
I had used gummyNex for about 3 weeks, but could never get mms to send or recieve. I'm currently on the cricket netwrk, and ive tried just about everything: apn backuprestore and a custom xml file to restore with "proper" settings, editing the settings myself, and numerous re-flashings of these roms and gapps, all with no luck. i believe once i managed to recieve a picture, but that was before my phone was even activated on the network.

Info:
model: Droid X
(it took the ota long ago, rooted it by sbf-ing to milestone X)
CM version: 9-20120809-UNOFFICIAL-shadow
gapps: gapps-ics-20120429-signed.

android version 4.0.4

i had a gb-based rom, steeldroid, and the mms would work. however, it was heavy, and camera would crash. real big fan of these ics-based roms, and im hoping to find a fix soon.
 

·
Part-time Noob Dev
Joined
·
157 Posts
I had used gummyNex for about 3 weeks, but could never get mms to send or recieve. I'm currently on the cricket netwrk, and ive tried just about everything: apn backuprestore and a custom xml file to restore with "proper" settings, editing the settings myself, and numerous re-flashings of these roms and gapps, all with no luck. i believe once i managed to recieve a picture, but that was before my phone was even activated on the network.

Info:
model: Droid X
(it took the ota long ago, rooted it by sbf-ing to milestone X)
CM version: 9-20120809-UNOFFICIAL-shadow
gapps: gapps-ics-20120429-signed.

android version 4.0.4

i had a gb-based rom, steeldroid, and the mms would work. however, it was heavy, and camera would crash. real big fan of these ics-based roms, and im hoping to find a fix soon.
Try this
http://www.cricketusers.com/verizon-motorola-droid-x/12264-working-apn-mms-apk.html
 

·
Registered
Joined
·
8 Posts
The reason this rom is not working on MMS is because the settings are hard coded in the build.prop file. If you set the numeric values in the build.prop, your mms will work fine, and even show up in the APN settings page. I finally got this working yesterday, and I am on nTelos.

In my case, I changed this value:
ro.cdma.home.operator.numeric=31047 (It is actually in the build.prop in two different places for some reason)

This is a combined MCC and MNC value.
MCC = 310
MNC = 47

Hence, the numeric value. You can also change your network id and many other things in the build.prop as well.
 
1 - 15 of 15 Posts
Top