Android OS Forum banner

1 - 20 of 23 Posts

·
Premium Member
Joined
·
164 Posts
Ok i dont know if this would be the section for this. If its not will a mod please move it. Im currently trying to push out my next release of Fang. But i did a edit to the update-script and now when i try to flash my ROM via CWR i get this:

---Installing: /sdcard/Fang-Beta3.zip
Finding update package...
Opening update package...
Installing update package...
E: Error in /sdcard/Fang-Beta3.zip
(Status 6)
Installation aborted.
I:Set boot command "boot-recovery"

I ran the Log VIA CWR and this is what came up.

Finding update package...
Opening update package...
Installing update package...line 10 col 28: syntax error. unexpected STRING,
expecting '.' or ')'
1 parse error
E: Error in /sdcard/Fang-Beta3.zip
(Status 6)
Installation aborted.
mtd: successfully wrote block at 0
I:Set boot command ""

ANY DEV able to help me? It would be GREATLY appreciated.

Wolf
 

·
Android Lover
Joined
·
1,260 Posts
But most likely, your uiprint characters are causing the problem. Blank that line or just fill it with alpanumerics and see if the error disappears.
 

·
Premium Member
Joined
·
164 Posts
Discussion Starter · #6 ·
"Snow02 said:
Just go ahead and post the script as an attachment and I'll look at it.

You're not using ifelse by chance are you?
No I'm not using ifelse (I think, and I'm mobile now so I can link u the rom dl file if that would work?
 

·
Professional Stuff Breaker
Joined
·
1,402 Posts
It's definitely the ui_print lines. You can't have all those characters in there without causing trouble. If you're going for some sort of ASCII art, I'd recommend dropping it. People aren't going to see it anyways except for a few seconds.
 

·
Premium Member
Joined
·
164 Posts
Discussion Starter · #10 ·
"DrMacinyasha said:
It's definitely the ui_print lines. You can't have all those characters in there without causing trouble. If you're going for some sort of ASCII art, I'd recommend dropping it. People aren't going to see it anyways except for a few seconds.
Ok. Thanks ill try dropping some of it and see if that works
 

·
Premium Member
Joined
·
164 Posts
Discussion Starter · #12 ·
"DrMacinyasha said:
Also, if you're using update-script (amend) instead of updater-script and update-binary (edify), you've got a major problem.
On ubuntu how/what do I do to edit the update-binary?
 

·
Premium Member
Joined
·
164 Posts
Discussion Starter · #14 ·
"Snow02 said:
You don't. He's saying you need to make sure you're using edify syntax in your script.
Ah ok. I believe I am. I just did an edit from cm7s script looked at one that has ascii and put my lines in.
 

·
Premium Member
Joined
·
164 Posts
Discussion Starter · #16 ·
"DrMacinyasha said:
So in your /META-INF/com/google/android/ folder of your ZIP, you have an update-binary and updater-script file, correct?
Correct. If u want to look @ it I can link u the zip.
 

·
Professional Stuff Breaker
Joined
·
1,402 Posts
Sure, go ahead. There's a good amount of stuff in the CM updater-script that really shouldn't be used by other ROMs unless you're kanging 99.5% of their code and just adding in your own theme/apps/etc.
 

·
Premium Member
Joined
·
164 Posts
Discussion Starter · #18 ·
"DrMacinyasha said:
Sure, go ahead. There's a good amount of stuff in the CM updater-script that really shouldn't be used by other ROMs unless you're kanging 99.5% of their code and just adding in your own theme/apps/etc.
Www.magicmonkeystudios.com/android/wolf/roms its fang beta 3

And right now I am kanging a bit until I get more into what is needed. I'm hoping to branch off soon.
 
1 - 20 of 23 Posts
Top