Android OS Forum banner
1 - 2 of 2 Posts

68 Posts
Discussion Starter · #1 ·
i'm curious, how do you recompile? i just got my dev edition today and my first goal was to pull framework-res and remove the wifi tether entitlement check. decompile and making the edit was easy, but on recompile i got the following error:

invalid resource directory name: /xxx/framework-res/res/values-mcc310-mnc-1
if i remove the last dash (i.e. change to values-mcc310-mnc1), it works...but i still get a warning on recompile:

aapt: warning: string 'usb_charge_notification_title' has no default translation in /xxx/framework-res/res; found: da de el es fr nb nl pt sv tr zh_CN zh_TW
i pushed the new framework to the phone and so far, it seems to work...but does anyone have any idea what's up with the errors? is it something that will cause any issues? is there a way to resolve it and get a clean decompile/recompile? i've tried using both beta7 and beta8 (which came from the apktool thread, i guess it's not publicly available yet?)
1 - 2 of 2 Posts