Android OS Forum banner
1 - 20 of 394 Posts

· Developer
Joined
·
1,604 Posts
cvpcs said:
the D2 libaudio can't load because it can't resolve symbols. copy libaudio.so and ap_gain.bin from the DX proprietary repo (github.com/koush/proprietary_vendor_motorola) and try those.
Well that got it to boot, some FCs so far, haven't had a chance to test much else, lol... will report back once I have some better info
 

· Developer
Joined
·
1,604 Posts
tb110895 said:
When you report back, please tell what works and what doesn't work. Like, 3G/data, Wifi, GPS, etc. A lot of it probably doesn't work but it would still be nice to know
Made a pretty stupid mistake and am SBFing currently, but I called a buddy of mine to ::cough:: brag a bit... the mic on the phone itself doesn't work (which i understand is in the process of being fixed) but using bluetooth worked fine, can't verify wifi or 3g right now cuz I didn't try it, lol... although the 3g icon was blinking back and forth.
Once i get done with the SBF and reinstall I'll come back with a full list, but that's a start... oh and it's a bit odd but settings FCed everytime i tried to access it, however if you went in through other means (manage apps, or if another app called it) it seemed to work... anyway, I'll have a full list here in a bit, just thought I'd give a quick update for those wanting it
 

· Developer
Joined
·
1,604 Posts
tb110895 said:
Sweet! Care to share that .zip for others that want to test?

I'll help in any way I can, even if it is just flashing it and giving the info needed
just to make sure everybody knows, I take no credit for anything here, lol... i just implemented a change that was suggested, and replaced the Settings.apk that was in the original with one that I'd compiled... fixed the FC on settings
hehehe... anywho, I'm not sure how the devs that are hard at work would feel about me sharing it with the changes I've made, but if they are fine with it, or considering cvpcs just posted on twitter he may have audio working correctly (i'm assuming that means the mic on the phone itself) they may want to hold off... but otherwise I'd be happy to hand out my zip freely
oh and I should have a list in a couple minutes, i'm just finishing up testing a couple things
 

· Developer
Joined
·
1,604 Posts
OK here's what I've found so far.... right now as long as you use the libaudio.so and ap_gain.bin from the DX like cvpcs suggested things look pretty good... Settings force closes but that can be fixed by replacing Settings.apk with a freshly compiled one from CM-nightly... the mic on the phone isn't working but all other sound seems to be fine, and you can make calls through bluetooth... wifi is a bit flaky... I'll throw the logcat link at the end of this... 3G is working well, and as long as you remember to install the google apps all is well there too, lol.... I tried to get into recovery by holding down the power button choosing reboot, then recovery but (as i expected) that booted directly into moto's stock recovery, and when i installed droid2bootstrap and did a reboot from there, it pretty well killed everything, I couldn't get passed the (M) logo, lol.... So... boiled down here's what I've got

Data: 3g working fine
Wifi: kinda flaky, connects/disconnects/connects/etc...
Bluetooth: seems to be good... and the only way to make a call
Audio: Output is good with DX's libaudio,etc... Mic still not working
Google Apps, etc: Once Settings.apk is replaced all is well

Logcat from the flaky wifi:
http://pastebin.com/RukcRtij
 

· Developer
Joined
·
1,604 Posts
tb110895 said:
Is that settings.apk the same as the one included? because I know some of the nightlies didnt have CM settings included
I've got an entry for CM Settings under settings... so i assume it's good... I couldn't pull a copy of the D2 repo in the OP so i used what I already had... which was a copy of the nightly repo from a couple weeks or so ago... oh... and the Camera works as long as you change build.prop to reflect the 5m camera as opposed to the 8m the DX has
 

· Developer
Joined
·
1,604 Posts
seems I worked around the wifi issue by setting a static IP... can anyone else confirm?

Edit: and it also appears I have no GPS, lol
 

· Developer
Joined
·
1,604 Posts
i got a working camera on the build I'm running... just had to modify build.prop to reflect 5m camera instead of 8m
how'd you get GPS working? lol
 

· Developer
Joined
·
1,604 Posts
ebev said:
GPS was not working for me. I tried several different programs. So, I pulled the gps.droid2.so from the gingerbread leak and pushed it into /system/lib/hw/. GPS seems to be working fine for me now.

Edit: I used Google Nav on my way to work and it worked fine the whole way.
Good call, works great
(PS great avatar :-D)
 

· Developer
Joined
·
1,604 Posts
***remy said:
Tried replacing the contents of /system/usr/keycars and keylayout...no luck. Keyboard symbol mapping is still borked.
Yeah, same here.... took a bit of trial and error/memorization, but i'm getting the hang of the new mapping ;-)... it was like those kids memory games lol
 

· Developer
Joined
·
1,604 Posts
ok, got keyboard mapping fixed... not sure what calls/sets the map, but just pushing the cdma_droid2-keypad.kcm.bin and cdma_droid2-keypad.kl didn't work... however, if you replace the qwerty.kl and qwerty.kcm.bin with the droid2 ones (renaming them to qwerty) it works great... anybody know where that gets set by chance?
 

· Developer
Joined
·
1,604 Posts
sparkyman said:
without wifi it takes forever to to load apps. and charging is taking forever, i guess because its downloading everything from the market???
you try setting a static IP for wifi?... seems to have "fixed" mine
 

· Developer
Joined
·
1,604 Posts

· Developer
Joined
·
1,604 Posts
bomorgan said:
anyone have any luck with getting the mic to work?
none at all on my end....

on a side note SBFing right now after making a stupid mistake... don't try to mess with the cpu governor... lol
 

· Developer
Joined
·
1,604 Posts
ok... looks like the problem with Torch is caused by the lack of /sys/class/leds/flashlight/brightness however we do have /sys/class/leds/torch-flash I can't seem to get a copy of the sources correctly... or build them, lol... so if somebody wants to edit packages/apps/Torch/src/net/cactii/flash2/FlashDevice.java and change line 11 to use /sys/class/leds/torch-flash/brightness it may work, lol... i'll keep working on this end, see what happens
 

· Developer
Joined
·
1,604 Posts

· Developer
Joined
·
1,604 Posts
metiCkOne said:
Oh and don't use bootsrap people use rm manager.. lol trust me
no kidding, lol... unless you enjoy SBFing O:)
 

· Developer
Joined
·
1,604 Posts
JBirdVegas said:
keyboard load process
http://pastebin.com/uVFJZgaL

ideas?
digging through sources now to see if i can find where all that is set, etc... for the time being, i just renamed the droid2 keymap and keychar to match the default qwerty (in other words just replaced the qwerty with the droid2's) and all is good... I'll let you know if i find anything useful :-/
 

· Developer
Joined
·
1,604 Posts
frameworks/base/libs/ui/EventHub.cpp starting at line 780 is what finds the .kl file... in case anybody wants to take a look at it, lol... I'm looking now but i gotta admit, my cpp is a touch rusty ;-)
 

· Developer
Joined
·
1,604 Posts
JBirdVegas said:
here is a logcat of the camera starting then switching to camcorder that doesn't have an image.
http://pastebin.com/vaRjpDQB

ideas?

camcorder fails around line 188
after pushing etc/cameraCalFileDef5M.bin from GB Leak, i get image with the camcorder... just can't record anything, lol... here's the pastebin (sorry it's kinda long)
the juicy stuff starts on 374 ;-)

http://pastebin.com/f36zpRcZ
 

· Developer
Joined
·
1,604 Posts
try 'source build/envsetup.sh & brunch droid2'
 
1 - 20 of 394 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top