Android OS Forum banner
1 - 8 of 8 Posts

·
Frenetic Amnesic
Joined
·
1,060 Posts
(resolved)

I have spent about 6 hours trying to root a family member's Charge

I downloaded Odin 1.82 (provided in the sticky), installed the Samsung driver, have tried multiple Voodoo/CWM/root kits that claim they work with Charge EE4
I put the phone with 100% battery into download mode, flash with Odin, and I get a Pass. When the phone reboots, it reboots quickly, and no root is applied.

If pressed up/home/power, I can boot into CWM. This takes several minutes and I hear the voice prompts that should happen after the root. Once I get to CWM, I reboot, BUT there is still no root. I have tried installing superuser.apk, but it says there is not a kernel that supports root.

I have tried several different root files, multiple times, different stock cords, 100% charge, the install always passes. CWM is successfully installed, why not the kernel? Any insight into what I am doing wrong?

Another oddity is in CWM the menu button should act as back, but it doesn't. I cannot figure out any back button. Any thoughts?

I am considering flashing a Froyo Voodoo kernel from CWM to see if that fixes it, but I am uncertain of the status of the Voodoo hack/filesystem and wanted to ask the charge community before I grow more gray hairs working on this phone


-Thanks

PS: While I am a neophyte to the Charge, I have been creating my own ROMs for the OG for 2 years, so I was hoping this would be simple, . . . .
 

·
Android Addict
Joined
·
310 Posts
You have to flash pbj froyo voodoo kernel in cwm or any other rooted kernel. I always use pbj. So odin cwm, then boot to cwm then flash the kernel. You'll have root. Just download superuser from market after that
 

·
Frenetic Amnesic
Joined
·
1,060 Posts
Discussion Starter · #4 ·

·
Frenetic Amnesic
Joined
·
1,060 Posts
Discussion Starter · #5 ·
Kernel works perfectly. Came with SU app.
Downloaded Voodoo control, converted the file system

CWM still does not have a working back button, but I don't think that will be a big issue.
clumsyninja21 - thank you for your help
 

·
Frenetic Amnesic
Joined
·
1,060 Posts
I already handed off the phone. The CWM version was 4.0.1.4 or maybe 4.0.1.4.5. I cannot recall the text color
The bottom 4 buttons including they back key do not appear to function.

Edit was 4.0.1.4
I reflashed CWM from the sticky and it works fine now.
 
1 - 8 of 8 Posts
Top