Android OS Forum banner
1 - 18 of 18 Posts

·
Android Enthusiast
Joined
·
268 Posts
Discussion Starter · #1 ·
Has anyone figured out a way to disable the ability to wake the phone's screen with the Menu, Home, Back and Search buttons to save power? I was able to do this on other roms such as Apex, Stock GB and Froyo. Any feed back would be greatly appreciated.

Sent from my DROIDX using Tapatalk
 

·
Carbon-Based Robotic Tech Machine
Joined
·
2,243 Posts
I do want to find a solution to this also. On stock FroYo or GB (or roms based on them), only the home button or power button wakes the device. If we could get this back that would be awesome. I am not as concerned with the front buttons as the volume rocker. This is easy to press and it lights up the phone every time.

Still not enough to dissuade me from keeping CM7. I can deal with a few issues for the amazing performance.
 

·
Android Apprentice
Joined
·
46 Posts
abqnm said:
I do want to find a solution to this also. On stock FroYo or GB (or roms based on them), only the home button or power button wakes the device. If we could get this back that would be awesome. I am not as concerned with the front buttons as the volume rocker. This is easy to press and it lights up the phone every time.

Still not enough to dissuade me from keeping CM7. I can deal with a few issues for the amazing performance.
CyanogenMod Settings -> Input Settings -> Volume Rocker Wake
 

·
Android Apprentice
Joined
·
46 Posts
Menu unlock is CM Settings ->Lockscreen Settings -> Unlock Options -> Menu Unlock. I know I have seen the other ones, but I can't remember where.
 

·
Carbon-Based Robotic Tech Machine
Joined
·
2,243 Posts
jcoll81 said:
CyanogenMod Settings -> Input Settings -> Volume Rocker Wake
The setting is there but it doesn't actually work. Tried builds 17 and 18 and no luck.

jcoll81 said:
Menu unlock is CM Settings ->Lockscreen Settings -> Unlock Options -> Menu Unlock. I know I have seen the other ones, but I can't remember where.
This option allows you to unlock from the Lockscreen by pressing the menu button.
 

·
Android Apprentice
Joined
·
46 Posts
abqnm said:
The setting is there but it doesn't actually work. Tried builds 17 and 18 and no luck.

This option allows you to unlock from the Lockscreen by pressing the menu button.
I know that allows for unlocking with the menu button and that is what the original poster wanted to disable. I just wanted him to see if it was checked. I am on nightly 21 and not having any of these problems so I was just trying to offer suggestions.
 

·
Carbon-Based Robotic Tech Machine
Joined
·
2,243 Posts
jcoll81 said:
I know that allows for unlocking with the menu button and that is what the original poster wanted to disable. I just wanted him to see if it was checked. I am on nightly 21 and not having any of these problems so I was just trying to offer suggestions.
So on 21 if you shut the screen off and press any one of the hard buttons on the front or the volume keys it does not wake the phone? I may have to jump up on nightlies if that is the case.
 

·
Android Apprentice
Joined
·
46 Posts
Correct. I haven't tried last night's yet, so I am not too sure about it. I am cautious about changing because of some of the random bugs that pop up.
 

·
Android Enthusiast
Joined
·
268 Posts
Discussion Starter · #9 ·
I don't have the menu button checked in the unlock settings section in the Cyanogen mod settings. This was something that was done in the system/usr/ketlayout settings.

Sent from my DROIDX using Tapatalk
 

·
Carbon-Based Robotic Tech Machine
Joined
·
2,243 Posts
I was looking around in the keylayout settings, and the volume buttons are clearly set to WAKE, but of the 4 hard keys, only home is set to WAKE. The other three should not wake the phone, but for some reason they do.
 

·
Carbon-Based Robotic Tech Machine
Joined
·
2,243 Posts
Thanks, but I have already tried all that. It seems like none of the changes I make have any effect at all. I removed everything from the home/back/search/menu and volume buttons but all of them still wake it. Maybe I will try again in a few days on a new nightly.
 

·
Android Apprentice
Joined
·
50 Posts
Mine still worked after using this method as well. Found that the other files in the same location need to be edited as well. I think one more had very similar text in it once I edited that only power button will wake it.
Sent from my DROIDX using Tapatalk
 

·
Carbon-Based Robotic Tech Machine
Joined
·
2,243 Posts
I edited both the qwerty and the plain cdma_shadow ones but mine didn't work. Let me check permissions.
 

·
Carbon-Based Robotic Tech Machine
Joined
·
2,243 Posts
Found the issue. I missed another menu and back at the very bottom of the qwerty.kl that was not in the cdma_shadow.kl. Changed that and it works perfect. Also the CM7 setting for wake with volume still works if needed. I kept home to wake it because I like that feature and it is pretty hard to accidentally press home.
 

·
Android Enthusiast
Joined
·
268 Posts
Discussion Starter · #17 ·
abqnm said:
Found the issue. I missed another menu and back at the very bottom of the qwerty.kl that was not in the cdma_shadow.kl. Changed that and it works perfect. Also the CM7 setting for wake with volume still works if needed. I kept home to wake it because I like that feature and it is pretty hard to accidentally press home.
Thanks!
 

·
Carbon-Based Robotic Tech Machine
Joined
·
2,243 Posts
1 - 18 of 18 Posts
Top