Android OS Forum banner
1 - 18 of 18 Posts

·
Android Apprentice
Joined
·
78 Posts
Discussion Starter · #1 ·
Does anyone know if the Droid Bionic bootanimation Droid-Life posted works on the DX? If so, how did you install it? I wasn't sure if I should use CWM or manually put the .zip somewhere in my phone.

Links:
bootanimation.zip
Sound file
 

·
Supporting Member
Joined
·
151 Posts
I have not personally tried it, but it should work just fine. It is not a flashable zip, so flashing it in CWR will not work. Assuming that you are rooted, you can use Root Explorer to place it in /system/media, overwriting the current bootanimation.zip that is in there, and then just set the proper permissions to rw-r--r--. In the case that you are using MIUI, overwrite the bootanimation.zip in /data/system/theme/boots as that is the bootanimation.zip that MIUI boots from.
 

·
Android Apprentice
Joined
·
52 Posts
You can save yourself some trouble and just stick it in /data/local as it looks there first. The file works for me but not the sound.
 

·
Solus
Joined
·
296 Posts
Or Try setting it in system/media...
From what I've tried... I've been able to get ones to work there that won't work in data/local

We have nothing to fear but running out of beer
 

·
Flashaholic
Joined
·
348 Posts
I got animation to work but not sound. I put both in media and renamed the sound to bootup.ogg but nothing. It is something in the build.prop that is not allowing it to pick up the sound. I am not by a computer so trying to check this on the phone.
 

·
Solus
Joined
·
296 Posts
"coltzfan said:
I got animation to work but not sound. I put both in media and renamed the sound to bootup.ogg but nothing. It is something in the build.prop that is not allowing it to pick up the sound. I am not by a computer so trying to check this on the phone.
ya... I believe it's nest the end if the build prop... And I have seen some instances where people have gotten the boot animations to go with the sound.. Although I've never done it

We have nothing to fear but running out of beer
 

·
Flashaholic
Joined
·
348 Posts
So here is where I am now

# BEGIN Motorola, a22976, 12-Mar-2010, IKSHADOW-1784, Power Up Tone
# Motorola, a22976, 12-Apr-2010, IKSHADOW-3298, Remove temporary power up tone
# BEGIN Motorola, wbdq68, 21-May-2010, IKSHADOW-3372, Turn ON Power Up Tone
# Motorola, a22976, 26-May-2010, IKSHADOW-6164, Remove power up tone to keep the same as Droid
persist.mot.powerup.tone=/system/media/bootup.ogg
# END IKSHADOW-3372
# END IKSHADOW-1784

I deleted the # before persist.moto and made sure the file in the system/media was named bootup.ogg and rebooted. Is there something I am missing. The permissions for bootup.ogg are rw-r-r--

The new build prop that was edited and put into the system via root explorer permissions are --rwxr-x

Still no sound. :( what am I missing?
 

·
Android Beginner
Joined
·
4 Posts
It works perfectly WITH sound. Using Root Explorer or Astro place bootanimation.zip in /system/media and place Bionic.ogg in /system/media/audio/notifications. Don't change names of the files.
 

·
Flashaholic
Joined
·
348 Posts
"zroid said:
It works perfectly WITH sound. Using Root Explorer or Astro place bootanimation.zip in /system/media and place Bionic.ogg in /system/media/audio/notifications. Don't change names of the files.
I tried that. Didn't work. I am running omfgb if that helps
 

·
Android Apprentice
Joined
·
27 Posts
zroid said:
It works perfectly WITH sound. Using Root Explorer or Astro place bootanimation.zip in /system/media and place Bionic.ogg in /system/media/audio/notifications. Don't change names of the files.
Thanks! works great. .602 ota rooted.
 

·
Android Apprentice
Joined
·
78 Posts
Discussion Starter · #15 ·
zroid said:
It works perfectly WITH sound. Using Root Explorer or Astro place bootanimation.zip in /system/media and place Bionic.ogg in /system/media/audio/notifications. Don't change names of the files.
That worked!
 

·
Flashaholic
Joined
·
348 Posts
I finally got the sound to work on CM7 based roms. mainly OMFGB I dont take credit for 99% of this as it was found doing some research. So credit goes to NUNsLAUGHTER92 on Droidxforums. Some things need to be changed but this does work.

Anyway, here are the files that you will need to edit/add:
build.prop - /system
init.local.rc - /system/etc
bootsound - /system/bin
android_audio.mp3 - /data/local (NEEDS TO GO INTO SYSTEM/MEDIA)

So you need to do four things to make this work..

1: Add these lines to your build.prop file -

Code:

### Safe to Delete: Start ###
ro.config.play.bootsound=1
### Safe to Delete: End ###

2: Add lines in init.local.rc -
Code:

###Bootsound - Safe to Delete: Start ###

service bootsound /system/bin/bootsound
user media
group audio
disabled
oneshot

on property:init.svc.bootanim=running # to correct timing (THE "G" WAS MISSING FROM "TIMING" SO I ADDED THE G AND DID THE REST
start bootsound

on property:dev.bootcomplete=1
stop bootsound
### Bootsound - Safe to Delete: End ###
3: Add the file 'bootsound' from below to /system/bin

4: Add any .mp3 named "android_audio.mp3" to /data/local (SYSTEM/MEDIA)

Note 1: Add all of those lines to the bottom of the files. I guess you might not have to, but why not do what we know works.

Note 2: Check if every line is correct, multiple times. If it's off by even one character it won't work.
It's safe to just replace the init.local.rc though.

So if this doesn't work for you, please try again before saying that it doesn't work, because I know for a fact that it does.

Hope it helps out for those trying to get it to work correctly.

 

·
Android Apprentice
Joined
·
78 Posts
Discussion Starter · #17 ·
Sorry to double post, but I'm trying to get the bootanimation to also play the Droid.ogg sound when the logo gets shown at the start of the animation. I adjusted the desc.txt file to look like this:

Code:
# droid<br />
p 1 7 01_droid<br />
s Droid.ogg<br />
<br />
# mobility<br />
p 1 0 02_mobility<br />
s Bionic.ogg - [COLOR="#FF0000"]removed for testing purposes[/COLOR]<br />
<br />
# loop<br />
p 0 0 03_loop<br />
I removed the Bionic.ogg (which does work) because I wasn't sure if the bootanimation could play 2 sounds. Any thoughts?
 

·
Registered
Joined
·
195 Posts
"coltzfan said:
So here is where I am now

# BEGIN Motorola, a22976, 12-Mar-2010, IKSHADOW-1784, Power Up Tone
# Motorola, a22976, 12-Apr-2010, IKSHADOW-3298, Remove temporary power up tone
# BEGIN Motorola, wbdq68, 21-May-2010, IKSHADOW-3372, Turn ON Power Up Tone
# Motorola, a22976, 26-May-2010, IKSHADOW-6164, Remove power up tone to keep the same as Droid
persist.mot.powerup.tone=/system/media/bootup.ogg
# END IKSHADOW-3372
# END IKSHADOW-1784

I deleted the # before persist.moto and made sure the file in the system/media was named bootup.ogg and rebooted. Is there something I am missing. The permissions for bootup.ogg are rw-r-r--

The new build prop that was edited and put into the system via root explorer permissions are --rwxr-x

Still no sound. :( what am I missing?
I got both animation and sound to work. For sound don't rename it, leave it as bionic.ogg copy and paste it in system>media>audio> inside notifications folder. If need be change permissions to match the other files, don't remember if I did or not lol.
 
1 - 18 of 18 Posts
Top