Android OS Forum banner
1 - 6 of 6 Posts

·
Android Beginner
Joined
·
6 Posts
Discussion Starter · #1 ·
Hey guys I helped a friend flash cm onto his nexus the other day, room flashed with no issues, but as soon as I try to flash any kernel on to it it won't boot past the splash screen. Any ideas on why it would only dislike kernels and not roms? I tried netarchy and matrix with no luck
 

·
Premium Member
Joined
·
768 Posts
My phone has had a similar issue in the past actually. I believe in my case it is something to do with using Any Kernel based kernels/update.zips as whenever I use one of them I can't get past the splash screen no matter what. It applies for all Trinity, Matr1x, Netarchy and Peter Alfonso's kernels when they use AnyKernel.

Haven't discovered a solution yet though, I never used to have issues but after stuffing up my boot partition things haven't been quite the same. Could be bad flash memory?

Sent from my Nexus S using RootzWiki Forums
 

·
Banned
Joined
·
1,227 Posts
Hey guys, thought I'd let you know that I've had a similar issue with my wife's Evo3d. I've tried 3 or 4 different kernels and not a single one sticks... the 3g and wimax bork out, but it boots and everything, but when i look at the keernel info, it says its still on stock. I'll do a restore and everything works fine again, of course.... just freaking strange.
 

·
Android Apprentice
Joined
·
13 Posts
@Jonathon

How did you 'stuff up' your boot partition? TWRP I assume?

I'd just like to know what doesn't work with it, personally some ROMs won't work, for example Genexus and the TMS Poolparty ROM port posted on XDA.

My guess twrp messed up my boot partition aswell, although I've got no problems with anykernels.
 

·
Premium Member
Joined
·
768 Posts
"treuse said:
@Jonathon

How did you 'stuff up' your boot partition? TWRP I assume?

I'd just like to know what doesn't work with it, personally some ROMs won't work, for example Genexus and the TMS Poolparty ROM port posted on XDA.

My guess twrp messed up my boot partition aswell, although I've got no problems with anykernels.
What happened was I had flashed an early (1.0) build of TWRP on my phone, and then not checked the XDA thread for a while. In this time, they had discovered a flaw in the backup and restore feature which would incorrectly restore the boot partition. I had just flashed a kernel and it didn't work too well, so I restored my backup and then I had issues. It wouldn't boot with fastboot even to the bootloader. I did fix it though with odin thankfully!

I don't know why some roms won't work with it, I have been on Cwm since but I may move back for 2.0 if I feel like it. It could be some rarely used feature that these roms require, maybe the scripting on reboot support which many roms use for OTA style updating. That's all I know really, sorry.

Sent from my Nexus S using RootzWiki Forums
 

·
Android Apprentice
Joined
·
13 Posts
Jonathon Grigg said:
What happened was I had flashed an early (1.0) build of TWRP on my phone, and then not checked the XDA thread for a while. In this time, they had discovered a flaw in the backup and restore feature which would incorrectly restore the boot partition. I had just flashed a kernel and it didn't work too well, so I restored my backup and then I had issues. It wouldn't boot with fastboot even to the bootloader. I did fix it though with odin thankfully!

I don't know why some roms won't work with it, I have been on Cwm since but I may move back for 2.0 if I feel like it. It could be some rarely used feature that these roms require, maybe the scripting on reboot support which many roms use for OTA style updating. That's all I know really, sorry.

Sent from my Nexus S using RootzWiki Forums
Ah, thanks anyway :)

Sent from my Nexus S using Tapatalk
 
1 - 6 of 6 Posts
Top