Android OS Forum banner
1 - 3 of 3 Posts

·
All of your roots, give them to me.
Joined
·
68 Posts
NOTE: Anyone who is having problems with drivers, http://forum.xda-developers.com/showthread.php?t=1363652 <-- That explains the two most common problems.

Step by step video from my friend Albert to gain root access:

This also includes a gApps install section in it incase you decide you want to run that.


You may NOT use the included script in your work without atleast asking me as of now, this may change in the future but I dont want to have to hop from thread to thread just to offer support when I can keep the answers organized for all to find. So please just ask first.
Thanks.

Information:
I have gotten zergRush to work on the nook tablet as well as created a batch script for you to run to allow you to root your tablet. This does NOT unlock the bootloader software/hardware checks this is just so you can remove whatever unnecessary crap you wish to get the **** off your device.

Needed files for root:
You need drivers first:
http://dl.dropbox.com/u/15069134/usbdrivers.zip

here is an app to pull up usb debugging menu
http://li362-167.members.linode.com/gapps/non_google/tgps_launcher.apk
Code:
<br />
<robertely> Also note, that while that box will remain checked, the setting is not persistant.<br />
<robertely> So you have to flick the top 'Usb Development' box twice to get it working.<br />
Download Link for rooting script:
http://dl.dropbox.com/u/15069134/Nook&Zergy.zip

How to get adb debugging enabled:
Download the apk provided in the second download link to be able to access the menu *if you're just installing an app the first time, it will pull up the menu anyway but this is more for AFTER you have root as a convienance to access usb debugging and whatnot. Just try to install the apk *or open it if you already set unknown sources* and you will get a prompt to allow non-market apps. Click settings then you should be able to see "Unknown sources" check that followed by going into "Development" and check the 2 "Usb Debugging" boxes and uncheck "auto mount" then your nook tablet is ready to be used in debugging mode.


Instructions to root:

1. Download the "usbdrivers" zip
2. Download the "Nook&Zergy.zip"
3. Extract both to a folder C:\ntroot\
4. Now you should see the following files and folders inside c:\ntroot:
5. Run "runmefirst.bat" and follow the instructions.

6a. When the batch file opens the device manager, If you don't see a broken device icon next to "NOOK Tablet" then you may have some other generic drivers taking over. Not sure how to remove them so you will have to move to another PC that has never had a tablet hooked up and start over.

6b. If you do see NOOK Tablet with a broken device icon.. then right click and choose "update driver". Choose "Let me specify where the driver is" and browse to the c:\ntroot\usbdriver folder and hit ok. It should install and you can click "OK" to the warning about unsigned drivers.

7. Run "NookandZergy.bat" and follow the instructions
7a. If you see a long string of numbers/letters it's your device
Now you should have root.

Code:
<br />
Changelog:<br />
3.0: Updated Gapps to latest [9/30/2011]<br />
2.5: Fixed a few minor typo's/bugs with the script<br />
v2.1: Added usb vendor id addition to adb_usb.ini<br />
v2.0: Rewritten script to allow for more user choices; added Gapps installer (thanks anlog); Added busybox installer apk and debug menu puller (allows you to access debugging menu)<br />
v1.1 Updated superuser apk<br />
v1.0: Official release<br />
v.75: Updated to install SU and superuser.apk<br />
v.5: Initial release<br />
Code:
<br />
Credits:<br />
anlog for finding out how to get nook color drivers to work and general testing<br />
Team Revolutionary for their exploit<br />
B&N for using android like good little sheep<br />
suicideclown for bearing with me while I tried to get it to work on his computer until anlog found the driver fix.<br />
Dsstrainer for the simplified instructions.<br />
How to do it manually instead of running the Nook&Zergy.bat file (for linux or mac users or someone who wants to do it all manually)

Install drivers and follow instructions up until running the batch file then do the following commands in order:
Code:
<br />
adb push zergrush /data/local/zergy<br />
adb shell "chmod 755 /data/local/zergy;cd /data/local/;./zergy"<br />
adb wait-for-device install Superuser.apk<br />
adb remount<br />
adb push su /data/local/tmp/<br />
adb shell cd /data/local/tmp;chmod 777 su;cd /;mount -o remount,rw -t rootfs rootfs /;<br />
adb push su /system/bin/su<br />
adb shell chmod 4755 /system/bin/su<br />
Wanna buy me a coffee or something pretty for christmas?


Unroot method can be found here

Rooted nook tablet using my method
Taken from inside of barnes and noble;
 

·
Android Beginner
Joined
·
18 Posts
I have been looking and I have not seen any development towards any type of custom ROM. I am sure there are some out there, but it appears that the Kindle Fire is getting all the love right now. I am hoping that changes due to the specs on this thing. Maybe the bootloader is locked similar to Motorola's.

On a side note, this root method is perfect. Worked amazingly well on the tablet. Thanks Indirect!
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top