Android OS Forum banner
1 - 2 of 40 Posts

· Android Beginner
2 Posts
Having some problems on my Desire Z after upgrading from Virtuous 1.0.2...

I was using JuiceDefender 3.5.6beta to toggle my mobile data at 15 minute intervals. It worked fine at first, however after 5 hours (approximately, it varies) the toggle breaks; it tries to initialize the mobile data connection, but no data is transmitted or received.

If I go to "Settings>Wireless and Networks", the "Mobile Data" checkbox is ticked, but instead of saying "Connected", it says "Use mobile data for data connection when Wi-Fi is unavailable" or something similar. Wi-Fi is not turned on, so I'm not sure what's going on.

When this happened, I tried the following solutions:

Disable JuiceDefender and manually toggle the "Moble Data" checkbox in "Settings>Wireless and Networks"
This occasionally works, allowing mobile data to connect, but most times it just greys out, says "Turning on..." and stays that way.
Incidentally, JuiceDefender does not modify APNs to toggle data, so it's not an APN issue, and the dev claims to support Gingerbread since v3.5.0.

After disabling JuiceDefender completely, I try the below solutions:

Turning Airplane Mode on and off
Also does not solve the problem.

Turn Wifi on, wait until it connects, leave it for a few minutes, then turn it off.
Very strangely, mobile data can connect after doing this, but subsequent tries to toggle mobile data manually from "Settings>Wireless and Networks" without doing this voodoo do not work.

Check out the phone information via *#*#4636#*#*
The test menu shows "GPRS service: Disconnected" and the ping test does not work. Turning the radio on and off from this menu does not solve the problem.

This is the next-to-final resort, and solves the problem, until 5 hours later.

Flash radio, match RIL, wipe EFS
So far, i have had this same problem despite flashing from to, and then to It doesn't seem to matter which radio I use.

I know that the XDA thread for this ROM has some reports of issues with mobile data, but those were solved by flashing radios and matching RILs. In my case, I think that a downgrade back to 1.0.2 may be in order...

Any suggestions?

· Android Beginner
2 Posts
While I am at it, I also have the following comments about features missing from Virtuous Sense 2.0.0 that were in Virtuous 1.0.2:

1) The trackpad in 2.0.0 is horribly unresponsive; it only advances one character at a time even when you swipe frantically at it, making it less than useful for text selection. This has been mentioned on XDA as well. Yes, Gingerbread has improved text selection markers, but HTC doesn't even implement them, and they've broken the only viable alternative!

2) The WWE RUU that 2.0.0 was based on does not appear to include support for Chinese handwriting input, which is a shame, since Virtuous 1.0.2 did, and no one's stepped up to extract it from the Taiwan RUU and offer it. It's also missing many locales, though I guess that Morelocales2 or similar would make them available.

2) When you click on the HTC Sense Flip Clock/Weather widget, it inexplicably jumps you to the World Time display instead of the Desk Clock display as it normally does on stock Sense (well, at least it did on versions of the widget up to Virtuous 1.0.2).

4) The Sync icon that appears in the status bar when retrieving email, contacts, etc. no longer spins. Similarly, the Download icons that show up when you are downloading an app no longer animate. Okay, this one is a matter of personal preference, but I liked how it looked... OTOH, I'm totally sold on the new battery meter's look.

None of these are as show-stopping as my mobile data problem, but they definitely dampen my enthusiasm for upgrading.
1 - 2 of 40 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.