Android OS Forum banner

1 - 8 of 8 Posts

·
Premium Member
Joined
·
1,900 Posts
Discussion Starter · #1 ·
== Chainfire Gingerbreak Testing ==

Download the source here if you are a developer or plan on using it - Here

'''INFO''' - This team has brought many exploits to the Android Scene and if you would like to donate to them please feel free to send via PayPal to [email protected]

This is for testing to help Chainfire (original developer) find out which devices whether its FroYo or Gingerbread; to see if the APK works. Please test and see if it works, Chainfire, Sebastion Krahmer, XDA Developers and RootzWiki are not responsible for bricked devices, even though none have been reported, please download the file and install it and run it, if you run in to an error "could not open assets" please do the following in the SDK using ADB:

Code:
adb shell rmdir /data/local/tmp
then

Code:
adb shell mkdir /data/local/tmp
Download - v1.0 Here

Download - v1.1 Here

'''PLEASE NOTE IF YOU NEEDED TO REMOVE AND MAKE THE DATA/LOCAL/TMP FOLDER WITH A STAR'''

v1.2 found on [http://forum.xda-developers.com/showthread.php?t=1044765 XDA forums]

Notes from Chainfire

'''Changelog'''
Code:
26.04.2011: v1.2<br />
- Removed some code that may break operation while the code itself isn't needed<br />
- Added UnRoot option<br />
- The APK now logs exploit output semi-live<br />
22.04.2011: v1.1
- Modded exploit code to not need /data/local/tmp - this should fix the problem extracting assets as well as be more compatible with various devices (in theory). In case the APK notices that this cannot work, it will warn you about this.
- Added some warnings and errors to the APK

21.04.2011: v1.0
- First release of APK
- Slight mods to the exploit source to have it work better from APK
'''About'''
Code:
 <br />
GingerBreak APK is a wrapper around the newly released GingerBreak exploit, which is meant to attain root access on GingerBread. This specific exploit may work on various Froyo and Honeycomb versions as well.<br />
What the APK and exploit do is as follows:
Code:
<br />
- The APK puts the right files in the right place to run the exploit<br />
- The APK runs the exploit<br />
- The exploit attempts to attain root access<br />
- If it succeeds, the exploit remounts /system as read-write and runs the installer script<br />
- The installer script attempts to install the su binary and superuser APK, and reboots
Some important things to know:
Code:
<br />
- You must have USB debugging enabled on your device<br />
- You need to have an SD card (formatted and) inserted<br />
- The APK must be install to device, NOT SD card<br />
- The exploit may take a while to run, but not more than 10 minutes, if it does, get me a logcat, and reboot the device<br />
- Always reboot between root attempts!<br />
- While (temporary?) root access may be attained, due to locked bootloaders, efuses, S-ON, and whatnot this may still not work on your device<br />
- The GingerBreak exploit should not be used to attain temproot and continue using the device. It fscks vold, you do not want to be running like that. You want to reboot! So if the root doesn't stick, you (still) have a problem.<br />
=== Successful Devices ===

Motorola Droid X using 2.3.3

Motorola Droid X2 using 2.2.1

Motorola Droid 2 using 2.3.3

Samsung Nexus S 2.3.3

Sony Xperia Arc

Sony Xperia Play

Sony Xperia Neo

Motorola Atrix 4G 2.2.1 (1.5.7)

Nexus One using 2.3.3

LG ALLY 2.2.2

LG OPTIMUS 2.2.2

=== Unsuccessful Devices ===

Thunderbolt 2.2.1 (Exploit works to gain root, but apk does not)

Motorola Xoom app force closes before it can start.

HTC Desire HD 2.2.1 (After an hour it gives up trying)

HTC Wildfire 2.2.1 program runs but no superuser

Samsung Galaxy ACE 2.3.3 program runs but no superuser

LG G-Slate (no SD card slot)

LG Revolution (Exploit works to gain root, apk does not. App opens, fails to copy files, then quits)

Google Nexus One 2.3.4 (no progress in 15+ minutes)
 

·
Premium Member
Joined
·
141 Posts
I can confirm Gingerbreak works on the Casio Gz'One Commando
 

·
Premium Member
Joined
·
141 Posts
No, Gingerbreak does not work on .596. The only way to get root on .596 if you have already taken the OTA is to SBF back to 2.3.340 and then upgrade to 4.5.596 utilizing the version released by TBH.
 

·
Themer
Joined
·
110 Posts
Nusince said:
No, Gingerbreak does not work on .596. The only way to get root on .596 if you have already taken the OTA is to SBF back to 2.3.340 and then upgrade to 4.5.596 utilizing the version released by TBH.
100% correct
 

·
U.S. MARINE SEMPER FI
Joined
·
178 Posts
Works on LG Vortex,motorola droidpro and samsung galaxy tab 7inch wifi
 

·
Android Beginner
Joined
·
1 Posts
When I run the gingerbreak 1.2 app on my d2 and click root it says my phone will reboot when successful but never reboots even after an hour. I've rebooted numerous times and I even reverted to factory settings with no luck. I have the superuser app but I don't have su access to apps ie barnacle... I'm at a loss any ideas?
 

·
Android Addict
Joined
·
348 Posts
When I user AlpharevX to S-Off my wildfire it worked on 2.2.1, wouldn't reboot though - I just checked the app drawer and superuser was there
 
1 - 8 of 8 Posts
Top