Android OS Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter · #1 ·
Hi guys, I've just joined rootzwiki hoping that someone will be able to help me with a problem that I have. I have a D2G phone - VZW branded, that I am using in Kenya. It's running the latest GB update (.608). The issue that I have is that I am unable to use 3G/HSDPA while in GSM only mode. If I switch to HSDPA mode, I am able to use high speed data, but my voice/network signal goes way too low that I am unreachable to callers. I suspect that it could be something to do with network frequencies, but I could be wrong as I am not an expert in GSM. I would truly appreciate if someone could help me out on this. Also let me know whether installing a custom ROM such as CM wound assist in eliminating this problem.

Thankfully,

Saichovsky
 

·
ヤンデレ
Joined
·
836 Posts
Hi guys, I've just joined rootzwiki hoping that someone will be able to help me with a problem that I have. I have a D2G phone - VZW branded, that I am using in Kenya. It's running the latest GB update (.608). The issue that I have is that I am unable to use 3G/HSDPA while in GSM only mode. If I switch to HSDPA mode, I am able to use high speed data, but my voice/network signal goes way too low that I am unreachable to callers. I suspect that it could be something to do with network frequencies, but I could be wrong as I am not an expert in GSM. I would truly appreciate if someone could help me out on this. Also let me know whether installing a custom ROM such as CM wound assist in eliminating this problem.
Motorola's software artificially lowers the signal strength indication for 3G GSM.

If you are rooted, get Root Explorer, head to /system and remount the filesystem in read-write mode. Then open build.prop, and find the line that goes
Code:
<br />
ro.mot.phonemode.vzwglobalphone=1<br />
Change that 1 to 0, save, and reboot the phone.

You're set.
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #3 ·
Hey mate,

Sorry for this late reply, I've just seen your post. I've done as you suggested, rebooted my phone but the signal still seems to be low
Any further tips?
I'm also trying to understand this build.prop file [I'm new to android :) ]

Me.
 

·
ヤンデレ
Joined
·
836 Posts
Did you get 5 bars display instead of 4? If not, then you somehow failed to edit it properly.
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #5 ·
The thing is... I'm not using stock ROM but this. I saw some dude on some website who also said that he got 5 bars... I actually have like 3!!! Does the 5 bars thing work on custom ROMs as well? I believe I've edited it alright. I also edited /data/local.prop some settings which are all over the web for improving 3G speeds. I think they work fine, but I also noticed that the radio signal seems to disappear for a couple seconds when changing from 3G to HSDPA and vice versa.
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #6 ·
My /system/build.prop --> http://pastebin.com/tef5rPxE

My /data/local.prop

ro.sys.atvc_allow_netmon_usb=0
ro.sys.atvc_allow_netmon_ih=0
ro.sys.atvc_allow_res_core=0
ro.sys.atvc_allow_res_panic=0
ro.sys.atvc_allow_all_adb=0
ro.sys.atvc_allow_all_core=0
ro.sys.atvc_allow_efem=0
ro.sys.atvc_allow_bp_log=0
ro.sys.atvc_allow_ap_mot_log=0
ro.sys.atvc_allow_gki_log=0
ro.ril.hsxpa=2
ro.ril.gprsclass=12
ro.ril.hep=1
ro.ril.enable.dtm=1
ro.ril.hsdpa.category=10
 

·
ヤンデレ
Joined
·
836 Posts
The thing is... I'm not using stock ROM but this. I saw some dude on some website who also said that he got 5 bars... I actually have like 3!!! Does the 5 bars thing work on custom ROMs as well? I believe I've edited it alright. I also edited /data/local.prop some settings which are all over the web for improving 3G speeds. I think they work fine, but I also noticed that the radio signal seems to disappear for a couple seconds when changing from 3G to HSDPA and vice versa.
I thought the builds hosted on MIUI.us are outdated?..

Try asking in the MIUI user thread.
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #8 ·
Hmm... I thought so too.. seeing that it's version 1.x.x

Do these ROMs ever get to a point where they're bug free anyway? If it's not one thing it's always another; I tried CM7 but the Sim Toolkit wasn't working. The STK is very important in my country (Kenya) because of a mobile money transfer service ran by my MNO.

Thanks anyways... lemmi check out the MIUI forum in the meantime.
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top