Android OS Forum banner
1 - 7 of 7 Posts

· Registered
4 Posts
Discussion Starter · #1 ·
Here is how you do it courtesy of Shannon VanWagner

and his website Humans Enabled

Thanks Shannon. Here is the what you should do: again all credit goes to Shannon VanWagner. Fire up a terminal session:

sudo apt-get install libusb-dev
2- download libmtp tar.gz from

3-cd to the directory you downloaded to: Download in this case, case sensitive

cd Download
4- extract the tar package

tar xvf libmtp-1.1.1.tar.gz
please make sure you check the file version, this file changes as it is updated and change it accordingly per the above website

5- cd to the newly created folder that has the extracted file:

cd libmtp-1.1.1
again don't forget to change the name if the version has changed

6- compile and install: do each step separately

./configure --prefix=/usr
sudo make install
7- while in the same directory in the terminal, copy the rules from there to the udev folder:

sudo cp 69-libmtp.rules /etc/udev/rules.d
8- install gMTP:

sudo apt-get install gmtp
9- open up gMTP, go to edit/prefrences and check the box for Always Show Download Path. This way when you are downloading from the phone to your computer, you are asked to choose a location. Use the Add button to upload from your Linux Box to the phone. Delete does, well, Delete a file.

· Premium Member
4,241 Posts
As an alternative, you can do something like

1) get this or use dropbear on the terminal

2) set it up and run it

3) in your linux desktop in the folder bar for switching folders, type:

sftp://username:p[email protected]

After that, you can transfer files over wifi from your computer to android securely or from android to your computer (including your filesystem outside of the "sdcard").

· Android Apprentice
370 Posts
I am running Ubuntu 12.04 64 bit and everything seemed to compile and I have the 69-libmtp rules file in the etc/udev folder, but gMTP will still not connect with my GNex. I can use Wifi File Explorer, but would really like to set this up to work properly. I tried the 1.1.3 libmtp and that just threw errors in the make command, so I tried 1.1.2 and it compiled, but gMTP still doesn't see my GNex. Any help would be much appreciated. I'm a bit of a Ubuntu noob, so please be nice.
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.