Android OS Forum banner
1 - 7 of 7 Posts

·
Android Apprentice
Joined
·
52 Posts
Discussion Starter · #1 ·
This is for anyone who has an I/O Edition tablet, yet wants to be able to update to 3.1 along with flash custom roms and CWM Recovery,

(This was originally posted on XDA via mughalgxt)

When you flash this ODIN it will flash the stock bootloader along with 3.1 Touchwiz UX. Once you root and flash CWM you can flash a stock 3.1 system if you wish

Instructions:
Kudos to samfirmware.com team, for bringing us (P7510 owners) much awaited stock ROM with TOUCHWIZ!

Samfirmware.com have released the stock ROM for Samsung Galaxy Tab 10.1 (WIFI) (EUROPEAN if it matters!) version P7510XXKFC Honeycomb 3.1 TouchWiz (2011 June). For those stuck on bootloops, bricked tabs or waiting to re-flash to stock firmware rejoice.

Just Odin the firmware (use attached odin file!) in download mode with the pit file available on samfirmware.com or directly accessible at:

INSTALL VIA. ODIN:

http://hotfile.com/dl/123934038/d74c74b/P7510XXKFC.zip.html

Steps:
--If rooted i recommend backing up your current firmware with rom manager before the plunge and saving it on your pc for future access.

--Switch off the tab completely

--Connect to PC

--Wait for the battery Icon to display

--Press power button followed by a second's delay left volume button (button near to power)

--Press left power button to choose odin (download mode) than right volume to confirm

--Start odin ( i used the one attached below) and place:

--RE-PARTITION UNCHECK! <---- SERIOUSLY MOST IMPORTANT PART!!!!!

--pit file in PIT

--Bootloader in Bootloader

--Code in PDA

--CSc in CSc

--press start and wait...........WAIT please patience!!!

--As for the error occurring in recovery mode during system wipe, manually factory reset and clear cache!

Once your Tab reboots you will be free from the wonky I/O Bootloader and treat your tab the way it should be :)
 

·
Android Beginner
Joined
·
4 Posts
HAve updated the post with a newer ROM, the touchwiz is more polished release version. Running very smoothly. It supports arabic, farsi,english,french and korean languages. Worth trying.
 

·
Android Beginner
Joined
·
6 Posts
Update

Just wanted to note the issue i was having with my I/O tab
Ive always had issues trying to flash CWR to this tab, it just would not work, the only way I was able to get it on was through rom manager after it was rooted
and the only way I was ever able to root this tab was by flashing PDA_SIGNED_P7105.tar.

http://forum.xda-developers.com/showpost.php?p=15687290&postcount=14

I noticed yesterday that I was not on the latest version of 3.1 KF3, went to system updates it said I was up to date.
Started looking around and found threads on the update, but for some reason fastboot was not working on my desktop, or my windows VM

http://www.androidpolice.com/2011/0...-1-io-edition-honeycomb-update-available-now/

I went into CWR, it got all strange, and would not let me get out of it or reboot, when I finally did I had a bootloop
I reflashed PDA_SIGNED_P7105.tar, still bootlooped
could not connect with fastboot
adb only worked while the tab was in bootloop
So I tired this method, got me into touchwiz, no problem
This morning I flashed recovery, it worked the first time, for the first time ever for me
I then went into Odin and reflashed PDA_SIGNED_P7105.tar, I should of wiped data/cache first but forgot
So after it booted up, thats what I did, because I was getting a ton of force close errors, rebooted
100% perfect
added my Samsung account, and updated to 3.1 KF3
still have root, recovery is stock and working like it should, which Ive never been able to get into.
 

·
Registered
Joined
·
1 Posts
Hi. Anyone know how to fix the tab if I made the mistake of NOT unchecking the "--RE-PARTITION UNCHECK! <---- SERIOUSLY MOST IMPORTANT PART!!!!!"?

My tab no longer responds. When i plug it in, it connects only with apx mode with a black screen. I think it responds to nvflash to a certain degree.
Please let me know.
 
1 - 7 of 7 Posts
Top