Android OS Forum banner
1 - 8 of 8 Posts

·
Themer
Joined
·
50 Posts
Discussion Starter · #1 ·
So I finally got around to learning how to build an adw theme from the template and for the most part all has gone smooth but When selecting a dock from my theme it just says "sorry there was an error try again". Im not sure if its related but when i first started building in eclipse i got about 9 errors about "getcount and getitem" which I dont really understand and I used the quick fix which removed @override from the line above these errors I have no clue how I created those errors. Ive started over from scratch with the template a few times only to end up with the same exact issues. Anyone who can shed anylight on my situation it would be greatly appreciated
 

·
Premium Member
Joined
·
63 Posts
Without seeing your code, it will be hard to decipher what you have done incorrectly. If you want to use teamviewer, I could look over your stuff to see if I can locate the issue.
 

·
Premium Member
Joined
·
63 Posts
Off the top of my head, make sure you've got the import line changed on the docks.java, make sure the AndroidManifest has your package name in the docks line and make sure you actually edited your docks.xml to point to the docks themselves. My offer still stands though if you want to go that route.
 

·
Themer
Joined
·
50 Posts
Discussion Starter · #5 ·
Description Resource Path Location Type
The method getCount() of type docks.DocksAdapter must override a superclass method docks.java /main/src/com/blackrome/adw line 49 Java Problem

Description Resource Path Location Type
The method getCount() of type main.IconsAdapter must override a superclass method main.java /main/src/com/blackrome/adw line 77 Java Problem

Description Resource Path Location Type
The method getItem(int) of type docks.DocksAdapter must override a superclass method docks.java /main/src/com/blackrome/adw line 54 Java Problem

Description Resource Path Location Type
The method getItem(int) of type main.IconsAdapter must override a superclass method main.java /main/src/com/blackrome/adw line 82 Java Problem

There are 5 more just like these i can post the rest but Im assuming that these are all related. I have these errors before I ever do anything, well after refactor and editing the manifest and deleting the import x.x.x R Ive never used teamviewer but ill look at it now
 

·
Android Beginner
Joined
·
9 Posts
Change your source compliance to java 6, it will be fixed.
This happens when you have @override annotation on an interface method. It is not valid before java 6. so, change the source compliance.
 
1 - 8 of 8 Posts
Top