Android OS Forum banner
1 - 20 of 96 Posts

·
Thread Cruiser
Joined
·
205 Posts
In order to help people fix their touchpad problems I will attempt to keep up with the development and post any fixes for common problems here. If you have an issue please read this ENTIRE OP and search the dev thread of the ROM you are using to see if it was fixed there. The answers here are for the masses and there will DEFINITELY be cases where these will not work. Each device is a little bit different.

IF YOU ARE RUNNING A NIGHTLY EXPECT TO HAVE ISSUES

CAMERA AND MIC DO NOT CURRENTLY WORK. DO NOT ASK FOR ETA's OR HELP WITH THOSE.

RANDOM REBOOTS
The minimum CPU frequency is set to 192MHZ and it is to low for some devices. Try using a CPU contoller like SetCPU($$) or System Tuner (Free) to change it to 384 or 432. Those seems to be the best to stop this. It could also be due to the max being too high. 1.7 seems to be the highest you can go before having issues. If you still have issues at 1.7 try 1.5

Can't transfer files
USB Mass storage does not currently work without some voodoo magic. Instead go to settings > storage > menu (3 dots, top right) > USB computer connection and select Media device (MTP). You may also need to turn off USB debugging at settings > Developer Options

WIFI Loses connection
Known bug. To get it again forget your network, turn off wifi, turn it back on and reconnect. You might need to do this a few times.

Moboot still shows (Other ROM Name here)
Get an app like Root explorer and navigate to /boot, change to R/W mode and delete UImage.(OTHER ROM NAME)

I want to change what boots first
Get an app like Root explorer and navigate to /boot, change to R/W mode, open moboot.default and change to whatever ROM you want depending on your preference. Be sure to type it in EXACTLY as it is in the /boot directory. So if it is UImage.AOKP make sure to enter it into the moboot.default as AOKP and not Aokp. CaPs matter.

It sounds like my touchpad is farting/Has Scratchy sounds when I have sound coming out of the speakers
Common issue. Usually only happens when the screen is off. I have had luck fixing this by turning the sound down a notch or two but others have not. If it happens when the screen in on stop whatever is making the sound and restart it (pause/play music). I use Google music a lot so I set a tasker profile to keep the screen on when music is playing. Makes it easier.

I am stuck at a boot/loading/whatever screen. The device screen/buttons are completely unresponsive
Hold down power and the hardware home button for a few seconds and it will reboot. This is a firmware hard reset and should only be used in the most dire of circumstances

It won't charge!
Make sure MTP is enabled. See instructions above. This is one of those "It works but I don't know why" type of deals.

No sound when using headphones
Plug in your headphones before you start the app with sound and it will work. You may need to force close the app to clear it from system memory.

No sound after touchpad goes to sleeep
boot up touchpad with headphones plugged in

Power options do not work
Flash this in CWM. Be sure to make a Nandroid first in case of issues.

http://www.mediafire...r1gdi841vndkrgv

Getting a "SD card Removed" Message in notifications (ONLY WHEN YOU HAVE LOTS OF APPS ON SD CARD)
Follow this guide. It says it is for CM7 but works for CM9

Can't Install Flash Player From the Play Store
Adobe has stopped support of flash for Android. You can download the latest build of it from their website.

http://helpx.adobe.com/flash-player/kb/archived-flash-player-versions.html

Scroll down the the middle of the page and select the latest version of flash for Android 4.0

I will add to this as more problems are fixed/found a workaround for. If there is any other things I have missed please let me know.

Have fun and stay hairy
 

·
Android Beginner
Joined
·
50 Posts
thanks, we sorely need this thread. you should let people report any more bugs here and post any links to fixes that may be available, such as gapps for the nightlies​
 

·
Registered
Joined
·
4 Posts
I'm new to the forums so I'm not sure whether or not this has been included in any of the discussions regarding the audio issues. I haven't experienced the farting/scratching sounds while the screen is off but I have heard them while using any type of equalizer apps. This includes dsp, eq equalizer, and music volume eq used in conjunction with stock music player, pandora, tunein radio, etc. The sounds are heard when using the speakers and headphones as well.
 

·
Registered
Joined
·
2 Posts
Cannot change minimum CPU frequency on my Touchpad. For some reason the option for Minimum and Maximum CPU frequency are greyed out in my menu.
 

·
Android Beginner
Joined
·
109 Posts
Cannot change minimum CPU frequency on my Touchpad. For some reason the option for Minimum and Maximum CPU frequency are greyed out in my menu.
you must use an app to do it. you can't do it from android itself.

i've tried a free one and i still got crashes. i trying a $2 app "setcpu" and i have not crashed yet. which leads me to....
 

·
Android Beginner
Joined
·
109 Posts
has anyone been able to change the minimum clock speed and thereby avoid the reboot crashes with an app OTHER THAN setcpu?

i tried one other free app and while the settings/performance/cpu menu reported that i was indeed idling at the higher cpu speed, i was still crashing. also, setcpu does not show that i have an app process going (bottom next to time) whereas the free app did... is there a difference there?

cuz if setcpu is the only thing that will prevent the crashes, we should just straight up say that you have to use that app if you don't want to crash.
 

·
Android Beginner
Joined
·
50 Posts
has anyone been able to change the minimum clock speed and thereby avoid the reboot crashes with an app OTHER THAN setcpu?

i tried one other free app and while the settings/performance/cpu menu reported that i was indeed idling at the higher cpu speed, i was still crashing. also, setcpu does not show that i have an app process going (bottom next to time) whereas the free app did... is there a difference there?

cuz if setcpu is the only thing that will prevent the crashes, we should just straight up say that you have to use that app if you don't want to crash.
i use system tuner, i think its a much better app than setcpu and does a hell of a lot more
 

·
Thread Cruiser
Joined
·
205 Posts
Discussion Starter · #10 ·
I'm new to the forums so I'm not sure whether or not this has been included in any of the discussions regarding the audio issues. I haven't experienced the farting/scratching sounds while the screen is off but I have heard them while using any type of equalizer apps. This includes dsp, eq equalizer, and music volume eq used in conjunction with stock music player, pandora, tunein radio, etc. The sounds are heard when using the speakers and headphones as well.
I believe the issue is the audio driver itself. I have had it happen with the screen off and on before, with and without an equalizer.
 

·
Android Beginner
Joined
·
109 Posts
I'll add that as a note in the OP.

EDIT: Just noticed I already have that in the directions. Perhaps people should just read......
you do note that you should do the procedure using an app like setcpu but maybe put a little thing saying you CANNOT do this through android without such an app.

?
 

·
Thread Cruiser
Joined
·
205 Posts
Discussion Starter · #13 ·
you do note that you should do the procedure using an app like setcpu but maybe put a little thing saying you CANNOT do this through android without such an app.

?
Didn't add that because it is built into some roms. AOKP has it built in, and I think cherry kang does too.
 

·
^^
Joined
·
41 Posts
In order to help people fix their touchpad problems I will attempt to keep up with the development and post any fixes for common problems here. If you have an issue please read this ENTIRE OP and search the dev thread of the ROM you are using to see if it was fixed there. The answers here are for the masses and there will DEFINITELY be cases where these will not work. Each device is a little bit different.

IF YOU ARE RUNNING A NIGHTLY EXPECT TO HAVE ISSUES

CAMERA AND MIC DO NOT CURRENTLY WORK. DO NOT ASK FOR ETA's OR HELP WITH THOSE.

RANDOM REBOOTS
The minimum CPU frequency is set to 192MHZ and it is to low for some devices. Try using a CPU contoller like SetCPU($$) or System Tuner (Free) to change it to 384 or 432. Those seems to be the best to stop this. It could also be due to the max being too high. 1.7 seems to be the highest you can go before having issues. If you still have issues at 1.7 try 1.5

Can't transfer files
USB Mass storage does not currently work without some voodoo magic. Instead go to settings > storage > menu (3 dots, top right) > USB computer connection and select Media device (MTP). You may also need to turn off USB debugging at settings > Developer Options

WIFI Loses connection
Known bug. To get it again forget your network, turn off wifi, turn it back on and reconnect. You might need to do this a few times.

Moboot still shows (Other ROM Name here)
Get an app like Root explorer and navigate to /boot, change to R/W mode and delete UImage.(OTHER ROM NAME)

I want to change what boots first
Get an app like Root explorer and navigate to /boot, change to R/W mode, open moboot.default and change to whatever ROM you want depending on your preference. Be sure to type it in EXACTLY as it is in the /boot directory. So if it is UImage.AOKP make sure to enter it into the moboot.default as AOKP and not Aokp. CaPs matter.

It sounds like my touchpad is farting/Has Scratchy sounds when I have sound coming out of the speakers
Common issue. Usually only happens when the screen is off. I have had luck fixing this by turning the sound down a notch or two but others have not. If it happens when the screen in on stop whatever is making the sound and restart it (pause/play music). I use Google music a lot so I set a tasker profile to keep the screen on when music is playing. Makes it easier.

I am stuck at a boot/loading/whatever screen. The device screen/buttons are completely unresponsive
Hold down power and the hardware home button for a few seconds and it will reboot. This is a firmware hard reset and should only be used in the most dire of circumstances

It won't charge!
Make sure MTP is enabled. See instructions above. This is one of those "It works but I don't know why" type of deals.

No sound when using headphones
Plug in your headphones before you start listening to music/playing a game and it will work.

Power options do not work
Flash this in CWM. Be sure to make a Nandroid first in case of issues.

http://www.mediafire...r1gdi841vndkrgv

Getting a "SD card Removed" Message in notifications (ONLY WHEN YOU HAVE LOTS OF APPS ON SD CARD)
Follow this guide. It says it is for CM7 but works for CM9

I will add to this as more problems are fixed/found a workaround for. If there is any other things I have missed please let me know.

Have fun and stay hairy
try set the frequency doesn't solve the reboot problem , and many ppl had tried this way .
 

·
Registered
Joined
·
13 Posts
I have this already known problem when using "Talking Tom Cat 2 Free" :

"It sounds like my touchpad is farting/Has Scratchy sounds when I have sound coming out of the speakers
Common issue. Usually only happens when the screen is off. I have had luck fixing this by turning the sound down a notch or two but others have not. If it happens when the screen in on stop whatever is making the sound and restart it (pause/play music). I use Google music a lot so I set a tasker profile to keep the screen on when music is playing. Makes it easier."

Can someone help me about this problem or give other idea how to solve it?
 

·
Thread Cruiser
Joined
·
205 Posts
Discussion Starter · #16 ·
try set the frequency doesn't solve the reboot problem , and many ppl had tried this way .
As I said in the OP, this is for the masses. Changing the frequency works for 90% of people, and there will definitely be cases where it doesn't work. Remember, this is an ALPHA build of an OS that was never meant to run on this hardware. We are lucky to be using android at all.
 

·
Thread Cruiser
Joined
·
205 Posts
Discussion Starter · #17 ·
I have this already known problem when using "Talking Tom Cat 2 Free" :

"It sounds like my touchpad is farting/Has Scratchy sounds when I have sound coming out of the speakers
Common issue. Usually only happens when the screen is off. I have had luck fixing this by turning the sound down a notch or two but others have not. If it happens when the screen in on stop whatever is making the sound and restart it (pause/play music). I use Google music a lot so I set a tasker profile to keep the screen on when music is playing. Makes it easier."

Can someone help me about this problem or give other idea how to solve it?
There is no solution. The problem lies in the audio driver. Until we get the proper driver we will most likely just have to deal with this bug.
 

·
Android Beginner
Joined
·
3 Posts
Does everyones haptic feedback work? Does it vibrate on keypress on the on screen keyboard and pattern lock screen? I know how to enable it. And it works if i reboot my touchpad. But if i put it to sleep is stops working until next reboot. I am running alpha 2 cm9. No nightlies. It worked great on cm7 alpha 3. I updated from that to cm9 a2. I did not delete data, i did the upgrade method. I cant seem to find many others with this issue. So im trying to figure out if i should wipe my tp and reflash cm9, or if it is a known issue. Please let me know if you have haptic working at or near 100% or if every has this issue.
 

·
Registered
Joined
·
13 Posts
Are blocked ports a known issue?

Per the documentation at Tivo web site, I need access to the following ports in order for their Tivo app to see / drive my Tivo:
TCP port 37, 80, 443, 1413, 2190, 4430, 5222, 5223, 5254, 5354, 7287-7297, 8000, 8080-8089, 8101, 8102, 8181, 8200, 31339

UDP port 37, 123, 2190, 5353

Running NetScan from my Touchpad, it can only get a response from the Tivo on ports 443, 2190, 2191 and 31339. Running the Tivo app on my Touchpad, it can't find the Tivo. However, if I run the iPod version of the Tivo app, it sees the Tivo and controls it just fine, so I know the problem isn't in the router settings or the Tivo. Any words of wisdom? Thanks in advance!
 
1 - 20 of 96 Posts
Top