Android OS Forum banner
1 - 20 of 28 Posts

·
Lord Vader
Joined
·
64 Posts
Discussion Starter · #1 ·
I've seen quite a few people having problems with the GPS not turning on in the newest CM7 build (RC 0.6) so I decided to give you a simple guide to get it working again

1. make nandroid backup of your current CM7 install
2. wipe data/cache/dalvik (3 times!!! jk...once is enough)
3. install sense ROM of choice (BAMF 2.1/3.0 is my choice but it's up to you)
4. after sense rom is installed, open up maps and make sure GPS is working properly
5. boot back up into recovery, nandroid restore of CM7
6. ???
7. profit! your 4sq check-ins can resume now
 

·
Android Addict
Joined
·
1,497 Posts
This seems pretty accurate other than you wouldn't be able to load up Bamf 2.1 or 3.0 if you were on CM7. To do this properly load up a sense based ROM that uses the older non leaked radio so that you still have data.
 

·
teh Jax
Joined
·
2,677 Posts
miketoasty said:
This seems pretty accurate other than you wouldn't be able to load up Bamf 2.1 or 3.0 if you were on CM7. To do this properly load up a sense based ROM that uses the older non leaked radio so that you still have data.
Wifi works with the wrong radio. And since you just need this for a minute, I'd skip the radio flashing if possible. Just my $0.02 worth...
 

·
Tech Fiend
Joined
·
70 Posts
Still having problems with getting navigation working. Any ideas?
 

·
Android Beginner
Joined
·
6 Posts
GPS has been completely fine for me on CM7 RC1.1 with the MR2.5 radio, didn't have to do anything, just a standard data//cache//dalvik wipe before installing.
 

·
Android Beginner
Joined
·
5 Posts
Im gonna have to try that out because i cant get a lock for nothing... and turning off network location seems a lot quicker lol
 

·
aided by and dependent upon a mechanical or electr
Joined
·
170 Posts
I am rocking CM 1.2 and cant get a GPS lock for anything, and when I use Maps it tells me I am kansas, I live in FL... any ideas? I have tried everthing...
 

·
iPhone!
Joined
·
214 Posts
ssethv said:
I am rocking CM 1.2 and cant get a GPS lock for anything, and when I use Maps it tells me I am kansas, I live in FL... any ideas? I have tried everthing...
like I said I turned off network GPS and just left standalone GPS on. mine was telling me I was in texas when I live in michigan lol.
 

·
That one guy.
Joined
·
132 Posts
imneveral0ne said:
like I said I turned off network GPS and just left standalone GPS on. mine was telling me I was in texas when I live in michigan lol.
Have you tried the gps fix stated above? I have a hunch that wrong location via network gps and the no gps are somewhat related. Had the network gps issue saying i was in europe (when i'm in kansas) and no gps. As soon as i did the fix as stated above, i get gps lock with in 20 seconds or less and network gps is spot on.
 

·
Android Aficionado
Joined
·
412 Posts
Has anyone had any luck getting coarse or network location working in AOSP? Works in Sense when I did the GPS fix mentioned here, but I'd hate to eat my battery life with my weather app fruitlessly powering up GPS indoors every few hours.
 

·
aided by and dependent upon a mechanical or electr
Joined
·
170 Posts
I have tried everything mentioned and still cant get my NAV too work... really pisses me off, I love CM7 but just cant go without my nav for work related issues ;( perhaps soon slayer will release another candidate.. I would love to have an official working CM7 for the thunderbolt... we all feel left out ;) well, at least I do
 

·
Android Beginner
Joined
·
1 Posts
I backed up then wiped my CM7 install, installed Das Bamf, got a GPS lock, then wiped and restored CM7 again.

However, when I turned it on, every application force closed and I could not even get past the initial Google screen.

I'm doing an advanced restore using the data from a backup from the previous day. Any other ideas?
 

·
Android Addict
Joined
·
715 Posts
BennyJr said:
Does this actually work?
getting ready to try it, will report back in a min.

Edit: didn't work for me.
1. downloaded RC1.5
2. took gps.conf from das bamf 3.0 rc4.9
3. copied this gps.conf and replaced the same file in the rc 1.5.zip
4. flashed rc1.5
5. reboot
6. gps doesn't even start.
 
1 - 20 of 28 Posts
Top