Android OS Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
294 Posts
I just found this and I am so thankful that someone was willing to put the time into making such a detailed 'how to'. I ran into an issue right off the bat however... I am using TextWrangler and the .xmls are not showing up properly. The first task I wanted to tackle was the background and when I opened the .xml the line I am looking for isn't there. I am editing adamthecashew's mms.apk from AOKP and when I open the [background=rgb(245, 245, 245)]listitem_background.xml all I see is the following:[/background]

‰< 4Rdº¿'state_selecteddrawable
state_pressedandroid*http://schemas.android.com/apk/res/androidselectoritemÄ°ôߡˇˇˇ$ˇˇˇˇˇˇˇˇLˇˇˇˇˇˇˇˇˇˇˇˇˇˇˇˇˇˇˇˇˇˇˇˇˇˇˇˇ`ˇˇˇˇˇˇˇˇˇˇˇˇˇˇˇˇˇˇˇˇˇˇˇˇˇˇˇˇˇˇˇˇLˇˇˇˇˇˇˇˇˇˇˇˇˇˇˇˇˇˇˇˇˇˇˇˇˇˇˇˇˇˇˇˇˇˇˇˇ

I have already themed (almost) all of the .png files and installed it and it is working wonderfully, but I just cant figure out the background.
 

·
Registered
Joined
·
294 Posts
That is very strange. Stupid question, but you did decompile the apk before attempting to edit the xmls right?

If that isn't the issue I would suggest using something like notepad++ or another text editor and see if that fixes things.

Sent from my Galaxy Nexus using RootzWiki
When you say decompile what do you mean? Maybe I did that wrong? And I can't use notepad++, I am using a Mac (running newest OS).

Sent from my SCH-I535 using Tapatalk 2
 

·
Registered
Joined
·
294 Posts
I didn't use apktool because I can't get it to install on my Mac.

Sent from my SCH-I535 using Tapatalk 2
 

·
Registered
Joined
·
294 Posts
I appreciate the help guys, I figured out the issue I was having earlier, but now I can't get the Mms app to install. I have tried traditional install and replacing the Mms in the system/app but when I change permissions and reboot I have no Mms app when it boots up.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top