Android OS Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi

This damned *#*#4636#*#* menu!!!

I know, I shouldn't be messing with what I don't know but I moved from an iphone so that I could 'fiddle' with a phone hence the GNex.

Anyhow. I have been having serious issues in sorting this out until I pieced the information together in this post. None of this I can take credit for - as it is built on others work - I just put it together in one easily accessible place.

The problem is that this menu somehow wipes the SIM card's record of the SMSC number.

You can't just enter the SMS Centre number as it is, you have to convert it into something called PDU format (no idea what this is)

I have converted a number of UK SMS Centre numbers into the correct format below.

Method:
1. Go to phone dialpad.
2. Enter *#*#4636#*#*
3. Scroll down to the bit that says SMSC
4. Type your sixteen digit number in from the table below.
5. Press Update
6. Press Refresh
7. Press Back button to exit the app.
8. Test by sending an SMS

Hope that helps. The GNex doesn't give an option which is easily accessible from anywhere to change the SMSC number, downright silly as my 10 year old Nokia would let me do that.

Just to help a few peoples out in the UK:

Network, Number, SMSC to type in
Vodafone (Monthly), +447785016005, 0791447758100650
O2 (Monthly), +447802000332, 0791448720003023
O2 (Pay & Go), +447802092035, 0791448720900253
Orange, +447973100973, 0791449737019037
Orange, +447973100974, 0791449737019047
T-Mobile, +447958879879, 0791449785788997
Tesco, +447802092035, 0791448720900253
Virgin, +447958879890, 0791449785788909
Three, +447782000800, 0791447728008000
ASDA, +447785014315, 0791447758103451
GiffGaff, +447802002606, 0791448720006260

Hope that helps someone out there as it helped me. I've been pulling out my hair all day...
d
 

·
Android Beginner
Joined
·
20 Posts
Thanks for collecting all the info.

Everyone, just don't hit UPDATE when you go to that menu. That UPDATES the SMSC number with the blank space that's there, requiring the above fix.

Just going to the menu itself won't do this. User error is involved!
 

·
Registered
Joined
·
1 Posts
As a side note for those wondering how they are constructed from the 'normal' numbers and who haven't already spotted the pattern: replace +44 with 079144 and then swap the position of each pair of digits:
+441234567890 -> 0791442143658709

Sent from my Galaxy Nexus
 

·
Registered
Joined
·
3 Posts
I have this exact same problem with T-mobile US. I tried setting the smsc with 079121601303000F4 it's code for +12063130004, pressing update or not pressing update.

Seems doesn't have any impact on me. I still can't send any text messages. Btw I'm on manhattan 112, if that helps. OP what is your ROM?
 

·
Registered
Joined
·
6 Posts
another solution :

1. pull out your simcard
2. put in old phone non Android like symbian or whatever
3. enter your smsc number at SMS Setting and save.
4. put back simcard to your Gnex
5. problem solved, try sent SMS/MMS
 

·
Registered
Joined
·
20 Posts
another solution :

1. pull out your simcard
2. put in old phone non Android like symbian or whatever
3. enter your smsc number at SMS Setting and save.
4. put back simcard to your Gnex
5. problem solved, try sent SMS/MMS
Yeah that's what I did
 

·
Registered
Joined
·
3 Posts
As a side note for those wondering how they are constructed from the 'normal' numbers and who haven't already spotted the pattern: replace +44 with 079144 and then swap the position of each pair of digits:
+441234567890 -> 0791442143658709
I found this advice a little confusing at first. Since we don't all live in the UK, it's more accurate to say:

Replace + with 0791 and then swap the position of each pair of digits. For me in Finland for example +358451100100 becomes 0791534815011000.

Oh and in case anyone finds dialing [background=rgb(245, 245, 245)]*#*#4636#*#* tiresome, there's an app called Network by [/background]Philipp Mangelow [background=rgb(245, 245, 245)]in the Play store: [/background]https://play.google....angelow.network
 

·
Registered
Joined
·
1 Posts
Tried all the fixes I could find with no luck. Then found out that I had enabled Google Voice+ to send SMS messages through Google Voice. After I disabled this everything went back to normal.

Just another thing to try that worked for me.
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top