Android OS Forum banner
1 - 9 of 9 Posts

·
Android Beginner
Joined
·
3 Posts
As of 1425 CDT on 22-Aug 2011 it appears HP has unlocked the DEMO units; you may not need the steps below. I'll leave them here for reference.

Solution with the help of other posts [special thanks to user chekz here on precentral.net and & webOS roundup] This set of instructions will take your DEMO unit 32GB HP TouchPad and place it into Dev mode [and help you update to webOS 3.0.2 if you haven't already done so].

Just an FYI, the error that you receive after you flash to regular webOS 3.0.0 or 3.0.2 and can't move forward in registration is: PalmS3036 which is listed as "Device is Locked from doing FirstUse". This leads me to believe, like others, that it is merely a software reason and not a hardware one as to why we cannot use these like regular units.

This does remove the DEMO software, allows you to update to webOS 3.0.2, and keeps you from getting stuck on trying to register; however, It is untested on weather you can log into an existing webOS account. I am unable to create a webOS account as I don't own any other webOS devices and I do not know if this will impact your ability to register/unlock your DEMO unit in the future [if HP does so]. I would assume you should be able to use webOS Doctor once again to restore the unit as it was before this solution was developed.

Here is where i got the information:

Touchpad demo mode - (Page 5)

how can i flash stock rom? - (Page 3)

Activation-Bypass Tool - webOS Developer Center

====

You will need this file:
Right click and Save as: http://onebluepoint.net/chekz-devicetool.zip

or

FileServe Download (again thanks to chekz)

I. HP TouchPad Demo Unit Solution - Bypass Activation

Steps:

1. If you have not already, update to webOS 3.0.2

****a. To do this download this: http://palm.cdnetworks.net/rom/touchpad/p302r0d08012011/wifip302rod/webosdoctorp302hstnhwifi.jar

****b. Run the aforementioned file by double clicking (You must have Java installed; I did this on Windows 7 Ultimate 64-bit)

****c. Continue the setup until you get to the step where you are asked to connect your device with a USB cable. (But, do not connect your TouchPad at this step)

****d. On you TouchPad shut down the tablet (you should be able to do this by holding the power option for a few seconds and selecting the "Shut Down" option ; if you can't get that to come up you can force a restart by holding the "Home" button and power button at the same time for apx 5-10sec)

****e. Restart/Start-up you device holding the Power button and the Volume Up button (This boots the device into Recovery Mode) You will know if you are successful if you see the USB logo on your screen.

****f. Connect your TouchPad to your computer; on screen you should be able to hit the next button to allow your device to be updated.

****g. Allow 10-15min for the application to finish; at the end it will tell you the device is resetting. You will see a small HP logo on your TouchPad, disconnect the USB from your computer.

****h. Once the upgrade is complete and has loaded you can attempt to login or create and account but if you have a demo unit; you won't be able to register. [aka ERROR CODE: PalmS3036]

2. Power down your TouchPad (see step 1d for help if needed)

3. Hold down the Power and Volume Up button to allow your device to boot into Recovery Mode. You should see a USB logo on screen. (see step 1e for help if needed)

4. On your desktop, unzip the chekz-devicetool.zip file. You might want to copy this un-zipped file to your C: drive to make the next step easier.

5. You will need to open a Command Prompt (for Vista and/or Win7 you might need to run as Admin by right clicking on the icon in your Start>Programs>Accessories folder)

6. Change to the directory where the unzipped file is located (i.e. C:\chekz-devicetool )

7. Connect your TouchPad to your Computer

8. In your Command Prompt type the following command: java -jar devicetool.jar

9: You should see the following (your device will restart a time or two):



10. Once you see the "Device is ready." You can Disconnect your TouchPad from your computer.

11. When you power on your TouchPad, you should go straight to the home screen; by bypassing the activation screen.

-----

I don't have a webOS Account to log into to see of existing users can log into their accounts. I was able to use the stock applications and login to the existing applications like Facebook. I did this about 30 minutes ago so, I am still playing around.

==============

Update from 22 - Aug 2011 @ 13:45 CDT

After completing yesterday's work; Today my goal was to get this thing fully working. I was able to create and log into a webOS Account ad even access the App Catalouge. Steps below.

II. Create/Log in to webOS profile for DEMO 32GB Touchpads

Information found:

Installing Preware with WebOS Quick Install

WebOS Quick Install v4.2.3

Impostah

Steps:

1. Download WebOS Quick Install (check the links above)

2. Open the afrorementioned downloaded file (i.e. WebOSQuickInstall-4.2.3.jar)

3. If your TouchPad is not connected, you will get a message that says "No Devices Found". Connect your TouchPad and hit OK.

3. Click the third button on the right (the globe icon)

4. Select the Applications tab at the top

5. Search for Preware

6. Click Install.

7. On you Touchpad, on the home screen hit the Launcher icon (on the bottom right, looks like an arrow) and go to the Downloads Tab

8. Touch/open the program Preware

9. In the top right corner, touch/open the Magnifying Glass and type in "Impostah". Click the one result that comes up.

10. At the bottom of the description page you should see a Install button; touch/click to install the program.

11. Once the download and install is complete, you should be able to launch the program. (If you are brought back to the Launcher, Impostah can be found in the Downloads tab)

12. Once Impostah is launched, select the Activation button.

13a. For Existing webOS Account holders You should be able to type in your email address and password and hit Login To Profile.

13b. For New Users, type in the email address you wish to associate your account with and the password you wish to use. Then hit the Create New Profile button. You should see message asking you to confirm that you wish to proceed. To continue simply hit the green "Create New Profile" button.

14. To verify that your TouchPad has your webOS Account associated with your device. Open the Launcher, go to the Settings Tab, then touch/open the "Device Info" icon. You should see the e-mail address you used to register/log-in to your account listed in the "HP webOS Account" field. If the "Name" field is blank, you will need to tap the blank area and enter your name.

15. You are done! Enjoy! You can now access the HP App catalog and other webOS features.

If you want to verify your account was created, you canlog-in to your webOS Account here: Manage my HP webOS Account

Thanks to everyone else here and they guys over at webOS roundup for some guidance.
 

·
Android Beginner
Joined
·
9 Posts
I have a solution to complete legitimize your HP Demo unit. Once you bypass the unit get the Preware app store. Then get Impsostah. Use the activation option to create a webOS account. Clear the current webOS account using impostah. The device will reboot. Login with your webs account. Voila!

If someone who isn't a newb like me can put better instructions and step by step that would be great!
 

·
Android Beginner
Joined
·
3 Posts
Discussion Starter · #3 ·
Already done! I just updated the post I made. Although, word on the street is now HP has unlocked the DEMOs. YMMV, i'll leave up the instructions anyways :p
 

·
Android Beginner
Joined
·
6 Posts
I work at an officemax and i bought one of our boxed TPs and one of my associates bought the display. if you wanna make it a fully functioning Touchpad then find someone that has one that can download WebOS doctor and then just run WebOS doctor on it and it will basicly wipe the demo completely clean and put WebOS 3.0.2 on there and then u can make a WebOS account because demo units will not let u make one. I fixed my associates TP by doing this. You DONT HAVE TO DO THIS BIPASS CRAP. Just find a friend with a Touchpad and bam u will have ur demo working and downloading apps in like an hour
 

·
Android Beginner
Joined
·
2 Posts
I have two TP's bud. One was for my wife. Demo was mine. I did the wipe, doesn't let me create new acct. though.

getting PAMS3041 when trying to create new profile
when I try to sign in using my wife's profile I get PAMS9994

I repeated all steps a couple times and still no go.
 

·
Android Beginner
Joined
·
10 Posts
I think I might have solved the problem.

I followed the instructions in the OP and was still getting the error when trying to register a new webOS account even with Impostah. I decided to just play around with Preware and Impostah and see what stuff could be done to the touchpad. While doing so, I think I figured out how to get Impostah to register a webOS account on a demo touchpad.

These are the steps I did:

1. Follow the steps in the OP exactly. (Thanks bluepoint951)

2. When you reach the point that Impostah fails to register your new webOS account reboot your touchpad. (See OP for reboot instructions)

3. Open Preware and update Impostah.

4. Add the testing feeds in Preware for the touchpad (armv7) (Instructions here: Testing Feeds - WebOS Internals )

5. Tap Preware menu in top left corner and then choose "Update Feeds".

6. After feeds update, tap the magnifying glass at the top right.

7. Search for "Device Profile Service Override" (without the quotes) and install.

8. After install reboot your touchpad again.

9. After startup run Impostah again and activate a new account.

That's it. You should now get a successful activation with Impostah. You'll now have full access to the HP App Catalog and everything else that comes with having a webOS account.

I hope that helps everyone out. If you have any issues still, post them. I'll try and help.

Good luck everyone.

-Jovo55
 
1 - 9 of 9 Posts
Top