Android OS Forum banner
21 - 40 of 116 Posts

·
Banned
Joined
·
2,166 Posts
Discussion Starter · #21 ·
I had to use adb commands to root mine too. The rev tool wouldn't do it automatically.

Sent from my Sabotaged Droid Incredible 2.
I've used revolutionary on 2 different incredible 2's and never had to dive deep into adb. I wonder why.
As for anti-virus: I don't know why it would block it, but I don't use antivirus software. I'm just extra careful. :)
 

·
Android Beginner
Joined
·
689 Posts
Yea I couldn't figureout why it wouldnt work either. It would do most of it then it would stop. So I just ran the commands manually and it would perfectly.

Sent from my Sabotaged Droid Incredible 2.
 

·
Banned
Joined
·
2,166 Posts
Discussion Starter · #23 ·
Yea I couldn't figureout why it wouldnt work either. It would do most of it then it would stop. So I just ran the commands manually and it would perfectly.

Sent from my Sabotaged Droid Incredible 2.
I suspect that is was something to do with the sleep command for the windows script. You could always replace the lines with sleep 10 with pause and it might work.
 

·
DoseOfAndroid
Joined
·
40 Posts
So if this device was unlocked with the HTC Dev site previously, I should re-lock it first???

...Nevermind, I confirmed for myself. I relocked the bootloader just now, but hey... what the heck do I run exactly in attn's zip? there is a shell script and another file in there that can be run through command prompt, then there is zergrush which is just showing up as a 'File'
 

·
Banned
Joined
·
2,166 Posts
Discussion Starter · #27 ·
So if this device was unlocked with the HTC Dev site previously, I should re-lock it first???

...Nevermind, I confirmed for myself. I relocked the bootloader just now, but hey... what the heck do I run exactly in attn's zip? there is a shell script and another file in there that can be run through command prompt, then there is zergrush which is just showing up as a 'File'
Linux users run the shell script and windows users run the batch file. Windows users may have to change all the sleep 10's to pause
 

·
Registered
Joined
·
9 Posts
i need some help, Im halfway through with this but the command hack-vivow is not working. Also when i start to type the code from the xda site, i get an error on the second line. any help would be great
 

·
Banned
Joined
·
2,166 Posts
Discussion Starter · #29 ·
i need some help, Im halfway through with this but the command hack-vivow is not working. Also when i start to type the code from the xda site, i get an error on the second line. any help would be great
This might help you in running the script:
Windows users may have to change all the sleep 10's to pause
If you have unlocked via HTC dev you will need to relock first!
 

·
Registered
Joined
·
9 Posts
well i found my first problem, i had a bad download. it was completely different from the correct one, so idk what was up with that. Now my problem is that when i get to the fastboot rebootRUU it just says waiting for device on both the script and when i manually copy and paste from the original post. I read that this probably means that fastboot isnt working, but i believe it is working, i added it to the path
 

·
Banned
Joined
·
2,166 Posts
Discussion Starter · #31 ·
well i found my first problem, i had a bad download. it was completely different from the correct one, so idk what was up with that. Now my problem is that when i get to the fastboot rebootRUU it just says waiting for device on both the script and when i manually copy and paste from the original post. I read that this probably means that fastboot isnt working, but i believe it is working, i added it to the path
Check that drivers are installed for fastboot too, not just adb. In the bootloader, when you have the phone plugged into your computer, it should show "Android phone" in device manager, not listed as an unknown device.
 

·
Registered
Joined
·
9 Posts
Check that drivers are installed for fastboot too, not just adb. In the bootloader, when you have the phone plugged into your computer, it should show "Android phone" in device manager, not listed as an unknown device.
yeah i think my fastboot was messed up, i unistalled all the drivers and redid everything and it worked perfectly! thanks for the help and guide!
 

·
Banned
Joined
·
2,166 Posts
Discussion Starter · #33 ·
yeah i think my fastboot was messed up, i unistalled all the drivers and redid everything and it worked perfectly! thanks for the help and guide!
Glad it worked out for you. Have fun trying out new roms and stuff. I personally think that aeroevan makes great roms, along with kernels to go with them. You should check out his ICS rom.
 

·
Banned
Joined
·
2,166 Posts
Discussion Starter · #34 ·
Wizkid pmed me saying he could not get into recovery, he just got a yellow triangle. If this helps anyone, here is what I pmed him back.
You need to flash clockworkmod recovery. You can flash it in the bootloader by running this command.

Code:
<br />
fastboot flash recovery recovery-clockwork-5.0.2.0-vivow.img<br />
Where recovery-clockwork-5.0.2.0-vivow.img is the recovery image for clockwork mod on the Incredible 2. You can obtain the recovery-clockwork-5.0.2.0-vivow.img at http://download.cloc...0.2.0-vivow.img

If you need any more help, post in the panic room if you are soft bricked or bricked.
In windows, the drivers for fastboot may be different. If it does not work, do it in linux.
 

·
Nexus Member
Joined
·
154 Posts
FWIW I couldn't get the downgrade script to work until I reset the phone to factory. Just kept failing half way in, when it rebooted it never pushed anything to the phone even though I had USB debugging on and fastboot off. Just my 2 cents for anyone who runs into a similar problem.
 

·
Banned
Joined
·
2,166 Posts
Discussion Starter · #37 ·
FWIW I couldn't get the downgrade script to work until I reset the phone to factory. Just kept failing half way in, when it rebooted it never pushed anything to the phone even though I had USB debugging on and fastboot off. Just my 2 cents for anyone who runs into a similar problem.
Don't know why that would happen, but I'm glad it worked for you.
 

·
Android Lover
Joined
·
239 Posts
I've tried running (both as administrator and normally) the attn1 tool but nothing is happening. It just quickly opens and closes the cmd terminally and nothing happens. What do I do?

**EDIT**

so I got it to run, but now the script isn't working. It just sticks at a black screen with "htc" sitting on it. What do I do now?
 

·
Banned
Joined
·
2,166 Posts
Discussion Starter · #39 ·
I've tried running (both as administrator and normally) the attn1 tool but nothing is happening. It just quickly opens and closes the cmd terminally and nothing happens. What do I do?

**EDIT**

so I got it to run, but now the script isn't working. It just sticks at a black screen with "htc" sitting on it. What do I do now?
Keep it on the black screen with HTC. It should eventually install the update after 5 mins or so. Is there a progress bar?
 
21 - 40 of 116 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top