Android OS Forum banner
1 - 2 of 2 Posts

·
Android Apprentice
Joined
·
76 Posts
Hello everyone, I am hoping you all can help me with a problem I've been having that I can't seem to figure out. I am having a weird problem with my launchers on my DX. After either entering settings or undocking from my car dock, My launcher will show as blank, with no widgets, icons, or even dock bar.

The part that really gets me is that I am seeing this through multiple SBF's, data wipes, fresh app reinstalls, and multiple ROM's. It has happened on Go Launcher and Launcher Pro Plus while running Shuji (1 and 2), Liberty, and Liberty AOSP. I'm thinking something else has to be causing it but have no idea where to start... any ideas?

Edit:
I think I've isolated the problem. I found out that if I enter settings and then hit back, it makes all widgets/icons/dock disappear. If I leave settings by hitting the home button however; everything is normal. Furthermore, this only happens if I am using a live wallpaper; if I set a static wallpaper, there is no issue. So, it appears that my live wallpapers are misbehaving. Thing is, I'm not sure what to do about it. Any suggestions would be appreciated!
 

·
Android Apprentice
Joined
·
76 Posts
Discussion Starter · #2 ·
Well it appears I've solved the problem. In case anyone else runs into it, I fixed it by grabbing the LiveWallpapersPicker.apk out of the Liberty 0.8 flashable zip (over in the DX > Developer > Liberty thread) and replacing the file in my system/apps with the new one using Root Explorer. After a reboot, the problem disappeared and hasn't come back. Hope this can be of help to someone else!
 
1 - 2 of 2 Posts
Top