Android OS Forum banner
1 - 16 of 16 Posts

·
Android Beginner
Joined
·
8 Posts
Discussion Starter · #1 ·
Tried installing Liberty 2.0.1 the other day. Got root easily, installed BootStrap no problem. When I got to the recovery screen, installed the .zip, everything looked good. When I reset the phone, I get stuck at a screen that just says Liberty. That's it. If I do a battery pull, it goes back to the recovery screen.

I would try to SBF it back to stock, but I'm not sure if the computer will read it, as I had to disable USB Debugging in order to get BootStrap to work. Any ideas?
 

·
Android Nut
Joined
·
2,611 Posts
i see it's your first post. welcome to rootzwiki.

i'll try to help you out.

what rom were you on when you flashed liberty?

did you wipe per the instructions?

since you're stuck in bootloop, have you tried a data wipe/factory reset?

usb debugging and sbf have nothing to do with each other. just follow the directions here if you want to sbf http://rootzwiki.com/showthread.php?399-UPDATED-GUIDE-LINKS-DX-SBF-s
 

·
Android Beginner
Joined
·
8 Posts
Discussion Starter · #3 ·
Thanks razorloves. I appreciate the help. It was the first ROM I tried installing since rooting, I came from stock 2.3.3. I thought I followed the directions to a T, even with installing the Toolbox. I have tried a data wipe/factory reset, still no luck. Let me try going back to stock through sbf, will let you know how it goes.

Thanks.
 

·
Android Apprentice
Joined
·
36 Posts
That version of liberty is for 2.2.1 froyo. 2.3.3 is gingerbread. I belive you will need to sbf unless you can get into clockwork and restore your 2.3.3 backup.
 

·
Android Beginner
Joined
·
8 Posts
Discussion Starter · #6 ·
tried SBFing a few times, Failing each time. I followed the directions exactly, tried on RSD 4.8 and 4.9. I need to wait for my standalone charger to charge my battery before trying again. I wish I could remember the error code/message I receive, but I think it came when trying to flash the RAM or something like that? Would it be helpful if I copied the entire message, or does that not help anyone trying to help me?
 

·
Android Apprentice
Joined
·
36 Posts
Try Redownloading the sbf file it may be corrupt. I've only done froyo from 4.8 but there is a version 5.4 linked on the my droid world site somewhere. I installed it and it recognizes my phone but i have not flashed anything.
 

·
Android Nut
Joined
·
2,611 Posts
dannyjd said:
I have, thanks! I should be using Official Droid X 2.3.34 SBF Froyo 2.2.1, correct?
Since you said earlier that you want to flash Liberty 2.0.1, yes, that is the right one.

make sure you're following the instructions for flashing the sbf.

and also make sure you follow the instructions this time, for flashing Liberty 2.0.1. That will ensure you have no problems.
 

·
Android Beginner
Joined
·
8 Posts
Discussion Starter · #14 ·
Follow instructions? They should put the important parts in bold, like where it says its only supported on 320/340 droid Xs. Oh they did.

Thanks for your help!!
 

·
Android Nut
Joined
·
2,611 Posts
"dannyjd said:
Follow instructions? They should put the important parts in bold, like where it says its only supported on 320/340 droid Xs. Oh they did.

Thanks for your help!!
Lol. No problem man.
Let us know if you run into any more snags. We'll be glad to help you out
 

·
Android Beginner
Joined
·
8 Posts
Discussion Starter · #16 ·
Thanks for the help guys. After numerous attempts on an old windows machine, i was able to SBF on my mac. That said, I am now up and running on Liberty 2.0.1 at the moment. Big ups to razorloves and Leon for your help.
 
1 - 16 of 16 Posts
Top