Android OS Forum banner
Status
Not open for further replies.
1 - 20 of 159 Posts

·
evolution noob
Joined
·
89 Posts
Hey guys noticed my available ram is low since AOKP jb mr1-b2 and now mr1-b3. Multitasking is very slow and the phone is really sluggish at times. Here's a picture from android status and it shows system server taking up most of the ram. Is that normal? What have you guys experienced? Any way of fixing it?

Adding this on Toro

Sent from my Galaxy Nexus using Tapatalk 2
 

Attachments

·
Premium Member
Joined
·
909 Posts
I actually noticed the same but so far I am not sure if it happens because of an app or if it is the ROM. Because my Nexus 10 doesn't leak memory I think it must either be specific to maguro or as said an badass app. I didn't had the time to investigate and so far I am just rebooting every now and then.

Marc
 

·
Registered
Joined
·
44 Posts
Toro with the same issue on mr1-3. I came over from Vanir with the same apps installed and did not have the issue there, so this appears to be ROM specific.
 

·
Android Apprentice
Joined
·
507 Posts
I am also having this issue. Noticing a lot of home redraws and even app redraws that I didn't see previously.
 

·
Android Beginner
Joined
·
31 Posts
I had this same issue. Thought maybe I had a bad flash so I wiped everything (even system) and reflashed. The issue persisted. On a whim, I decided to flash Dizzy's unofficial AOKP build and my ram usage was as bit better, but my screen redraws are back. The phone is pretty laggy currently. Hope this gets fixed soon.

Sent from my Galaxy Nexus using Tapatalk 2
 

·
Android Apprentice
Joined
·
507 Posts
I had this same issue. Thought maybe I had a bad flash so I wiped everything (even system) and reflashed. The issue persisted. On a whim, I decided to flash Dizzy's unofficial AOKP build and my ram usage was as bit better, but my screen redraws are back. The phone is pretty laggy currently. Hope this gets fixed soon.

Sent from my Galaxy Nexus using Tapatalk 2
I had good luck with fitsnugly's latest AOKP build. No more redraws for me.
 

·
Android Apprentice
Joined
·
507 Posts
I had good luck with fitsnugly's latest AOKP build. No more redraws for me.
Actually I take that back...it starts out good after a reboot but eventually SystemUI keeps growing in the amount of RAM it takes up for some reason. I think that is why we are getting redraws. Wonder if SystemUI grows because of the hidden navbar feature? Personally I don't use it though. Here are screenshots showing what I'm talking about. The first is after a reboot, the second after a few hours of uptime. Notice how SystemUI more than doubles in the amount of RAM it takes up. It also moves from a service only app to an active application, not sure if that means anything.
 

Attachments

·
Premium Member
Joined
·
1,812 Posts
Actually I take that back...it starts out good after a reboot but eventually SystemUI keeps growing in the amount of RAM it takes up for some reason. I think that is why we are getting redraws. Wonder if SystemUI grows because of the hidden navbar feature? Personally I don't use it though. Here are screenshots showing what I'm talking about. The first is after a reboot, the second after a few hours of uptime. Notice how SystemUI more than doubles in the amount of RAM it takes up. It also moves from a service only app to an active application, not sure if that means anything.
Are you using Hidden NavBar?
 

·
A Dragon
Joined
·
303 Posts
My Nexus7 and Gnex both on build 3 are really sluggish. Gnex only had less than 50 mb ram to use on a fresh reboot.
 

·
Premium Member
Joined
·
1,812 Posts
Do you guys happen to use lockscreens?

I'm not experiencing any sluggishnes ... but there is a discussion going on right now amongsts the devs about a possible memory leak in system_server. we may have tracked it to locksreen issues.

I only use the slide lock, not any kind of security, and that may be the difference.
 

·
A Dragon
Joined
·
303 Posts
Do you guys happen to use lockscreens?

I'm not experiencing any sluggishnes ... but there is a discussion going on right now amongsts the devs about a possible memory leak in system_server. we may have tracked it to locksreen issues.

I only use the slide lock, not any kind of security, and that may be the difference.
Only System lockscreens, slide to unlock.
 
  • Like
Reactions: tocKreativ

·
Flash first, ask about stability later.
Joined
·
49 Posts
Do you guys happen to use lockscreens?

I'm not experiencing any sluggishnes ... but there is a discussion going on right now amongsts the devs about a possible memory leak in system_server. we may have tracked it to locksreen issues.

I only use the slide lock, not any kind of security, and that may be the difference.
Only slide lock for me. No additional lockscreen widgets. I didn't notice this issue with build 2. Memory usage is definitely traceable to the system_server process (currently at ~240MB and growin after 12 hours of uptime).
 
1 - 20 of 159 Posts
Status
Not open for further replies.
Top