Android OS Forum banner
1 - 20 of 28 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter · #1 ·
I can't find any instructions on how to enable the hotplug governor in Franco.Kernel nightly 13.

Franco has released an app which does this automatically, but I don't have a credit/debit card so can't purchase it. Apparently the release notes for the Kernel give instructions on how to do this, requiring the typing of some script in some location. I see some console commands in his release notes, but they are non-transparent.

Can anyone tell me the necessary steps to enable the hotplug governor for Franco.Kernel that doesn't require purchasing of his application?
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #5 ·
Thanks for your replies. In the OP I mentioned I can't purchase it because I don't have a debit or credit card.

Also I am aware that there are instructions somewhere hidden in Franco's post, and as I mentioned they are not very clear or thorough, so I am posting here to get better instructions.
 

·
I play with lazers (literally)
Joined
·
513 Posts
You could use lean kernel with interactivex which is basically hotplug, but can't you borrow a friends card for 1.80?

Sent from my Galaxy Nexus using Tapatalk
 

·
Registered
Joined
·
17 Posts
I didn't mention that I came from lean, which I left because it had the same problem with battery. However I didn't use interactive x, so i will try that tomorrow if i have no progress by then

Also, thanks for the repeated suggestions to buy, but I am trying to figure out how to enable hotplug without the paid app.
 

·
Registered
Joined
·
91 Posts
you need to use terminal emulator or an app similar .

when u are at the cmd prompt in the emulator type "su" then press enter. It will ask you for root permissions.

then enter this exactly "echo 1 > /sys/module/dsscomp/parameters/hotplug_enabled" hit enter and your done

you can also edit the build.prop by just changing the echo 0 to echo 1 in root explorer if you know how to use that as well.

hope this helps
 

·
Registered
Joined
·
17 Posts
Thanks for those tips. Typed that into console, nothing happened, ie set CPU does not give me the hot plug option. might require a reboot. Went to file explorer to edit build prop but there was no text anywhere that said echo. I checked line by line. Search for string "echo" returns no results so I know it isn't there.
 

·
Registered
Joined
·
198 Posts
Thanks for those tips. Typed that into console, nothing happened, ie set CPU does not give me the hot plug option. might require a reboot. Went to file explorer to edit build prop but there was no text anywhere that said echo. I checked line by line. Search for string "echo" returns no results so I know it isn't there.
That's...not...how...it...works.

Sent from my Galaxy Nexus using Tapatalk
 

·
I CAN'T STOP IT'S TOO DANGEROUS
Joined
·
654 Posts
Thanks for those tips. Typed that into console, nothing happened, ie set CPU does not give me the hot plug option. might require a reboot. Went to file explorer to edit build prop but there was no text anywhere that said echo. I checked line by line. Search for string "echo" returns no results so I know it isn't there.
Even if its enabled I don't think it shows in SetCPU because I have Franco's app and SetCPU and even with hot plug enabled in Franco's I see no difference in SetCPU

Sent from my Galaxy Nexus using Tapatalk
 

·
Registered
Joined
·
32 Posts
Navigate to "/sys/module/dsscomp/parameters/hotplug_enabled" with explorer. Open file with text editor, change value from 0 to 1, save and exit; done.

Or use terminal emulator and type "su" then enter, then type "echo 1 > /sys/module/dsscomp/parameters/hotplug_enabled" then enter, then type "exit" enter, type "exit" enter.
 

·
Android Moose
Joined
·
159 Posts
Navigate to "/sys/module/dsscomp/parameters/hotplug_enabled" with explorer. Open file with text editor, change value from 0 to 1, save and exit; done.
I've personally done this and the change does not stick. You have to check it in the app or echo it in terminal. The only good browsing to that file does is to verify it is enabled or not.
 

·
Registered
Joined
·
17 Posts
That's...not...how...it...works.

Sent from my Galaxy Nexus using Tapatalk
Thanks for taking the time to put so much thought into your suggestion, your post was quite helpful and full of useful insight.

@JJ hunter Et al.

Thanks for these tips. I have found that the hotplug is in fact enabled, using file explorer to check that file. Despite the fact that it is enabled, it still doesn't show in SetCPU. So apparently we are at an impasse. I also just upgraded to FKernel nightly 13.1 to see if that would help, but it does not.
 

·
Registered
Joined
·
198 Posts
Thanks for taking the time to put so much thought into your suggestion, your post was quite helpful and full of useful insight.

@JJ hunter Et al.

Thanks for these tips. I have found that the hotplug is in fact enabled, using file explorer to check that file. Despite the fact that it is enabled, it still doesn't show in SetCPU. So apparently we are at an impasse. I also just upgraded to FKernel nightly 13.1 to see if that would help, but it does not.
Well there's countless people asking the same question in other threads in regards to why it doesn't show up in SetCpu. If you had really researched you would've known that hot plug in Franco's simply doesn't work that way. You're screaming for help but refusing to use a search tool.

Sent from my Galaxy Nexus using Tapatalk
 

·
Registered
Joined
·
17 Posts
Well there's countless people asking the same question in other threads in regards to why it doesn't show up in SetCpu. If you had really researched you would've known that hot plug in Franco's simply doesn't work that way. You're screaming for help but refusing to use a search tool.

Sent from my Galaxy Nexus using Tapatalk
You've made it clear that your time and ego are too valuable to provide the solution.
If you really were trying to be helpful, I apologize for misconstruing your intentions, and sincerely thank you again for your indispensable contributions to our discussion.
 

·
Registered
Joined
·
198 Posts
You've made it clear that your time and ego are too valuable to provide the solution.
If you really were trying to be helpful, I apologize for misconstruing your intentions, and sincerely thank you again for your indispensable contributions to our discussion.
Alright alright. I'll direct link you to the obvious Google results next time. I'll hand-feed you some grapes too.

Sent from my Galaxy Nexus using Tapatalk
 

·
Registered
Joined
·
13 Posts
I got it working with terminal emulator using the same "input" as in this blog. After pushing enter I exited out terminal. Then I let it sleep on its own. When I woke it up it flickered while illuminating. I have not experience that with his tons before. It sleeped again and then lit up normally on waking up. I turned off the phone for a few and back on. Runs great just have to see if battery improves.

I'm running nightly 13.1 not 13 or 12. I have heard of problem with those on the hot plug. 13.1 has c4 enabled (deeper deep sleep). I have left the phone for 10 hours overnight with out charge from 100%. It went down to 92% on the morning I woke up and that is before franco hotplug.

Running codename android rom 1.1.4.

Sent from my Galaxy Nexus using Tapatalk
 

·
Registered
Joined
·
5 Posts
Hi all,

I have trying to enable the hotplug for the power saving.

After checking, even I change the parameter in hotplug_enabled, it would be restore after restart the devices.
So I want to place it in init.d folder for running.

But I found the init.d did not run.

I use the rom from bigxie and franco.kernel.

Did anyone knows why the script not works?
 
1 - 20 of 28 Posts
Top