Android OS Forum banner
1 - 3 of 8 Posts

· Android Beginner
3 Posts
Discussion Starter · #1 ·
First post, so Hello! Still pretty new to this so please excuse me if my explanations are long winded. Rooted and Rom'd my Atrix and now also have a Thunderbolt and have pursued the same goal but have run into some roadblocks.

DEVICE: Thunderbolt (Mecha)
HBOOT SAYS (no idea if this is important):
- Revolutionary -
HBOOT - 6.04.1002
Feb 23 2011, 20:42:55

ISSUE: After flashing CM7, phone will not find a signal, displays "Searching for Service", "Baseband" in About Phone displays "Unknown"

Used revolutionary to gain S-OFF, and install CWM. Downloaded the latest release from the thread here, checked the MD5 (matched!), booted to CWM, Wiped Data/Wiped Cache/Wiped Dalvik, installed zip. Waited 15 minutes AFTER first boot (from recommendations here), no signal. Had a dee-dee-dee moment, doesn't come with a radio? k.

Started with the the radios from 1.12.605.6 RUU (Stock), both CDMA and LTE. Hboot, volume up once it's checked it, reboot, repeat for LTE. No signal. Reflashed CM7, reflashed radio, still no signal. First noticed "Baseband Unknown".

Reflashed CM7, found a thread that said I needed an MR2 radio, which more reading led me to interpret basically meant "Newer Gingerbread Radio". This led me to the CDMA from 2.11.605.0 RUU, and the LTE from 2.10.605.1 RUU. Flashed CDMA, flashed LTE, no signal. Reflashed CM7, no signal, redid radios, no signal.

Found a stock image and returned the phone to stock (with S-OFF), signal found, data/phone works right away. Reflash w/Stock radios, reflash w/Gingerbread radios, still no dice.

Im back at stock at the moment and totally stumped as to what I'm doing wrong. Ive spent quite a bit of time on google over the past 3 days, here, and on XDA trying to find ANYONE with my problem. But every thread or article that references CM7 (or any AOSP rom without a radio) and no signal ends up just needing a radio.

Any advice?
Thanks for the help.

· Android Beginner
3 Posts
Discussion Starter · #6 ·
So here are the steps I took.

Redownloaded (checking md5's) CM7 1.7, gapps, and the suggested radio 0817r.
Formatted SD card using CWM
transferred files to fresh SD card.
power off
boot to cwm
wipe data/factory reset, wipe cache, wipe dalvik cache
flash CM7, flash Gapps, reboot. Didn't touch phone for 10 minutes after first boot (settle in??)
Skip registration, use file manager to rename -PG05IMG to just PG05IMG
shut down, flash radio. reboot.

worked! thanks all

· Android Beginner
3 Posts
Discussion Starter · #8 ·
Thanks for the tips iszcr.

Was walking through all my steps as I did them, half expecting them not to work cause I was gettin frustrated then BAM. Was gettin irritated cause it stopped Searching for Service, but still didn't have any, then a bar, then 2 bars. Scored!
1 - 3 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.