Android OS Forum banner
1 - 20 of 44 Posts

·
Supporting Member
Joined
·
265 Posts
lortay78 said:
Just failed on flashing a kernel for me. Error says it wasn't signed correctly.
I agree. Thank you. It does allow you to toggle off the signature check, so I was able to flash the kernel.
This is my first time really using Amon Ra. I only tried it once when helping a friend with her evo. Seems nice so far. I have counted on clockwork for three of my phones now, and I have had a few problems with it not wiping in the past. I assume those issues have been solved now, but it is nice to have options.
 

·
Former #1 troll.
Joined
·
1,413 Posts
Discussion Starter · #13 ·
unzip this to your android sdk/ tools folder. take your existing zips for roms and kernels/themes and put them in the folder. rename them "update" and hit the sign batch file, it will sign the zips properly. it will create a signed.zip and then you can rename it and flash away. sign them one at a time only.

enjoy!
 

Attachments

·
Kernel Dev
Joined
·
880 Posts
"fixxxer2012 said:
funny as i had to re-sign all my zips.
Over the past few days, I gave myself a crash course in recovery images and the code used to make twrp and cwm and some of ra. I know for a fact that this recovery is no diffrent from all the custom recoveries (besides the fact that it supports amend, which is really nothing). All it does is enable signature verification by default. All of your zips will flash normally if you turn verification off in the zip install menu (or if its disabled in the code).

Also, cwm has no zip dependencies. All zips are universal, and will work for cwm, ra, and twrp. No zips are build specifically for one recovery.
 

·
Average Android
Joined
·
286 Posts
I had some problems I posted at xda and will post here as well.

Been playing around with amon recovery and now stuck at the splash screen. I was converting a cwm backup to amon recovery and now stuck at the splash screen.
Here's what I did.
Flashed amon recovery created a backup of current rom cm7.
Booted to cm7
Flashed back to an older recovery of cwm
Booted to recovery, (cwm). Restored a backup.
Booted bamf
Flashed back to amon recovery
Rebooted recovery (amon)
Created a backup of rom with amon
Tried to restore initial rom (cm7) and it hangs at the splash screen.

Tried wiping and then restoring with no luck.
So I tried restoring another backup
Restored the bamf backup fine.
 
1 - 20 of 44 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top