Android OS Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter · #1 ·
So, I was trying to root my Kindle Fire this morning, and successfully did it, but the Superuser app kept crashing (just giving background in case it is needed). I used the Kindle Fire Utility that was on XDA, and everything worked, except now my kindle will not boot into the GUI, it only reboots to the bootloader, then goes straight to recovery, even without pressing the power button. I tried connecting the tablet to the computer, but it will not show up on adb. Any help?
 

·
Android Beginner
Joined
·
19 Posts
Hey there.

Without being there in person to see your tablet and what exactly its doing, or how it got that way, it sounds like you might be stuck in IDME 4002, which is a fastboot mode that always spits you right back into TWRP without pressing the power button at the yellow triangle bootloader screen. Give the following a try, on a windows machine (I'm going to assume you're at least a little familiar with ADB commands and basic windows functionality):

- Plug in your KF at the recovery screen to your computer.
- Download the latest Kindle Fire Utility to your desktop and extract it... here
- In the extracted file, you'll find a file called "install_drivers.bat" or something like that; double click and install the drivers
- In the bootmode screen of the Kindle Fire Utility, choose option #1 (Bootmode Menu)
- In the Bootmode Menu screen, make sure that your ADB status says "online". If it doesn't, try rebooting the KF by holding the power button in for about 10-15 seconds (it will reboot automatically).
- Choose option #1. This will reset your fastboot to mode 4000, allowing you to reboot into whatever version of android you had been running, assuming that you haven't wiped the system in an effort to fix this problem. If you DID do a complete wipe, be sure to reflash a ROM / GApps before you try to reboot.

Let me know if this did the trick...

-x-

EDIT: If you haven't tried ICS on the KF yet, may I humbly recommend this ROM, which is basically a themed beta version of some of the work being done by Hashcode and JackpotClavin (and slickly themed by Zone23) on XDA. Most stuff is working very well, with the notable exceptions being Netflix and Bluetooth. GApps are already installed on it, I believe. Good luck!
 
1 - 2 of 2 Posts
Top