Android OS Forum banner
1 - 20 of 26 Posts

·
Premium Member
Joined
·
272 Posts
Welcome to Eclipse! Eclipse is 100% open sourced and based off of the latest 4.3 AOSP code.

All firmware and kernel source can be found at: http://github.com/nitroglycerine33

EclipseAOSP1small.png

EclipseAOSP2small.png

Build does not have softkeys enabled
invertedAllApps.png


Eclipse features overview
It is pretty vanilla AOSP android at this time but there are a few additions I have made so far

General UI
-Theme engine
-Reboot options
-Screenshot option
-Customize lockscreen hotseats
-Eclipse mode - Choose between light and dark themes

Input Controls[/b]
-Volume rocker controls (wake, skip tracks)
-Long press back to kill
-Hardware key remapping
-Home button wake - on/off
-Volume panel and ability to unlink/link notifications & ringtons
-Clear all recents

Statusbar options
-Clock (Hide, center, right), Day of the week
-Signal text
-Combined notification count
-Battery Bar options
-Battery text
-Battery style options
-Power widgets/toggles
-Quick settings/tiles

Misc apps/settings
-Quick reply Mms with emoji
-DSP manager
-Modded AOSP camera
*Choose storage location
*Power shutter
*Enhanced shutter speed
-Quiet Hours
-CM File manager
-Terminal emulator
-Embedded Superuser
-LockClock
-USB audio
-Trebuchet Launcher
-Advanced settings for kernel tweaks (color temp, vibration, backlight, sound)
-Profiles
-Notification and battery LED control

Changelog
Build 5
-Updated Google Apps to fix face unlock
-Added Profiles
-Notification led settings
-Battery led settings
-Expandable volume panel
-Ability to link/unlink ringtone/notification sounds
-Quiet Hours
-Hardware key remapping
-Volume rocker controls (wake, skip tracks)
-Clear all "recents"
-Added a shortcut to clock/weather widget
-Trebuchet launcher and added shortcut in Settings
-Updated light theme for cleaner images
-Updated dark theme images to high resolution images
-Enabled autocomplete/t9 by default
-Updated S4 Luna kernel to Linux 3.4.60 and added native exFat support
-Fixed an issue where the camcorder was only using one mic

Build 4
-Eclipse mode toggle (Choose between dark/light themes)
-Cleaned up light theme
-New modded AOSP camera with timer, power shutter
-Revamped MMS app with several new features from build 3
*MMS breath
*Direct call - picking up the phone calls the current contact
*Adjustable text sizes
*Emoji
*Easy selector list for picking multiple contacts
*Hide avatar
-Enable T9 by going into dialer settings and uncheck and recheck Dial pad autocomplete
-Fixed green lines in foward facing camera (S4)
-Enhanced camera hardware support
-Added Focal camera for those who would like to play with it

Build 3
-Fixed many Bluetooth streaming issues
-Added IRDA remote control ability
-Updated build to 4.3_r2.2 (JSS15Q)
-Updated kernel for exfat and Linux 3.4.59
-Microphone disabling on S4 should be resolved
-Added power widgets
-Added quick settings tiles
-Added torch (as well as a flashlight toggle)
-Several audio enhancements
-Several performance enhancements
-Customize lockscreen hotseats

Build 2
-Fixed SunBeam live wallpaper
-Theme engine
-Reboot options
-Screenshot option
-Added Eclipse bootanimation

-Statusbar options
*Clock (Hide, center, right), Day of the week
*Signal text
*Combined notification count
*Battery Bar options with color picker
*Battery text
*Battery style options

-Modded AOSP camera
*Power shutter
*Set storage location
*Much more!

Build 1
-Initial build
Known Issues
-HDR takes dark photos

Downloads

Firmware
Build 5: http://www.androidfilehost.com/?fid=23060877490004899

Download Google Apps *updated 9/3/13 (use one or the other)
Gapps (inverted/dark): http://www.androidfilehost.com/?fid=23060877490004901
Gapps (light/white): http://www.androidfilehost.com/?fid=23060877490004900

Donate
https://www.paypal.com/cgi-bin/webscr?cmd=_donations&business=GJ26YYQA986PJ&lc=US&item_name=Elemental%20X%20Designs&currency_code=USD&bn=PP%2dDonationsBF%3abtn_donateCC_LG%2egif%3aNonHosted
Donations are not expected but always greatly appreciated. Thank you for supporting Elemental X!
Follow me on Twitter: nitroglycerin33

How to Install:
1. Wipe Data / Factory Reset
2. Flash Rom
3. Flash Google Apps
4. Enjoy

Already Running an Eclipse build?
1. Flash Rom
2. Flash Google Apps
3. Enjoy your updated build

Having issues with Titanium Backup not working on 4.3 roms?
Here is a guide to fix backups/restores with AOSP 4.3:
http://www.elementalxdesigns.com/eclipse/showthread.php?4084-How-to-fix-Titanium-Backup-when-using-a-4-3-Firmware
 

·
Registered
Joined
·
568 Posts
I'll be flashing this once ME7 gets the bootloader unlocked. I already have it downloaded.

Sent from my SCH-I545 using Tapatalk 4

 

·
Premium Member
Joined
·
272 Posts
Discussion Starter · #5 ·
Nitro, have you ever built for GSM?
No I have not. But it would take me 5 minutes to add the device repo. Everything is setup in my source for it.
 

·
don't say yolo around me...I will slap you&#33
Joined
·
107 Posts
been running this for about 2 hours now, coming from carbon, this a really smooth rom! love it! keep up the good work, I think this might be my daily driver for a while now.
 

·
Supporting Member
Joined
·
180 Posts
Anybody having trouble with wifi? I cannot even get it to turn on, much less try to connect. Neither the little slider switch nor long-pressing is enabling wifi. Clean flash. Not sure if it's universal, or just that I'm very special today LOL.
 

·
Premium Member
Joined
·
272 Posts
Discussion Starter · #13 ·
I use wifi everyday and it works just fine. Did you flash a different kernel or some weird baseband?
 

·
don't say yolo around me...I will slap you&#33
Joined
·
107 Posts
Anybody having trouble with wifi? I cannot even get it to turn on, much less try to connect. Neither the little slider switch nor long-pressing is enabling wifi. Clean flash. Not sure if it's universal, or just that I'm very special today LOL.
WiFi working perfect here!

Sent from my SCH-I545 using Tapatalk 4
 

·
Supporting Member
Joined
·
180 Posts
I use wifi everyday and it works just fine. Did you flash a different kernel or some weird baseband?
No, on the ME7 radios. I have since flashed a different kernel in a futile attempt to fix it. Never thought to reflash the MDK radio. Will try that once things get back to normal around here.
 

·
don't say yolo around me...I will slap you&#33
Joined
·
107 Posts
Got two random reboots today.
Is there any specific way you want us to submit big reports? Or are you not doing doing that at the moment?

Sent from my SCH-I545 using Tapatalk 4

 

·
Premium Member
Joined
·
272 Posts
Discussion Starter · #19 ·
Got two random reboots today. Is there any specific way you want us to submit big reports? Or are you not doing doing that at the moment? Sent from my SCH-I545 using Tapatalk 4
Are you using a different kernel or have you modified any kernel settings? Because you are probably alone on the issue. If you PM me the logs I can look at them.
 

·
don't say yolo around me...I will slap you&#33
Joined
·
107 Posts
Did you dirty flash the update?

Sent from my SCH-I545 using Tapatalk 4
Got two random reboots today. Is there any specific way you want us to submit big reports? Or are you not doing doing that at the moment? Sent from my SCH-I545 using Tapatalk 4

Are you using a different kernel or have you modified any kernel settings? Because you are probably alone on the issue. If you PM me the logs I can look at them.
This is a clean install coming from carbon.
I'm not using a different kernel or any modified settings

If it happens again I'll send you some logs.

Sent from my SCH-I545 using Tapatalk 4
 
1 - 20 of 26 Posts
Top