Android OS Forum banner

[ROM GUIDE] How to install Android 2.3-4.3 on the HP TouchPad "The Easy Way"

1867938 Views 3709 Replies 482 Participants Last post by  nevertells
Hello and welcome to the full "Easy Way" guide for installing Android on the HP TouchPad.

Additional resources:
XDA Version of this thread here
[ROM GUIDE] How to install Android 4.4.2 Data Media builds on the HP TouchPad

[ROM GUIDE]How to use the TouchPad Toolbox to install Android "The Super Easy Way" (DM and Non-DM)

[ROM GUIDE] How to Update/Install Android 4.2, 4.3 and 4.4.2 Builds on the HP TouchPad(Non-DM)

News and Updates

Get the latest android 5.x.x and 4.4.x DM Kitkat builds with the New Super Easy Install Guide featuring Jcsullins TPToolbox!

Note: This is the latest how to guide for installing android on the HP Touchpad!

[ROM GUIDE]How to install Android 5.x.x/4.4.x with Jcsullins TPtoolbox (click here)

How to install Android on the HP TouchPad "The Easy Way"(Android 2.3-4.3)


How to Uninstall Android The Easy Way Guide Video(click here)

How to make a Nandroid backup video(click here)
Note(Important) I highly recommend you make a Nandroid backup after installing and setting up Android on your HP TouchPad. This perfectly preserves your current configuration and can easily be restored through CWM or TWRP Recovery.

General Unofficial Release Notes(Important):
-Sound and Mic
-H/W Video
-WiFi & Bluetooth
-Most builds have a Low to medium battery drain during sleep -4mA to -10mA or -4mA to -30mA(See below)

Known Issues:
-Dirty flashing older builds (CM9/CM10) over newer builds (CM10.1/CM10.2) will result in Boot loops.
-If this happens use your backup or do a fresh install, Click here for a how to Video:
-Flashing CM9/CM10 Over CM10.1/CM10.2/CM11 through CWM or TWRP, can cause a boot loop.(use a Backup)
-Doing an install with ACMEInstaller can sometimes result in a boot loop. Use a backup or flash the Rom and Gapps package through CWM or TWRP.

The usual HP TouchPad battery drain issues:
-If your battery is heavily drained, then you may need to leave it charging for a full day.
-When the battery is fully drained it can take the TP a longtime to reach even the lowest battery level.
-The USB cable that comes with the HP TP is often defective and breaks easily. Try using another USB cable if possible.
-The USB cable does not transfer enough power to effectively charge the tablet. You must use the wall plug when charging the HP TouchPad.
-To be safe don't let your HP TouchPad run out of Batteries ever! Install one of these free apps!
-You can add an automatic shutdown Rule by doing the following.
-AutomateIt, Play Store Link- What to do: New Rule/Trigger Battery level(Below 20%)/Action/Shutdown//save. Or
-Llama, Play Store Link- Location Profiles:Event tab choose + (at the bottom of the screen) Addcondition (battery Level Below 20%) Actions (turn off phone)

1)Getting started, Requirements and Preparation:
Start by downloading and Installing both Java and the Novacom Software onto your PC or Mac Computer. These files are required before doing the next step.
You will need to have Java installed to run the Universal installer. Click here:
Download and run the Universal Novacom Installer 1.4.1. Click here:
Note: You may need to reboot after installing this software.
Note: If you're having issues getting the Novacom drivers installed disable any antivirus or spyware protection that might be preventing the app from downloading the correct drivers for your system.


Download, extract and install the appropriate version of Novacom for your OS. Click here:
Note: Under Linux the Novacom driver is installed at /opt/Palm run it from this location.

2)The Novacom software you installed will create a new folder called Palm, Inc. You will need to place the ACMEInstaller5/5E/5m and ACMEUninstaller2 files into this Palm, Inc folder. By default this folder will be located on your PC @ C:/Program Files/ Palm, Inc. Mac OS X users will find this folder @ /opt/nova/bin. Download the files and copy and paste them right into either of these directories.

a] ACMEInstaller5 (Install CM7, CM9, CM10, or Flash .zips located in the cminstall folder)

b] ACMEInstaller5E (Install Evervolv AOSP Android, or Flash .zips located in the cminstall folder)

c] ACMEInstaller5M (Install CM10.1,CM10.2, or Flash .zips located in the cminstall folder)

D] ACMEUninstaller2 (uninstalls Android and removes recovery, All versions)

Click the picture below to see the PC location:
Photograph White Light Product Font

3) Choose One of the following versions of Android. Download your chosen package and extract it to your PC. The extracted cminstall folder will contain 4.zipped files needed to install Android. Next attach your HP TouchPad to your PC with the USB cable and place it into USB Drive Mode(WebOS) or MTP mode(Android). Open the extracted folder and transfer the cminstall folder(Contains 4 .zips) into the Internal Storage of your HP TouchPad; the location the opens when the USB is attached to the PC/Mac. Make sure that the folder is named "cminstall" and contains files. Once complete disconnect your TouchPad from the USB cable.

Android Installation Package Downloads:

a]Evervolv AOSP Android 4.3.1 JB (20140129) cminstall package Download:
Notes: Low battery drain(-4mA to -10mA) h/w video, Audio & Mic, Camera, Bluetooth, Automated Updater.

Note: May have rebooting issues with the gallery app crashing, try a different one here
Note: Windows users may need to do the following in order to attach the Touchpad with the USB cable.
1. Go into the Device manager. You will see "MTP USB Device" under portable devices.

2. Right Click it and select update driver software

3. Select Browse my computer for driver software.

4. Select Let me pick from a list of device drivers on my computer

5. Select USB Mass Storage Device then click next.

6.Turn on USB mass Storage from the USB connection notification on the Android device

b]CM10.2 Android 4.3.1 JB (20131209)cminstall package Download:
Notes:Low battery drain(-4mA to -10mA) h/w video, Audio & Mic, Camera, No Bluetooth.

c]CM10.1 Android 4.2.2 JB (20131210)cminstall package Download:
Notes:Low battery drain(-4mA to -10mA) h/w video, Audio & Mic, Camera, Bluetooth.
Notes: Popular/stable user build but without official flash support. (Roland Recommended)

d]CM10 Android 4.1.2 JB (20131019)cminstall package Download:
Notes:Low battery drain(-4mA to -10mA) h/w video, Audio & Mic, Camera, Bluetooth.
Notes: A solid build like CM9 but without official flash support. (Roland Recommended)

e]CM9 Android 4.0.2 ICS (20130929)cminstall package Download:
Notes:Low battery drain(-4mA to -10mA) h/w video, Audio & Mic, Best Flash support, Camera, Bluetooth, best Netflix/Flash support

Notes: Last Official CM Rom release, best supported build. (Roland Recommended)

f]CM7 Android 2.3.7 Gingerbread (CM7Alpha3.5)cminstall package Download:
Notes:Medium battery drain(-30mA to -60mA) h/w video, Audio & Mic, Flash support, Camera, Bluetooth, Original CM7 Alpha Release.

Note: Each package contains all 4.zips files needed to install Android!

How to Install Android

4) Installation:
-Once the cminstall files are on The HP TouchPad, it's time to reboot into WebOS Recovery mode.
-If you are currently running WebOS you must disconnect the USB cable from the PC.
-On your PC look for the USB icon in the bottom right corner, click it and eject the HP TouchPad.

-In WebOS Reboot the device by going into Settings/Device Info/ and select "Reset options" choose restart.
-In Android Reboot the device by holding down the power button and select Reboot/OK.

-As soon as the screen goes dark hold down the volume up button until you enter WebOS Recovery mode(aka USB Mode). Note* the large USB symbol that should be on the screen. If you miss it just reboot again and hold down the Volume up button right away. Now connect your USB cable to the PC.

Open a Command Prompt or Terminal

On your PC:
-Open a command prompt by going to the start button and typing CMD into the search window (enter)
-Open a command prompt by Opening the Palm, Inc folder, Hold [Shift] & [Right Click] then select "open Command window here" Photograph White Light Product Font

On your Mac:
Mac OS X users will need to start a Terminal window. This can be found in the /Applications/Utilities folder.

Using the Command Prompt or Terminal
-Next either type or copy and paste the following into the command prompt (without the part in brackets). You can either enter the individual commands or just copy and paste the full (Typed all at once) line into the command prompt.
Note(Optional): You can run batch files to automatically input the following commands easily download here:

On your PC
cd\ (enter)

cd program files (enter)

cd palm, inc (enter)

or (Typed all at once)

cd c:\Program Files\Palm, Inc (enter)

On your Mac

cd / (enter)

cd opt (enter)

cd nova (enter)

cd bin (enter)

or (Typed all at once)

cd /opt/nova/bin (enter)

Note:(Important)Only enter One of the Following commands below.

On your PC

novacom.exe boot mem:// < ACMEInstaller5 (Install CM7, CM9, CM10, or Flash .zips located in the cminstall folder)

novacom.exe boot mem:// < ACMEInstaller5M (Install CM10.1, CM10.2, or Flash .zips located in the cminstall folder)

novacom.exe boot mem:// < ACMEInstaller5E (Install Evervolv AOSP Android, or Flash .zips located in the cminstall folder)

novacom.exe boot mem:// < ACMEUninstaller2 (uninstalls Android and removes recovery, All versions)

On your Mac

./novacom boot mem:// < ACMEInstaller5 (Install CM7, CM9, CM10, or Flash .zips located in the cminstall folder)

./novacom boot mem:// < ACMEInstaller5M (Install CM10.1, CM10.2, or Flash .zips located in the cminstall folder)

./novacom boot mem:// < ACMEInstaller5E (Install Evervolv Android, or Flash .zips located in the cminstall folder)

./novacom boot mem:// < ACMEUninstaller2 (uninstalls Android and removes recovery, All versions)

Note: Mac OS X users will enter the commands without the ".exe" extension.

-You will see the lines of text scrolling on the HP TouchPad while Android is installing. Now disconnect the USB cable from the HP TouchPad. Once this is complete you will be greeted with the Moboot menu and Android will boot for the first time. You will be taken through a series of menus to setup the device. Congratulations you have now installed Android onto your HP TouchPad, Have Fun.

Note(Important): If you're unable to install Android and/or get a message like "failed to connect to server" you may have encountered a problem when installing either Java or Novacom. Disable your Antivirus/firewall software and try to uninstall and reinstall both Java and Novacom. If its still not working try another computer or laptop, this fixes the problem 99% of the time.

[ROM GUIDE] How to Update/Install Android 4.2, 4.3 and 4.4 Builds on the HP TouchPad
-Get links and instructions for installing the latest Android builds here:

Android install package contents explained:
-You will need 4 files to install Android on the HP TouchPad. The first two files, the Rom and Gapps, can vary depending on the version of Android you choose to install. CyanogenMod9(CM9) is used here for Example:

1) (The Rom Installs your Android Operating System)
2) (The Gapps Package, Installs your Play Store & Google Applications)
3) your Boot Menu options)
4) (Installs ClockWorkMod6 recovery, allows you to make backups, update Roms ect)

Gapps Downloads & Extras:

Main Gapps page
Mpgrimm2 Dev-Host backup files
Mpgrimm2 AFH backup files mirror
Jcsullins Dev-Host backup files file to change the partition size to 512MB
CWM6 tenderloin-20121215:
Nexus 7 Camera Launcher:
WebOS Doctor 3.0.5:

Optional Patches, Tweaks, and Customization's (Not included):
(Optional)Add flash Support for Android:
[video]How to Install the Adobe Flash Player on Any Android Device 2.3-4.4
Note: Official flash support for Android was removed after CM9(Android 4.0.2).
-You can add support back by installing the Flash apk file and using a supported Web Browser.
-To use Nexfix properly it's recommend to use CM9.
Main Adobe Flash Player Archive Flash Player for, Android 4.0-4.3 and 2.x+ versions:

(Optional) Updated CWM( and TWRP( Recovery flashable .zips:
iMarck90 has packaged the latest CWM6 and TWRP recoverys into flashable zips. Download the latest version of CWM and TWRP then flash it through your current recovery to install them: Watch this video to learn all about using TWRP recovery: How to flash Roms, Gapps packages & .zip files with TWRP!

Recovery Download:

(Optional) Additional ACMEInstaller versions by iMarck90:
iMarck90 has modified the ACMEInstaller to work with TWRP and Milaqs CM builds. Checkout his thread below for full details and instructions.
Note: Milaqs CM10.2 builds requires additional partition changes and the installation of the Data media CWM. Full install information is covered in my How to update/upgrade Android thread here:

ACMEInstaller4 Testing and other things..

(Optional) Roland's Custom HP TouchPad Boot Animations:
[Boot Animation] Roland's HP TouchPad Custom Boot Videos (XDA Thread)
A variety of fun Boot Animations to enhance your TouchPad Boot experience here:

Notes, Fixes and Tweaks(Important):
Note:The following are Solutions for the most Frequently asked questions and problems.
1)1)If the WiFi turns off in Sleep/suspend mode while set to on, then uncheck WiFi optimization.
Note:Turning off "WiFi optimization" might help to improve WiFi functionality.
note:Turning WiFi off during sleep saves extra battery life.
-Settings/WiFi/3 Dots/Advanced/WiFi optimization (uncheck)
-In Shumash's Schizoid build you can find it @ RomControl/General

2)If the HP TouchPad isn't charging do the following. If MTP is already checked,then uncheck and recheck the option.
-To Enable MTP mode, Go to settings/storage, look for the three dots in the upper right hand corner of the screen, tap computer connection, make sure there is a check next to MTP.
-This will enable the TouchPad to transfer files and charge using the USB cable.

3)If your Touchpad skips moboot and boots right into Android, then do the following:
-Hold the home key while booting to force moboot to display the Menu.
-To fix this problem use a Rooted File explorer, like X-plore, to delete the file located @ Root/Boot/
-This problem is often caused by using the CyBoot app in WebOS.

4)Turning off "network location services" might help to improve overall battery drain and longevity.
-Settings/location access/ access to my location set to off
-You may wish to monitor your battery drain history during sleep.
-Install the the free app Battery Monitor Widget:
-To setup the Battery Calibration correctly for the HP TouchPad,
-go to BMW settings/calibration/Battery capacity/ and set it to either 6300 (F29C) or 5800 (S29C) and tap OK
-Note* See the Battery p/n # on the original packaging.
You can also use Cool-Tools to monitor your battery drain in real time.
-Watch the instructional video Here.
Note:Flashing the A6 firmware will ensure your battery has a long healthy life.

5)You can enable additional reboot options like recovery by enabling Developer options.
-Go to Settings/About Tablet/ Tap on "Build number" 7 times.
-A new menu will appear in the Settings/About Tablet/Developer options/ tab on the left.
-Check "Advanced reboot" to get the Recovery/Boot loader options.

6) When installing Roms and .zips with the ACMEInstaller, you may need to add "update-" to the beginning of the file names or they won't flash correctly. Like so ""

7)If Moboot is displaying multiple Rom or recovery names that you are not currently using, then do the following.
-With a rooted File explorer go to root/boot/ and delete the unwanted uImage.( X) file to remove the entry from Moboot.
-Here you can also change the default boot option by editing the moboot.default as text.
-Also you can change the default recovery option by editing android.default.recovery

8)If you are unable to find the Play Store after you install CyanogenMod, then you will need to reflash your gapps package. Click Here for the how to video!

9)If you are unable to find the camera app install this Nexus 7 Camera Launcher:
-This will also make the camera preview full screen.

10)Use this free app "4.2 Multiple User Enabler Root" to enable multi-user functionality.
-You can also use the terminal emulator to enable it too, see VFF instructions here.

Bricking, Boot Loop, Help & Fixes(Important):
If your HP TouchPad is stuck in a boot loop or not responding:
-Hold down the Power and Home buttons together for 30sec to force the TouchPad to Reboot.
-Hold down the Power button and click the Home key 14 times.
-If you're stuck in a boot loop restore a back or do a fresh install, Click here for a how to Video:
-Dirty flashing older builds (CM9/CM10) over newer builds (CM10.1/CM10.2) will result in Boot loops.
-If this happens use your backup or do a fresh install, Click here for a how to Video:
-Doing an install with ACMEInstaller can sometimes result in a boot loop. Use a backup or flash the Rom and Gapps package through CWM or TWRP.

If your TouchPad seems bricked and won't turn on:
-If your battery has been fully drained, then you may need to leave it charging for a full day.
-When the battery is fully drained it can take the TouchPad a longtime to reach even the lowest battery level.
-The USB cable does not transfer enough power to effectively charge the tablet. You must use the wall plug when charging the HP TouchPad.
-After charging the HP TouchPad for a full day try hold down, home + power + volume down for 30+ seconds.
-If the tablet does not turn on after the previous steps it may be bricked and you will need to run the TPDebrick procedure found in the thread below:
Developer Jcsullins has posted a thread "TPDebrick v0.4" dedicated to helping people with bricked HP TouchPads(Important):
Note* All debricking questions should be posted here!

-Warning: Certain TouchPads can become "Bricked" if you let the battery drain to zero.
-Installing one of these free apps could solve the problem and save you time.
-AutomateIt, Play Store Link- What to do: New Rule/Trigger Battery level(Below 20%)/Action/Shutdown//save.
-Llama, PLay Store Link- Location Profiles:Event tab choose + (at the bottom of the screen) Add condition (battery Level Below 20%) Actions (turn off phone)

If you ran the WebOS doctor but it got stuck at 8-12% follow the instructions in the threads below:
The Official Fix your TouchPad ( 8-12% stopped, No SD, Opps reformat, The Official Fix your TouchPad ( 8-12% stopped, No SD, Opps reformat, The Official Fix your TouchPad ( 8-12% stopped, No SD, Opps reformat, $&^#[email protected]&# crap....) thread.(Rootzwiki)^#[email protected]&# crap....) thread.(Rootzwiki)^#[email protected]&# crap....) thread.(Rootzwiki)

The Official Fix your TouchPad ( 8-12% stopped, No SD, Opps reformat, The Official Fix your TouchPad ( 8-12% stopped, No SD, Opps reformat, The Official Fix your TouchPad ( 8-12% stopped, No SD, Opps reformat, $&^#[email protected]&# crap....) thread.(CM)^#[email protected]&# crap....) thread.(CM)^#[email protected]&# crap....) thread.(CM)
Touchpad Backup with QPST -- need this for unbricking:

Fixes for SDCARD issues for all versions of CyanogenMod:
-Download a to increase the size of your internal storage.

How to Change the DPI settings:
-If your home screen looks a little off then you may wish to change the DPI/LCD density.

Note: Setting the DPI to something other than 160 or 120 can cause compatibility issues with the Google Play Store. If you are unable to download and install apps then change the DPI to 160 or 120.
You can change the DPI settings either by using a free LCD app or by editing the build prop. The two apps below will do the job.

Resolution change / Density, DPI Play Store Link:
Try editing the build prop with an easy to use free app.
Build.prop Editor, Play Store Link:

How and when to Use the WebOS Doctor (Important):
Q: What's the WebOS Doctor and when should I use it?

Click Here to Watch the Full Step by Step Video:

The WebOS Doctor is a program that has two main functions for HP TouchPad users. It can either update your version of WebOS or fix problems with a damaged WebOS by completely reinstalling it. If WebOS no longer boots or apps and preware have stopped working correctly, then you will need to resinstall WebOS with the Doctor. A failed or interrupted attempt at changing the partition sizes with WebOS preware app Tailor may cause these problems. To check what version of WebOS is currently installed go to Launcher(Up Arrow)/Settings/Device Info/ Version

Note(Important): You MUST uninstall Android before running the WebOS doctor. Failing to remove Android before running the Doctor can result in the process becoming stuck at 8-12% and potentially bricking the device. If you are currently stuck visit the thread below for information about fixing the problem. If you're unable to use the tablet at all follow the instructions in Jcsullins TPDebrick thread.
The Official Fix your TouchPad ( 8-12% stopped, No SD, Opps reformat, The Official Fix your TouchPad ( 8-12% stopped, No SD, Opps reformat, The Official Fix your TouchPad ( 8-12% stopped, No SD, Opps reformat, $&^#[email protected]&# crap....) thread.(Rootzwiki)^#[email protected]&# crap....) thread.(Rootzwiki)

Note(Important): Running the Doctor will completely wipe all personal information, applications and preware from the TouchPad. Media like music and movies will not be affected. However I would recommend backing your important files to PC, before running the Doctor.

Note(Important): In order to install apps from the WebOS store you will need to get the Root Certificate fix for WebOS cloud services.
[Video+Guide] HP TouchPad Root Certificate fix for WebOS cloud services

How to run the WebOS Doctor:

1) Install Java
-Java must be installed in order for the TouchPad to communicate with your PC.

2) You MUST completely uninstall Android from the HP TouchPad before running the WebOS doctor. Remove Android by running the ACMEUinstaller2. Watch the following video for full uninstall instructions.
How to Uninstall Android or CyanogenMod on the HP TouchPad (All versions)

3) Download the latest 3.0.5 WebOS doctor application to your PC. If upgrading you can check your current version from WebOS by going to Launcher(Up Arrow)/Settings/Device Info/ Version.
WebOS Doctor 3.0.0 to 3.0.5 Official Links

4) Put the tablet into WebOS recovery mode by doing the following:
-In WebOS Reboot the device by going to Launcher(Up Arrow)/Settings/Device Info/ select "Reset options" choose restart.
-As soon as the screen goes dark hold down the volume up button until you enter WebOS Recovery mode. Note the large USB symbol that should be on the screen. If you miss it just reboot again and hold down the Volume up button right away. Once in WebOS recovery mode connect your USB cable to the PC.

5) Now you're ready to run the WebOS Doctor app by clicking on the .jar file you downloaded in the previous step. Be sure that your tablet is fully charged and connected with the USB cable before starting this process. Running out of power or interrupting this process in anyway could brick your HP TouchPad. Please be careful and fully read the instructions before beginning.
-Double click the webosdoctor.jar file to launch the app
-Select your language then click next
-Accept the licence agreement, read the warning message then select next to begin the install.
-Be patient the process can take anywhere from 15min to 1hour to complete.

HP TouchPad Battery Drain issues during sleep (Important):

Full step by step A6 Firmware Flashing instructions and Info here!
The Problem:
Developer James Sullins, Aka Jcsullins, has informed HP TouchPads users that there is a problem with our tablets A6 Firmware. This issue can cause an usually high battery drain during sleep. This problem occurs overtime while running both CyanogeMod and WebOS, on the HP TouchPad. As a results the Touchpads battery drains more quickly with daily use and the overall life span is reduced.

The Solution:
Reflashing the A6 Firmware effectively fixes the problem but may need to be repeated as a part of regular HP TouchPad maintenance. Watch this video and follow the step by step instructions to reflash your own Touchpads A6 Firmware.

How to test:
How to monitor your battery
To monitor your battery drain history during sleep install the free app Battery Monitor Widget:
-Once installed open the app and go to history to see a log of your devices sleep history.
-To setup the Battery Calibration correctly for the HP TouchPad,
-go to BMW settings/calibration/Battery capacity/ and set it to 6300 (*f29c), 6000 (*i29c) or 5800 (*s29c) and tap OK
-Note* See the Battery p/n # on the original packaging.
-Note* after setting the calibration, users will have to allow several hours to pass before the history can be accumulated.
You can also use Cool-Tools to monitor your battery drain in real time.
-Watch the instructional video Here.

A6 Firmware Threads & Info:
Battery Drain issues on HP TouchPad RootsWiki

[Fix Guide] How to Reflash the A6 Firmware XDA

How to Reflash the A6 Firmware Method 2:
[video] How to fix the A6 firmware Battery Drain Problem on the HP TouchPad Method 2

1) Boot to WebOs and in the "Just Type" box enter the following: webos20090606 or upupdowndownleftrightleftrightbastart
-Tap the developer mode icon and slide the toggle to on, then press submit.
-Plug the USB cable into the HP TouchPad and your PC.

2)On your PC Install Java and the WebOSQuickInstall-4.5.0 software*
- Note* If you have already previously installed Android with Java, then skip it.

a]Download Java:

b]Download Novacom Universal Installer:

c]Download WebOSQuickInstall-4.5.0:

3)Run the WebOSQuickInstall-4.5.0 software, note your TouchPad must be connected with the USB cable.
-Click on the Small globe icon located under the plus minus buttons.
-This will take us to a new menu where we will search "preware"
-Click the install button and the Preware app will be installed.
-You may now unplug the USB cable.

4)On the tablet while booted into WebOS navigate to downloads and select Preware.
-scroll down until you see a button appear to continue
-Search for "wterm" and install the app.
-Run wterm, and set a password to give the app Root permissions.
- You can set or change the password by looking for the wterm menu in the upper left corner and select setup.
-Click on New password and enter a simple password like "0000"
-Confirm the password and press "Set Password" button, now hit done and exit.
-Note you can increase the font size by going to wterm preference settings.

5) Now in wterm enter the following command
PmA6Updater -f -d 0 /lib/firmware/a6_firmware.txt.00
PmA6Updater -a (Note this shorter command flashes two firmwares)
-It should take about 20-30 seconds to complete and will inform you upon completion.
-Congratulations you have now reflashed the A6 Firmware and can safely close the terminal and reboot your HP TouchPad.
Note: If you input the command and get a message saying it said can't open the A6 device, then try toggling developer mode off and on.

How to Reflash the A6 Firmware Method 1:
[video]How to Reflash the A6 Firmware Method 1:

1) Boot to WebOs and in the "Just Type" box enter the following: webos20090606
-Tap the developer mode icon and slide the toggle to on, then press submit.
WARNING: Do not enter a password. Just tap submit.
-Plug the USB cable into the HP TouchPad and your PC.

2)Install Java and the Novacom software*
- Note* If you have already previously installed Android with, Java and Novacom drivers, then proceed to step 3.

a]Download Java:

b]Download Novacom Universal Installer:

3)Open windows explorer and go to C:\Program Files\Palm, Inc\Terminal
-Now run the Terminal.bat*
-Note* if you are using a 64 bit OS and get the Error "Windows cannot find Javaw..." you will need to copy the Javaw.eve from C:\Windows\SysWOW64 and paste it into C:\Windows\System32.

4)In the open Novaterm window, select file\connect\Ok
-Now copy and paste the following line into Novaterm and press enter*
PmA6Updater -f -d 0 /lib/firmware/a6_firmware.txt.00
PmA6Updater -a (Note this shorter command flashes two firmwares)
-Note* Do Not! disconnect the TouchPad After starting this procedure.
-Novaterm will tell you "firmware update complete"
- In the open Novaterm window, select file\disconnect\Ok
-Congratulations you have now reflashed the A6 Firmware and can safely disconnect your HP TouchPad from the USB cable.

SDcard Fixes and Internal App Storage Increase(Important):

All these fixes can be found in the following thread below by Jcsullins:
Fixes for SDCARD issues for all versions of CyanogenMod
Removed SDcard Error Message:
"Removed SD card
SD card removed. Insert a new one.

If so, that (most likely) means that you have encountered the
50+ issue. To fix it, you will need to move apps back from
the 'sdcard' to the 'Internal storage' (or 'phone').

The next fix/workaround allows you to 'stash' some of the apps
on the 'sdcard' so that the 50+ issue does not come into play.
This will allow you to move apps back from the 'sdcard' without
encountering the "Removed SD card" error while attempting to do so.
Each time you apply this 'fix', it will 'stash' all but 40 of
the apps on the 'sdcard'.

So, apply this fix once. Then move apps back from the 'sdcard' to
the 'phone' (or 'Internal storage'). Note that apps that have been
'stashed' might show with a greyed-out icon with an 'SD Card' symbol
and the letters 'SD' -- do not attempt to move these. After you
have moved the apps from the 'sdcard' back to 'phone' (those that
haven't been 'stashed'), you apply the fix again. Applying the
fix the second time will 'unstash' the remaining apps (remember
that it will not allow more than 40 apps to be 'unstashed') thus
allowing you to move them off the 'sdcard' too.

Get it here: http://www.mediafire...4n3fhag1d33127q
Apply with your favorite recovery software."Jcsullins Quote

How to Increase the 'Internal space' for Additional App Storage:
You can increase the size of your 'Internal space' (or /data)
in increments of 256MB, 512MB, 1024MB and 2048MB. You apply
these 'fixes' with recovery software (tested with CWM and TWRP),
however, please note the warnings below.

********** PLEASE READ ALL WARNINGS BELOW **********
********** PLEASE READ ALL WARNINGS BELOW **********
data_plus_256mb: http://www.mediafire...gxqjki8s255lwpw

data_plus_512mb: http://www.mediafire...wh83t6urhnf82ad

data_plus_1024mb: http://www.mediafire...zaeh4fd3pjinaga

data_plus_2048mb: http://www.mediafire...xyxdx7xscee6mex
********** PLEASE READ ALL WARNINGS BELOW **********
********** PLEASE READ ALL WARNINGS BELOW **********


1) BACKUPS. BACKUPS. BACKUPS. As always, and especially when you
are resizing filesystems, you should have backups. This means
backups of all data (that you would care about losing) on the
Touchpad. These backups should be stored off of the Touchpad.

2) Before attempting to resize your 'Internal space' make sure
you have enough free space on your 'sdcard' to do so. Check
this from Settings/Storage/SD card/Available Space. You should
have enough space plus a very healthy 'safety margin'.

3) Before applying this 'fix', make sure you have plenty of charge
on your battery.

4) Do not reboot, reset or otherwise interrupt the touchpad while
applying this 'fix'.

5) As soon as this 'fix' is complete, use the recovery software's
reboot command to reboot the system. Do not do anything else
in recovery after applying this 'fix'. This 'fix' does things
that recovery software are not designed to do and does not
Jcsullins Quote

Removing System Apps(Optional):
If System apps are displaying error messages or working incorrectly you can use a free app to remove them. In some cases you may wish to uninstall apps from your system and reinstall them as regular apps such as Google+ and Chat.
Note: The device must be rooted

Sdx Stock App Removal Thread:
Sdx Stock App Removal Download:

Warning! Please take care removing apps. If it's an app that the system needs, it will be removed and can cause the phone to boot loop or worse? We do not take responsibility for your choice to install this and remove anything. PLEASE USE CARE!

Partition Size Problems and ACMEInstaller3(Important):
The Problem:
-Android 4.2.2+ Roms requires a larger partition size than older versions.
-The ACMEInstaller 5 is meant to increase the partition size from 300MB to 600MB.
-Android 4.1.2(CM9) only needed 300MB but Jelly Bean and Kitkat Roms require more System partition space(400MB+).
-In some cases users have reported 0.0/400MB of space left after installing Android 4.2.2(CM10).
-Although everything may still run fine it is recommend to leave at least a little space free. The consequences of running it without free space are not known.

How to monitor free System Storage spaceOptional):
-You can use a free app,Quick System Info PRO, to check the size of your partitions and remaining free space.
-Having a System Partition size of 500-600MB is needed when installing Android 4.2+ Roms.
-If you used the ACMEInstaller5 and then later restore an older Nandroid backup, you will still retain the larger partition size.
Quick System Info PRO Video Clip Link:
Quick System Info PRO Play Store Link:

How to free up System Storage space on the HP TouchPad(Optional):
I believe I have located about 15.89MB of data we can safely delete. Android in space videos and Phone Ring tones are located @
root/system/media/videos & root/system/media/audio/ring tones.

X-plore File Manager, use this app to delete the files:

Note* X-plore needs to be given Root Permissions by clicking the 3 dots in the corner and choosing configuration. Here check your Root Access settings. SuperUser + Mount Writable, this is what it should say. Next you may need to reboot before it takes effect.

How to guide for changing your system, data, and cache partition sizes(Optional): (Gradular)

Related Links:

Donate to the Developers:
Donate to show your appreciation to our hard working developers:

Donate to Jcsullins:

Donate to Dorregaray:

Donate to Evervolv Team (Flintman):

Donate to Invisiblek:

Donate to Milaq:


See less See more
  • Like
Reactions: 5
1 - 20 of 3710 Posts
I am showing 1 ma for my idle current draw........EXCELLENT! Thanks devs! This is a much more useful device now. The 20130304 rom rocks and so does Mr. Sullins and Rolland and Dorregary and all the rest of the devs. Thanks a lot people. I inherited this tablet from my Father in July 2012. It sat around mostly because WebOS is uber limited, software support when I found Cyanogen and then this dev branch, I was smitten to be able to make daily use of Dad's Touchpad. I suspect that with this being open sourced that it will eventually chew up M$ and Apple and even google in the end. This is encouraging. Keep up the great work people! and thanks so much. I only wish I knew of this while pops was still alive. He was still using WebOS when he passed......never got to see the device shine....he was one tech savvy 74 year old. He would have been ALL OVER this stuff!

See less See more
  • Like
Reactions: 4
Heh Radio Shack. Sorry for the off topic here...I am 46 the 22nd. I had a TRS-80 in 1977 when I was 10! and I hung out at the Radio Shack Computer Center store for like a year and a half before that since I was 8! Having a device like this Touchpad would have TRULY gone over as sci-fi back then. Even now I can hardly believe stuff like this exists. Stuff like my Nexus 4 phone that pretty much mirrors the specs of the Touchpad is truly incredible, not to mention sonething like the new Galaxy S IV.....WILD! But I digress hehe


This touchpad doing 1 ma in sleep lasted 2 days without budging off 100 % battery. NICE!!! THE DEVS ROCK!

/me does the "I'm not worthy" genuflection
One small correction, Google owns Android.

Honestly, I think google is going to lament the day they let the cat out of the bag and open sourced Android 4. I could be wrong, but I suspect they will. As far as them owning_it, I dunno man. I think these large companies taking open source code....making it propriatary in some way, and then claiming copyright on it is assinine. I mean I don't begrude coders making cash on their skills but something like taking BSD 4.4 and twisting the kernel and calling it darwin...and then osx...and then copyrighting it....there are TONS of other ways to charge for mad skillz. Apple is just one example of open source hijacking IMO. Support based models like redhat before they got a big head is the way to do it...for that matter calling software copywritten in and of itself is assinine IMHO. It isn't a song, it isn't painting, it isn't a book, it is wholly necessary piece of a functioning device called a computer, at least the OS is, so I think software should be pattened.....but NOT if it has been derived from open source...but oh my..,I digress again. Sorry admins.I'll keep it on topic now.
See less See more
Could be the usb cable, or the charger itself. Make sure the removable end(with the folding prongs)is turned fully clockwise. Test on WebOS and see that it charges there. Double check settings/storage/ three dots upper right, usb computer connection that MTP is checked. Try reinstalling CM10 and gapps again.

You are the first I've seen report a -1mA battery drain. That is true WebOS performance. Wondering what you are doing to get that. Is it a 32GB or 16? IT IS A 32 GIG PURCHASED DURING FIRESALE
Have you done anything out of the ordinary to try to reduce battery drain? NO. MY SETUP IS RATHER BASIC THOUGH
It is a 32 GIG purchased summer 2011 firesale. I have done nothing special. My setup is pretty basic though. I have a userinit.d folder in /data/ that folder I have a file that ups my max allowable cpu to run 1782mhz as well. So I am getting that 1 ma sleep performance while overclocked as well. There is even entry in the log showing 0ma and I do not think it is erroneous. The pig just was drawing less than 1ma when the logger polled it. You would have to verify with whomever wrote that logger but I suspect that is what 0 ma implies, less than 1 ma. I mean even at 1ma, that is frrggin shelf life self discharge on a lithium ion cell I think. VERY NICE DEVS! Let me see if I can get a snippet of that log pasted here...look for it in a few I am at a clients right now trying to finish up.
See less See more
A snippet of my Battery Monitor Log. Note the one entry a few down from where it starts the 1ma will wee one showing 0 ma at 07:04:50

2012/12/10|05:54:51 AM|252mA|99%|4104mV|29.0ºC|.1|2
2012/12/10|06:04:50 AM|329mA|100%|4108mV|30.0ºC|.996|1
2012/12/10|06:14:50 AM|249mA|100%|4108mV|30.0ºC|.1000|1
2012/12/10|06:24:50 AM|197mA|100%|4108mV|30.0ºC|.1000|1
2012/12/10|06:34:50 AM|35mA|100%|4108mV|30.0ºC|.998|1
2012/12/10|06:44:50 AM|1mA|100%|4108mV|30.0ºC|.1000|1
2012/12/10|06:54:50 AM|1mA|100%|4108mV|30.0ºC|.1000|1
2012/12/10|07:04:50 AM|0mA|100%|4108mV|30.0ºC|.1000|1
2013/03/15|10:07:10 PM|1mA|100%|4108mV|23.0ºC|.1|1
2013/03/15|10:10:10 PM|1mA|100%|4108mV|23.0ºC|.298|1
2013/03/15|10:20:10 PM|1mA|100%|4108mV|24.0ºC|.26|1
2013/03/15|10:30:10 PM|1mA|100%|4108mV|22.0ºC|.0|1
2013/03/15|10:40:10 PM|1mA|100%|4108mV|21.0ºC|.0|1
2013/03/15|10:50:10 PM|1mA|100%|4108mV|21.0ºC|.0|1
2013/03/15|11:00:10 PM|1mA|100%|4108mV|20.0ºC|.0|1
2013/03/15|11:10:10 PM|1mA|100%|4108mV|20.0ºC|.0|1
2013/03/15|11:20:10 PM|1mA|100%|4108mV|20.0ºC|.0|1
2013/03/15|11:30:10 PM|1mA|100%|4108mV|20.0ºC|.0|1
2013/03/15|11:40:10 PM|1mA|100%|4108mV|20.0ºC|.0|1
2013/03/15|11:50:10 PM|1mA|100%|4108mV|20.0ºC|.0|1
2013/03/16|12:00:10 AM|1mA|100%|4108mV|20.0ºC|.0|1
2013/03/16|12:10:10 AM|1mA|100%|4108mV|20.0ºC|.0|1
2013/03/16|12:20:10 AM|1mA|100%|4108mV|20.0ºC|.0|1
2013/03/16|12:30:10 AM|1mA|100%|4104mV|20.0ºC|.0|1
2013/03/16|12:40:10 AM|1mA|100%|4108mV|21.0ºC|.0|1
2013/03/16|12:50:10 AM|1mA|100%|4104mV|21.0ºC|.0|1
2013/03/16|01:00:10 AM|1mA|100%|4108mV|21.0ºC|.0|1
2013/03/16|01:10:10 AM|1mA|100%|4108mV|21.0ºC|.0|1
2013/03/16|01:20:10 AM|1mA|100%|4108mV|21.0ºC|.0|1
2013/03/16|01:30:10 AM|1mA|100%|4104mV|21.0ºC|.0|1
2013/03/16|01:40:10 AM|1mA|100%|4104mV|21.0ºC|.0|1
2013/03/16|01:50:10 AM|1mA|100%|4104mV|20.0ºC|.0|1
2013/03/16|02:00:10 AM|1mA|100%|4104mV|20.0ºC|.0|1
2013/03/16|02:10:10 AM|1mA|100%|4104mV|20.0ºC|.0|1
2013/03/16|02:20:10 AM|1mA|100%|4104mV|20.0ºC|.0|1
2013/03/16|02:30:10 AM|1mA|100%|4108mV|20.0ºC|.0|1
2013/03/16|02:40:10 AM|1mA|100%|4104mV|20.0ºC|.0|1
2013/03/16|02:50:10 AM|1mA|100%|4104mV|20.0ºC|.0|1
2013/03/16|03:00:10 AM|1mA|100%|4108mV|20.0ºC|.0|1
2013/03/16|03:10:10 AM|1mA|100%|4104mV|20.0ºC|.0|1
2013/03/16|03:20:10 AM|1mA|100%|4104mV|20.0ºC|.0|1
2013/03/16|03:30:10 AM|1mA|100%|4104mV|20.0ºC|.0|1
2013/03/16|03:40:10 AM|1mA|100%|4104mV|20.0ºC|.0|1
2013/03/16|03:50:10 AM|1mA|100%|4104mV|20.0ºC|.0|1
2013/03/16|04:00:10 AM|1mA|100%|4104mV|20.0ºC|.0|1
2013/03/16|04:10:10 AM|1mA|100%|4104mV|20.0ºC|.0|1
2013/03/16|04:20:10 AM|1mA|100%|4104mV|20.0ºC|.0|1
2013/03/16|04:30:11 AM|1mA|100%|4104mV|20.0ºC|.0|1
2013/03/16|04:40:10 AM|1mA|100%|4104mV|20.0ºC|.0|1
2013/03/16|04:50:10 AM|1mA|100%|4104mV|20.0ºC|.0|1
2013/03/16|05:00:10 AM|1mA|100%|4104mV|20.0ºC|.0|1
2013/03/16|05:10:10 AM|1mA|100%|4104mV|20.0ºC|.0|1
2013/03/16|05:20:10 AM|1mA|100%|4104mV|20.0ºC|.0|1
2013/03/16|05:30:10 AM|1mA|100%|4104mV|20.0ºC|.0|1
2013/03/16|05:40:10 AM|1mA|100%|4104mV|20.0ºC|.0|1
2013/03/16|05:50:10 AM|1mA|100%|4104mV|20.0ºC|.0|1
2013/03/16|06:00:10 AM|1mA|100%|4104mV|20.0ºC|.0|1
2013/03/16|06:10:10 AM|1mA|100%|4104mV|20.0ºC|.0|1
2013/03/16|06:20:10 AM|1mA|100%|4104mV|20.0ºC|.0|1
2013/03/16|06:30:10 AM|1mA|100%|4104mV|20.0ºC|.0|1
2013/03/16|06:40:10 AM|1mA|100%|4104mV|20.0ºC|.0|1
2013/03/16|06:50:10 AM|1mA|100%|4104mV|20.0ºC|.0|1
2013/03/16|07:00:10 AM|1mA|100%|4104mV|20.0ºC|.0|1
See less See more
OMG you are correct. I was at an office gathering with one of my clents at 7pm on the 16th so I thought that was my battery usage..cause I had the pad with me. Now I am seeing it is 7am and that is in fact when it was plugged in. Color me st00pid anyways....So sorry for that....BIG DUH...I will get a real snippet of battery usage in sleep soon. I can tell you that I accidentally left it unplugged all weekend last weekend and didn't use it at all until (GASP!) Sunday evening, and that was 42 some odd hours...and it was still at 100. I just installed Battety Monitor when I saw it in the it has only been a few days I have been running it.
After further testing and trying to do various things on hulu, skyfire is only slightly better than dolphin and other browsers. I found that once I selected the flash setup while on hulu, the screen tearing, etc. came back with a vengeance ... so there is still no relief in sight. Personally I am flabbergasted that a site as huge as hulu would NOT have switched over to HTML5 by now, or at least set things up in dual mode with the user having the ability to choose their favorite mode.​

Just FYI, firefox, not the beta,,will do the flash.....but you have to dynamically re-size the video...either way. bigger or smaller and the video will stabilize. All you have to do is do a full squish so it bounces off the smallest size, and then it autosizes up to fill the screen with the browser window and your video should be good.
HTML5 is what's happening and folks need to get over Flash.
nevertells.....before I say this, just want to state my respect for all the devs and thread moderators that make all this stuff possible, you people truly rock socks dude.....but.....SAYING EVERYONE NEEDS TO GET OVER FLASH IS A PATENTELY RIDICULOUS STATEMENT!! There is just simply STILL way too much content that uses Flash with no alternative delivery medium. Currently there is no "getting over Flash" and having access to a complete web experince. I totally understand the devs badly wanting Flash to eff the eff off and go away, but that is as unrealistic as users wanting Flash to work properly on JB. So in the spirit of this controversy, I am wondering this........WHAT SITES DO ACTUALLY SUPPORT HTML 5 VIDEOS ANYWAYS, BECAUSE I CAN'T FIND ANY!!! hehehe. Then again I was st00pid enough to mistake a section of my Battery Monitor log when charging, for battery usage hehe so.....I AM TEH BIG DUH!

See less See more
  • Like
Reactions: 2
Ladies & Gents I have the same problem. Used nevertells' instructions on upgrading from latest CM9 nightly directly to CM10. My camera force closes every time.

The only deviation from nevertells instructions was I already have moboot (3.5) and the CWM version he referenced so I did not put them in the cminstall folder.

I checked the additional settings are present in the Advanced settings.

I cleared data and cache for Gallery and data for Camera. Rebooted.

One thing I noticed is the dpi looks maybe different vs CM9 - my home screen looks skewed towards the bottom and less apps appear per screen on the apps screens.

Any thoughts please?

I think you should see if it can play FLASH!!!!


/me ducks!
  • Like
Reactions: 1
I was trying to keep it simple. But since you called me out
, the long version is, Flash is going away. Web developers, software authors and the like are slowly removing Flash support in lieu of HTML5. Flash is a security nightmare amongst other issues and the folks that make these kinds of decisions have opted for HTML5. Google removed support for it in Android Jelly Bean. The only way to try to jury rig Flash in JB is side load the .apk and put up with the sketchy performance. At least Puffin browser has apparently found a way to support Flash without using installed support. If you absolutely need rock solid Flash support then go run CM9. But the constant beating it back and forth in a CM10 thread is wearisome as was indicated by the number of likes and tongue in cheek posts that followed that post. Maybe someone should start a separate thread just for the discussion of how to install/run Flash in CM10. I know what, I nominate you.

Let's just give it a rest in this thread.
Flash is surely a prescription for pwntage...A seperate thread for flash support on CM10....that is actually a very good idea. It might even lead to a short term interim solution for people. Puffin sounds like an interesting alternative to side loaded flash. I would like to know how they are accomplishing that without violating adobe licensing......anyways....I PROMISE I WILL NEVER MENTION FLASH IN THIS THREAD EVER AGAIN!


Much love for all the devs and moderators. Not only do I love this hardware and this OS, I LOVE THIS SCENE!! It is so much fun and so encourging to see all this absolutely RABID open source dev taking place..reminds me of the old AmigaDOS days where devs just kept pumping out new capabilites for the machine all the fun fun fun PHUN! FOR EVERYONE!!!!

See less See more
  • Like
Reactions: 3
I experienced the same problem with the stock cables. I did this to rectify the situation. NOTE: BE GENTLE SO AS NOT TO DAMAGE THE TOUCHPAD CHARGING PORT!
First, examine the cabels micro USB connector looking into it so you can see if the connectors perimeter is misshaped at all. If it is, make an attempt to fix that if possible. I used a VERY petit needle nose to fix the shape. It was slightly bowed wide so I squeezed it a bit to correct the problem. That, however, did not fully mitigate it. If the cable was out a millimeter or so, it would stop charging. Then I moved it around in the socket a bit to see how it actually fit and I noticed that it was wanting to stay at a slightly downward (with the screen facing up) angle. Using VERY GENTLE pressure, I pushed the connector in so I was sure it was bottomed out and all the way into the touchpad, and then applied upward pressure to bend it back up so it no longer wanted to rest at the slight downward angle. That fixed things very nicely. In fact, I can not get ANY cable I own to stop charging no matter how I move them. They all stay charging perfectly now no matter how the connector is moved around. This leads me to believe I may have corrected the touchpad's connector as well as the cable. Once again, BE CAREFUL! The micro USB connections are VERY FRAGILE!
See less See more
  • Like
Reactions: 2
lippy, much as I admire you for attempting such a delicate repair, I have to ask the obvious question. Why would one want to risk damaging their TouchPad USB port when for a couple of bucks they can purchase a good quality replacement? We all agree that the HP USB cables are a piece of crap, so making repairs on a lousy quality cable is also something that should only be attempted if nothing else is available. That being said, I leave the decision to you and any others that want to attempt this repair.
Some of us here, in fact I suspect many here, define broke.....myself included. Otherwise, besides the geek sport of it, I would think alot of people are using the hp touchpads because their budgets are slim. As far as the last time I looked, the were still one of the least expensive options to get a device of this class and specs. Hell, I wouldn't have been able to justify this for me. I inherited this pig from my Dad who passed last July. I have two children. one almost 5 and one 7 months old. 8-15 dollars or so for a replacement cable is like one day of keeping my daughter in the after school program for 11 dollars a day so I can hit up another client or two before I pick her up.PLUS, the connector on the pad itself was a good part of the problem. All of my cables are rock solid now. Charging doesn't wink on and off on rough roads anymore. Didn't have to apply much pressure at all. I suppose I risked breaking it, but the times the battery went down to nothing because of the connector slop was risking my battety as well. li-ion / poly cells tend to crystalize when fully drained. I figured it to be a good gamble. Sorry for the book. You asked heh.

8) In fact, snce writing this blurb, I am wondering if many of the winky blinky charging issues people have had may very well be this issue. Their touchpad's connector has gone intermittant itself. I have always been suspect of trying to pass 10 watts on a micro usb cable. If your female connector is loose as a goose, I would think the chances of 10 watts passing less than the desigbed surface area, because of a loose female micro usbjack.......would be diminished quite a bit. I haven't had a single charging issue mobile or at home since the fix.

/me shrugs
See less See more
This rom is WAY smoother. Thanks a lot JC. Your commitment to the platform and open source is rather inspiring.
I hear people crabass about this being on 2.x vs 3.x kernel.
This is just for my curiosity. I know full well changing a kernel is a major pain. Most of the pain is usually related to the hardware no longer working properly, or more likely, not working at all on the new kernel in my experience.
Is this the case here on Android / cm_tenderloin? Changing the kernel to 3.x would just break everything?

On another note,
I keep hearing people mention Adreno drivers so they can achieve full hardware accel for the graphics subsystem.

1. Is it worth bothering? The machine seems to run acceptably.

2. Has any one done this on this rom, and I mean cm10_tenderloin in general, BUT if someone has done it on this 20130418 rom, and can share the method.....I would be grateful to have something to hack towards.

3. Are there any attempts to go with the 3.x kernels....if so are they going to pop up here and already support full hardware accel on the cm_tenderloin platform, thus making it pointless for me to bother and I should just wait for the man to get to it or what!!?????!


P.S. I know the rom only came out yesterday, but people here are freakshows!! hehehe
See less See more
My understanding is we don't have all the 3.xx drivers for our hardware, only 2.xx, therefore stuck with 2.x kernel.

Trust me. The TP devs are using the best drivers/kernel possible. The fact that you can run a Jelly Bean rom on a non-CM Froyo device with most everything working as good as it does, is no small feat. We now have a good start on 10.1. :D
No doubt. Like I said...just my geeks sport curiosity....
Any opinion on pursuing the Adreno hardware drivers?
Flake city?
Anyone know?
  • Like
Reactions: 1
Sorry J.C., I don't understand what "from within WebOS" means. I've never used ADB, even trying scripts intimidates me. Any additional information and guidance is really appreciated. I imagine a lot of folks will want to be trying this. Your comment in the "Debricking" thread about the A6 firmware being flakey and how you corrected it by running the whole debricking process is kind of scary. Thanks
I think Web OS has a shell enviroment, doesn't it? I believe ye oldde sir sullins was saying to boot Web OS, pull up the linux command line interface terminal, and enter the text exactly the way JC posted. That should launch the binary executable Pma6Updater and point it to the /lib/firmware directory and direct the Pma6Updater to flash the a6_firmware.txt.00 file. I think adb is simply the command line interface you would use "from within WebOS" to enter the command JC posted. Is that the essence of it JC? Thanks for all the great work!
  • Like
Reactions: 1
Yep. Here's a fix:

This is an update you can flash via recovery. It will disable the "dock" behavior of the Touchstone (it will only act as a charger).

This will work for CM9 or CM10. Since it's a script (which runs on boot) that lives under /data/local/userinit.d, you will not
have to re-install unless you erase or format the /data partition.

Thanks JC! You Rewl Fewl!
  • Like
Reactions: 1
Big THANK YOU for this! Tried out with hangouts this morning and microphone works! The 180 degree rotation can be fixed using the "Advanced" menu in the settings and choosing the WebOS camera. I tried with all three and the WebOS option was correctly orientated on both preview and on receiving side of the video chat. The orientation settings had no effect by the way. I will keep testing and update my 2nd touchpad as well and let you know if I run into any other bugs. But for now, you fixed one of my last remaining wishes.

Thanks again for the awesome job!

Edit: Choosing the WebOS default profile to correct the orientation only works in the new Hangouts app. Video chats initiated in the Google+ app are still rotated 180 no matter what setting is chosen. I'll double check the mic in the Google+ app later.
Oh My God! See what I mean about this guy? Awesome dev.

See less See more
  • Like
Reactions: 1


/me ducks


Sorry. Could not resist!
I am compelled to be an asshat!
It's kind of one of those each to his own things. There are trade offs for how we want to play. For example, I find that using "Fake GPS" keeps most of my apps happy and so I keep location services turned off. If I need Google maps, I launch my browser and use Maps that way. Colchiro is just bragging 'cause he is getting low battery drain without having to jump through all the hoops.
I've been one of the lucky ones that's never had WiFi or reboot issues, while others have been plagued with them no matter what Rom they try. And so far, I've managed to avoid any "bricking" issues.(Knocking on wood frantically)
Honestly, and this is my opinion, these devices are very much the same. I am not buying it that hardware or the rom are to blame in the instances of individuals having odd problems. I suspect a lot of it has to do with app management / usage / methods / habbits.
For instance, if you install an app, and you decide it sucks, first, go flame the developer! j/k 8) but THEN uninstall it. A cluttered file system is a slower file system, a less stable file system. Operator habbits also play into this. Not to mention computing common sense. If you use an app ALL the time, like your e-mail, leave it running. If you use an app occasionally, do the computer a favor and get it off the stack.......don't go around with 20 apps running all the is a prescription for instability. It doesn't matter WHAT computing platform we are discussing, this applies, ESPICALLY on something highly experimental such as this HP Touchpad device running a rom it was not designed for. Mac OSX. Winbl0ws..*nix, doesn't matter. Computers WILL become unstable with lots of apps cotinuously munching on the stack. ARM compiled *nix is a fairly new sport in general, much less ARM *nix on obscure hardware meant originally for another OS. Don't expect to be able to beat the thing like you can a Mac OSX machine. These common sense pratices apply to pretty much all computing devices. Battery issues are another topic where common sense applies. You do NOT want to repeatedly take any lithium based rechargable batteries down close to zero charge The chemistry gets unstable easily in that state and you start to get crystallization in the cell. This is very detremental to the material and can lead to a spontaneous utter and total crystallation of the entire cell. Most of you have most likely had the experience of a LiIon batrery that had good capacity just suddenly go B0RK! and it is shot. That is what you see when the material in one or more of the cells has crystallized, a rapid detremental change in capacity and a refusal of the device to charge the battery. A LiIon battery certianly needs to get used because either extreme state, either fully charged or fully discharged can lead to crystallazation, more so on fully discharging than leaving the machine plugged in all the time, but if a machine IS left plugged in for a long period of time, you will also see crystallazation. I get people in my computer store ALL the time that tell me....I got a brand new battery and never used it. When I finally went to use it it crapped very quickly and won't charge now....
That is what happens when LiIon paste remains in one or the other state of charge for too long. With that in mind....don't take any LiIon batteries down super low. unless it is a necessity, do't go below 20 percent. LiIon draws like twice the charging current at 10 percent charged than it does at 20, so you also beat your charging circuits when you let the battery get below 20%
See less See more
  • Like
Reactions: 1
1 - 20 of 3710 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.