Android OS Forum banner
1 - 20 of 121 Posts

·
Registered
Joined
·
138 Posts
Hi everyone!

So i'm brand new to rooting, like...brand new. I just got a razr HD and am loving it so far, but I would like to get on board with a custom ROM. i've read through plenty of tutorials and whatnot, but am still pretty shaky on a lot of things. if you all don't mind...can i ask a few questions? and they will ultimately relate to this thread.

1. to do all of this (install safestrap and this ROM) do i need to root my phone?
2. If so, is there a way to root this guy via mac yet? seems like the only thing i've found is for a PC root.
3. does going through with this in any way affect me getting OTA updates? as in, when verizon finally ships out this jelly bean update, will i get it?

I have a lot more questions but i'll leave it here. Thanks so much for any help guys! and i'm excited to get this started!
 

·
Registered
Joined
·
138 Posts
You can use Matt's utility to do root from mac here is the link http://www.droidrzr....y-100-linuxmac/ I am pretty sure you need root as when installing Safestrap it asks for superuser access.
thanks! now then, just so i have this outlined in my head. i root the phone. then i install safestrap. then i make a virtual ROM partition. then i flash jake's .zip rom to that partition. presto?
 

·
Registered
Joined
·
138 Posts
hi everyone so i flashed the rom and gapps, and everything said successful....

but now its booting up and it just went black. and is staying black. i'm assuming this isn't normal?

thanks so much for your guys' help!
 

·
Registered
Joined
·
138 Posts
wait wait! i got it to boot into safestrap recovery. vitreous is still flashed into rom slot 1. but now i'm afraid to reboot.

EDIT:

i just went through and read this thread again. it seems like some people are saying that i can't do this from stock ICS? i need to download the JB leak first?
 

·
Registered
Joined
·
138 Posts
Download this http://db.tt/NIp5A5Ax
Make sure rom slot 1 is active then flash the fix

Sent from my DROID RAZR HD MAXX using Xparent SkyBlue Tapatalk
just to be sure. i am running stock ICS. do i need to be on the leaked JB for this to work?

and...what is this exactly?

EDIT:

well...i just went through and did it all again more or less. backed up the stock ROM (which works), restored it to ROM slot 1. wiped cache, system. then flashed vitreus, gapps, and JB fix to to rom slot 1. and... still black.
 

·
Registered
Joined
·
138 Posts
Once the rom slot is active you do a restore of your stock backup that u made before creating the rom slot just restore it to thd rom slot then do a fdr, cache wipe, and dalvick cache wipe then install the rom and gapps and the JB rom slot fix then reboot and u should be good

Sent from my DROID RAZR HD MAXX using Xparent SkyBlue Tapatalk
first of all thanks so much for helping us out, but i still can't get this guy to work.

i saved these .zips to my SD card, i'm assuming that's not an issue. maybe should i re download all these files?

do i need to flash the JB fix before installing the ROM? does the order matter?

here is exactly what i'm doing:

I backed up stock. created a 1GB ROM slot. activated it. restored the backup to ROM slot 1. then i did factory reset, cache wipe, dalvick wipe. then I flash the ROM, then Gapps, then the fix in that order. do i need to do any cache wipes or anything again? i reboot, and it takes me to the safestrap splash screen. i press continue, and the screen goes black and stays black.

sorry for asking so many questions. i just know i'm so close! haha.

thanks so much for your guys' help i can't tell you how much i appreciate it.
 

·
Registered
Joined
·
138 Posts
i'm reinstalling all the .zips as my last try for the night. but obviously my wifi is painfully slow tonight.....haha

EDIT:

well ... i'm done for the night. haha. my new question, though, is about MD5 sums. i don't know what they are, but if i have safestrap check the .zips for them, it says no md5 found and it aborts the flash. is this not something i should care about? or is it problem if its charging or not charging? (obviously i'm getting desperate for answers haha).

I just don't get it.

thanks for your patience. seriously.
 

·
Registered
Joined
·
138 Posts
@msass: MD5 sums are checks used for file integrity as far as I know. If the sums aren't matching, the file is bad.
did you check "force md5 check on all zips" before flashing these? these are the third set of zips i've downloaded off page one of this thread, and none of them, including the jb slot fix have MD5s. the error says "no MD5 file found! Aborting install. Error flashing zip '/external_sd/download/[.zip]'"

...
 

·
Registered
Joined
·
138 Posts
Yeah I changed my DPI but that's not what I meant. I meant that all those non folder files (the scripts and things) are also displayed, whereas it isn't on yours. Wasn't sure whether you changed that as an option in the settings or not.

But wait, I thought you HAD to be on JB to do this? Wasn't aware it could work from ICS, especially as the rom slot fix is for JB. I did all this from JB, and it worked.

EDIT: @mass: No I didn't. I actually just took my chances which was a pretty dumb decision. Try downloading them again and matching them through windows if you can. I'm sure you could find a free utility, but I don't know of one.
others have been telling you can be on stock ICS. that's why i was confused when people told me to put the JB slot fix on here.....

also the md5s match. fjklsadjfls. at what point in time would i install the JB leak? do i install it over the restored version of ICS on the rom slot? or over the stock rom, then back that up and send it to the rom slot?
 

·
Registered
Joined
·
138 Posts
would you mind doing me a favor and try flashing any of those files with the md5 check box selected? just to see if it aborts for you too. i don't think its an issue with safestrap because i can restore my stock to the rom slot and it runs fine.
 

·
Registered
Joined
·
138 Posts
right...well that means everything is working fine. i'm going to try putting the stock on JB and see if that works.

has anyone done this with stock ICS 4.04 updated fully on the stock slot? it seems like everyone is coming from the JB leak
 

·
Registered
Joined
·
138 Posts
GOT IT BOOTING UP!! inkdaddy there is hope on the horizon!!!! keep going hahaha.

anyway. i'm pretty sure this was a problem with having ICS as the stock. i didn't do anything different besides install the JB leak. just for anyone new looking into it.

EDIT:

hmm....keeps giving me an "unfortunately, Android keyboard has stopped." message.

EDIT 2: mine seems to be a little bit buggy. i let it sit for a good ten minutes or so when it booted.

I thought other people were trying to get circles widget back, and smart actions. i still have those.... and i have two versions of the camera application. and the clock app doesn't work. and the android keyboard doesn't work (swype does). should i re flash the ROM?
 

·
Registered
Joined
·
138 Posts
I didn't do system. sorry for being such complete rookie about all this...i can't even handle it haha. i just thought doing a system wipe would get rid of everything i had just uploaded to it.....let me try again.
 
1 - 20 of 121 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top