Android OS Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
16 Posts
First off, here's my original post:

http://rootzwiki.com...ase-to-another/

In a nutshell, I've tried to move things from my wife's old phone to her new one. Both are Samsung Galaxy S Showcases. I have:
  • made a backup of the old phone using ClockworkMod Recovery 4.0.1.0 for Fascinate/Mesmerize/Showcase. Also made a backup for Odin using the procedure outlined here: http://forum.xda-dev...d.php?t=1082288
  • used Odin to get new phone from Android 2.3.5 to 2.2.1
  • attempted to restore CWM backup, which failed saying it couldn't unmount /system (actually, it worked except that I had no service on the phone)
  • made and flashed a .tar.md5 of factoryfs.rfs in an attempt to restore the system through Odin, which didn't work
  • tried to restore CWM backup again, which seemed to work. But then the phone froze on the "SAMSUNG" screen during booting (at least after 5 minutes or so nothing had happened)
  • made a .tar out of all the backup files I had made for Odin using IZArc and tried to flash that, which failed
So now I get the phone, the exclamation point inside the triangle, and the computer when I attempt to power on. I can still connect to my laptop.

Any help would be extremely appreciated and would probably save me from a beating from my wife
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #2 ·
Ok, I just got the brilliant idea that I could use Odin to get the phone back to the stock 2.2.1 state (or I suppose it could be a slightly-modded state), so I can at least boot the phone now. But I still am at a loss for getting this phone to a usable state, so far as being able to make calls, text, etc.
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #5 ·
I also have my own Showcase, which is identical so far as hardware goes. And it's currently working as it should. So if there are things I need to get off of it, I can.
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #6 ·
Ok, I've tried several other things, but nothing has worked. The new phone currently boots up normally into Android 2.2.1 (again, it came to us with 2.3.5, but I thought moving back to the same version as the old phone might make things easier). I restored a full backup made from Titanium Backup, so I have the old apps, data, etc. But I have no connectivity, and "About phone" displays "Unknown" for "Hardware version" and "Baseband version." I tried to flash modem.bin using Odin's "Phone" section, but this didn't seem to do anything. And the phone was activated and worked before I started messing with things.

Regarding a .pit file, I did use one when I flashed the phone with what I'm told is the full version of a 2.2.1 (EE25) Odin-flashable package. I used the one that came bundled with a zip file that someone had linked to from (I think) the xda forums. I did not, however, use a .pit file when trying to flash the modem.bin mentioned above or the backup I made from the old phone.

So here's what I have available to me now:
  • My Showcase, which is hardware-identical to my wife's old and new phones.
  • The full 2.2.1 (EE25) stock Odin package for the Showcase.
  • A backup of the old phone that I made using the ClockworkMod Recovery console.
  • A backup of the old phone that I made using this procedure: http://forum.xda-dev...d.php?t=1082288
  • A backup of the old phone made with Titanium Backup
  • Odin3 v1.30, Heimdall suite 1.3.1, and just enough knowledge to be dangerous
And here are the questions I currently have:
  1. How is the carrier and phone line activation information stored, and can I do anything to fix that?
  2. Is there any hope that I can get everything from the old phone onto the new phone, or at least have the new phone able to call, text, etc., again?
Thanks again.
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #7 ·
I realized that I made the backups of the old phone after it was deactivated, so that might have something to do with it.
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #8 ·
Apparently, all the personal info was still around. I flashed the 2.3.4 (EH09) ROM linked to from http://rootzwiki.com...m-update-flash/, and the phone's radio functionality was restored. I couldn't update with Kies mini, but restoring a ClockworkMod backup of the new phone (before I screwed around with it) brought it back to 2.3.5 (EI20). Then I just restored apps and settings from the Titanium Backup of the old phone.

So I suppose the new phone didn't like things too well when I downgraded Android.
 
1 - 8 of 8 Posts
Top