Android OS Forum banner

1 - 16 of 16 Posts

·
Android Beginner
Joined
·
6 Posts
Discussion Starter · #1 ·
So i dropped my X, cracked the screeen and apparently rattled the battery enough for it to swell twice the normal size. Got a new battery and turned on the phone, the white M comes up and never leaves the screen. I did an full SBF with 2.3.34 and it went flawless. Phone reboots and is STILL stuck on the M. I can get into the stock recovery as well, but it never boots past the M. Am I SOL now? Should i attempt another SBF file or SBFportable?
 

·
I just hide here
Joined
·
2,237 Posts
hmm...it doesnt bootloop? it just sits at the M? U can try flashing again. but it sounds to me like u may have done some hardware damage.
 

·
Android Beginner
Joined
·
6 Posts
Discussion Starter · #5 ·
Nope, first time i've dropped a phone so i've got few backups. Guess i'll see what this goes for on ebay. Or maybe part it out.
 

·
Themer
Joined
·
192 Posts
Do you hear any noises when the phone attempts to boot? Probably jarred the processor or something. I'm sure you can get a decent price by selling for parts.
 

·
I just hide here
Joined
·
2,237 Posts
Dang that sucks. Ya u can always sell it for parts. Take it no upgrade either?

Sent from my DROIDX using Tapatalk
 

·
Android Apprentice
Joined
·
84 Posts
Sbf. That fixed it for me.

Well actually try holding power and home and then boot recovery and wipe data.

I did it wrong and had force closes so did sbf.

Sent from my DROIDX using Tapatalk
 

·
Android Beginner
Joined
·
6 Posts
There aren't any noises that are loud enough to hear. But putting it up to my ear i can hear a somewhat highpitch noise.

Upgrade isn't for another 8months.

I tried KDS1 it runs thorugh everything, but still not getting past the M.

Also tried the Gingerbread SBF, stuck at a much nicer looking M. Nada. So, off to ebay it goes.
 

·
I just hide here
Joined
·
2,237 Posts
Ya man i would flash every .sbf i could find. and also after flashing make sure u go into stock recovery and wipe data/Factory Resets

Heres a thread i made with all the .sbfs i have and a few other users posted.

DX-SBF Links
 

·
Themer
Joined
·
192 Posts
If an SBF has completed and you followed with a factory reset, you're X is damaged internally. If it cracked the screen then it must've taken a hard fall.
 

·
Android Beginner
Joined
·
6 Posts
Discussion Starter · #13 ·
The only access i have is to the stock recovery. I'm pretty sure after SBFing 4 times with 2.3.34 and .596 and using KDS1 iso that this thing is toast. Oh well. Maybe i'll tear it down or just sell it for parts. Thanks, guys.
 

·
Android Beginner
Joined
·
6 Posts
Discussion Starter · #15 ·
Not sure how i didn't notice this earlier in the day. Came home and checked out the stock recovery. Shows a bunch of errors

E:Can't mount /cache/recovery/command
E:Can't mount /cache/recovery/caller
E:Can't mount /cache/recovery/log
E:Can't open /cache/recovery/log
E:Can't mount /cache/recovery/last_log
E:Can't open /cache/recovery/last_log

Would this basically mean the internal flash storage is damaged? Or maybe a connection has come undone?
 
1 - 16 of 16 Posts
Top