Android OS Forum banner

Trouble with amazon appstore

2349 Views 1 Reply 1 Participant Last post by  cmdixon
For the past several days I have been unable to download anything from the amazon appstore. I've tried purchasing new apps and updating existing apps. Here's what I see:

User Authenticated
Purchase Complete
Download in Progress

After a minute or so, I get an error "There was an error while downloading (app name). Please try again."

I did some searching yesterday and ran across some threads that indicated having multiple devices associated with your account could cause a problem. I only have 1 device, but I logged on to amazon to check. Sure enough, there were 3 Motorola Droid X's listed. I deregistered all 3 of them, uninstalled the appstore, gave my cell number to amazon and they emailed me a link to download and install the appstore.

I couldn't even get that to work on my phone. I ultimately downloaded the appstore on my computer and then transferred to my phone. Then I installed it - with no problem. However, I still can't download any apps. That didn't seem to make a difference at all. I have rebooted my phone, done battery pulls, even tried a different sd card. I'm out of ideas. Can anyone help?

By the way, I have a Droid X running Liberty GB v0.09.


1 - 2 of 2 Posts
Well, I got notification this morning that there was an update for the appstore. I installed it and voila! everything is working again. Weird.
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.