Android OS Forum banner
1 - 7 of 7 Posts

· Registered
Joined
·
49 Posts
question about the required packages:

in the OP it says to get these:
sudo apt-get install git-core gnupg flex bison gperf build-essential zip curl libc6-dev libncurses5-dev:i386 x11proto-core-dev libx11-dev:i386 libreadline6-dev:i386 libgl1-mesa-glx:i386 libgl1-mesa-dev g++-multilib mingw32 openjdk-6-jdk tofrodos python-markdown libxml2-utils xsltproc zlib1g-dev:i386

and then:
sudo ln -s /usr/lib/i386-linux-gnu/mesa/libGL.so.1 /usr/lib/i386-linux-gnu/libGL.so

on the ICS tutorial it says to get these:
sudo apt-get install curl git-core gnupg flex bison gperf libsdl1.2-dev libesd0-dev libwxgtk2.6-dev squashfs-tools build-essential zip curl libncurses5-dev zlib1g-dev sun-java6-jdk pngcrush schedtool g++-multilib lib32z1-dev lib32ncurses5-dev lib32readline5-dev gcc-4.3-multilib g++-4.3-multilib

So should I redo the packages using the listed jb packages? Will they just update whatever needs it? Also still on 11.10, so am guessing I can go ahead and let ubuntu update to 12.04 before doing this? Thanks.
 

· Registered
Joined
·
49 Posts
I haven't had good results trying to manually repackage the zip (what method were you using?). I've been able to manually pull the audio_policy.conf file from ~/aokp_jb/device/samsung/tuna/audio; I then adb push it to /system/etc after flashing the ROM. That works for me (so far).
Thanks for this, my toro build was missing this too. Found it in the build folder and copied it over. Working great.
 

· Registered
Joined
·
49 Posts
Thanks, got an error on the make clean too. Am going to do a full repo sync.
Clean repo sync & build gets me this error now:


  1. make: *** [out/target/product/toro/obj/SHARED_LIBRARIES/libwebcore_intermediates/Source/WebKit/chromium/src/WebCString.o] Error 1

  2. make: *** Waiting for unfinished jobs....

  3. make: *** [out/target/product/toro/obj/SHARED_LIBRARIES/libwebcore_intermediates/Source/WebKit/chromium/src/android/WebHitTestInfo.o] Error 1

  4. make: *** [out/target/product/toro/obj/SHARED_LIBRARIES/libwebcore_intermediates/Source/WebKit/chromium/src/android/WebDOMTextContentWalker.o] Error 1

  5. make: *** [out/target/product/toro/obj/SHARED_LIBRARIES/libwebcore_intermediates/Source/WebKit/android/jni/WebCoreJniOnLoad.o] Error 1
Help! :)
 

· Registered
Joined
·
49 Posts
Sorry, I might be a little bit late on asking this, but I have already started repo syncing, but if I was doing this for another phone other than toro, like my phone (crespo4g), would all I have to change is
. build/envsetup.sh && brunch toro
to
. build/envsetup.sh && brunch crespo4g?
When you repo sync you are syncing for all devices that are supported. It is not device specific. You only specify the device when you are building. Just to clarify :)
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top