Android OS Forum banner
3461 - 3468 of 3468 Posts

· Registered
4 Posts
1 errormake: *** [/home/unnamed/Document/OS/aokp/kitkat/out/target/common/obj/JAVA_LIBRARIES/telephony-common_intermediates/classes-full-debug.jar] Error 41make: *** Waiting for unfinished jobs....
Hello all, i got same error after 5 times to building AOKP Kitkat 4.4.3 KTU84M for ancora device
This is my log

i've done my build for 3 hours, and it booting up.
Thanks to all member in here who help me a lot. :)


· Love your frenemies
1,542 Posts
I just synced the repo and tried building hammerhead (nexus 5) and it keeps crashing (the brunch hammerhead command) at ThemeProvider. I made clobber and trying again, so if it crashes again, i'll post the output. usually i don't need help but i can't figure this out.

· Love your frenemies
1,542 Posts
Whenever you get one of those "error" lines; the build will not complete without your first fixing the cherry pick.
- To do this -
Install Meld:
sudo apt-get install meld

Then the next time an error pops up:
Type "git mergetool"
It will say there are conflicts on _____ file(s).
Press enter to open meld.

As Akellar said, the middle is the file you're truly worried about...but I find it easiest to just make all three match until the "all files are identical" pop-up comes up.
Green blocks can generally just be moved across using the arrow that comes out of the block.
This is only not true when you're moving blocks in that are no longer part of the code.
So if it's on the far right file in meld...make sure it pertains to the cherry pick or you're probably moving in code that was removed.
Blue blocks are usually a copy and paste of a few lines from one block onto the top of the other.'ll have to figure out yourself.

Once all files are fixed with meld:
git status
This will show the .orig files that need to be removed. Remove all .orig files.
git add -A
git commit -a
Control+X will commit the cherry...
And you're done.
Kit, always saving me from the past.

· Registered
5 Posts
Hey guys,

Any help with AOKP Lollipop?

Trying to build nightlies but it just keeps showing an error as follows:

[email protected]:~/aokp$ breakfast mako
ls: cannot access device/*/mako/ No such file or directory
build/core/ * Can not locate config makefile for product "aokp_mako". Stop.

** Don't have a product spec for: 'aokp_mako'
** Do you have the right repo manifest?

I've tried different variations but it still won't build. Are the files not ready to go or is the device name wrong?
3461 - 3468 of 3468 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.