Android OS Forum banner
1 - 18 of 18 Posts

·
Registered
Joined
·
1,298 Posts
Team Win Recovery Project 2.2, or twrp2 for short, is a custom recovery built with ease of use and customization in mind. It's a fully touch driven user interface - no more volume rocker or power buttons to mash. The GUI is also fully XML driven and completely theme-able. You can change just about every aspect of the look and feel.

Twrp 2.2.0 change log
- On-screen keyboard in recovery! -- supports long press, backspace repeat, and swipe left deletes everything left of the cursor
- Name new backups and rename existing backups
- Rename files and folders in the file manager
- Pseudo-terminal emulator
- Support decrypting an encrypted data partition on Galaxy Nexus (enter password using keyboard)
- Backup archive splitting -- allows backup and restore of data partitions larger than 2GB
- Simplified XML layout support between resolutions
- Added dual storage selection radio buttons to zip install, backup, and restore pages
- Improved zip install compatibility
- Updated update-binary source code
- Numerous small bug fixes and improvements​

This is an unofficial port of TWRP by ME (runandhide05)

Standard disclaimers
blablabla im not responsible for anything
Please report any issues as I will be perfecting it.[/B]

Change log
0.0.4
initial beta release
0.0.7
fixed factory reset wiping internal sdcard
fixed nandroid backups restoring /data/media (creating LARGE backups)
fixed restoring /data
0.0.8
fixed restore system partition
all should be 100% now ( should be leaving beta soon, il leave it for a few days and i want to hear back from people)
0.1.1
removed usb mount(dose not work with xoom)
themed and added some EOS swag
v1.0 (Release)

Updated to TWRP 2.2.2.0 (8/24/12)
Many updates see TWRP github for changes
some but not all inclusive
scroll improvements
decryption (on supported devices)
OTG support (on supported device)

* note about 2.2.2.0 the external card is not mounted by default ( just mount it once in recovery( from main page click mounts, then check mount sdcard) )
FIXED[strike]** Noticed that theme ui.zips are not loading on boot ( i know about it)[/strike]

as normal internal SD is at /data/media ( or simply /emmc )
External is at /sdcard ( once the card is mounted )( REMEMBER TO MOUNT BEFORE YOU TRY TO MAKE BACKUP TO EXTERNAL OR RECOVERY WILL CRASH AND LOOP AT TWRP LOGO)

Download Links
NEW TWRP 2.2.2.0
Ln.Wn.twrp2.2.2.0.ui.zip - 9.90 MB install script for windows or linux
TWRPv2.2.2.0_R.A.H.ui.img - 4.79 MB
TWRPv2.2.2.0_R.A.H.ui.zip - 4.89 MB

twrp 2.2.0
script includeing new v1.0
recovery image v1.0
Flash Zip v1.0


Installation instructions (option 1)

Download zip file from link below
Place zip on Micro SDcard
Reboot into existing recovery
Flash TWRP2.2.0_R.A.H.v0.0.X.zip

Installation instructions (option 2)
download recovery.img
place tablet in to FastBoot
Flash Recovery with
Code:
fastboot flash recovery name-of-recoveryimage.img

Installation instructions (option 3)

Download zip file, extract zip to anywhere, choose the Operating system
linux or windows folder,
For windows:
Simply click the RUNME.bat
For Linux:
Make adb and fastboot files included in the linux folder executable
Make script executable.
click RUNME.sh


Installation instructions (option 4)

download through goomanager app
GooManager

I am proud to announce that today twrp recovery is now officially available through goomanager app.
These are the Stock (non-EOS themed)
Thank you Dees_Troy

Source: runandhide05's Github
For more info on TWRP see the Team Page teamw.in
Bug tracker bug tracker

Themes

I will probably do a few more themes, so i will just make a part here just for my themes

To install a theme on TWRP could not be easier
simply download the ui.zip from link below and save it to /sdcard/TWRP/theme/ui.zip
( aka /data/media/TWRP/theme/ui.zip)
and then boot into TWRP. thats it

A Zen State of Mind
A Zen State of Mind
screen shot

NEW theme

Black And Blue
black and blue ui.zip - 1.03 MB
screen shot
screen shot
screen shot
 

·
Registered
Joined
·
386 Posts
Very glad this has finally made its way onto the Xoom. I will have to install it now. Thanks
 

·
Android Apprentice
Joined
·
60 Posts
Okay awesome. Thank you. I will be installing this as soon as I get home.

Sent from my Galaxy Nexus using RootzWiki
 

·
Android Addict
Joined
·
277 Posts
Flashed it seems to be working fine. Looks diff than on my gnex

Sent from my Xoom using RootzWiki
It does look different than the Gnex version. I do think though that it works as well. I do notice that the touch is way more responsive on the Xoom compared to my Gnex.
Maybe something to do with the screen size, and that my fingers don't really fit the menu selections on the Gnex TWRP as easily.
Glad to see TWRP on the Xoom.
 

·
Android Apprentice
Joined
·
60 Posts

·
Android Beginner
Joined
·
1 Posts
Hoping you guys can help. Installed TWRP without a problem. Trying to install a new rom is where my problems began. I downloaded the rom using goomanager. rebooted into TWRP verified that the Rom was in fact on the Xoom then proceeded to wipe and factory reset and then tried to install the updated room.

set up as follows:

zip file signature verification? unchecked
Force MD5 checks on all zips? unchecked

when I try to flash it says:
verifying filesystem...
verifying partition sizes...
error flashing zip 'data/media/EOS-wingray-20120828.zip'

I have downloaded the latest ver of EOS and have it on the external SD but I can not get TWRP to read the file on the external SD
I have tried to select "Using external SD" as well as "Using internal storage"
neither seem to allow me to browse to the file that I have put on the external sd.

I have also tried to click mount in TWRP and made sure mount SDcard is checked.
does anyone know how to either get TWRP to install a file from the root directory of the external SDcard, or is there a way to mount a xoom stuck in TWRP using usb so I can move the file from my pc?

Any help would be greatly appreciated!

-ianh2o
 

·
Supporting Member
Joined
·
820 Posts
Thanks for this, one thing when i tried to backup using external the recovery crashes and get stuck on the TWRP Blue start up screen .
 

·
Android Apprentice
Joined
·
101 Posts
Thanks for this, one thing when i tried to backup using external the recovery crashes and get stuck on the TWRP Blue start up screen .
I had the same issue and figured it out last night. while in recovery you need to mount the external sd card. select mount then select mount sd card and it will change to unmount sd card. then run backup again.
 

·
Supporting Member
Joined
·
820 Posts
I had the same issue and figured it out last night. while in recovery you need to mount the external sd card. select mount then select mount sd card and it will change to unmount sd card. then run backup again.
Yep that did the trick, thanks much.
 
1 - 18 of 18 Posts
Top