Android OS Forum banner
1 - 1 of 1 Posts

12 Posts
Discussion Starter · #1 ·
I am having a problem with voice commands over bluetooth and I don't know if this is a common problem or if it's related to samsung in general, ics, or if I have a random hardware problem in my handset.

When I try to use any type of voice command program in conjuction with a bluetooth headset, I can hear the interactions in my earpiece but rather than using the bluetooth microphone, the phone listens to the built-in microphone instead. I work in a very noisy environment and cannot use the built-in microphone at all and be understood over the noise.

I've used several programs, iris, vlingo, google's voice search, go dragon... All of them use the phone's microphone instead of the bluetooth. They all give the prompts through the bluetooth headset though.

I've tried three different headsets with a2dp, hsp and hfp capabilities. A Blueparrot VXi B250-xt plus, Motorola Finiti, and Plantronics Voyager Pro HD. All three of these did work with my previous phone, a Motorola Droid Pro, using Vlingo and google's voice search with absolutely no problems at all.

I tried using the default 4.0.2 rom, both locked and unlocked. I have also tried a few different 4.0.3 roms (bugless, redemption, codename, cm9 kang, and currently on aokp milestone 3.)

Is this a problem common to the Galaxy Nexus or all Samsung phones? I saw the review of the Nexus S by a pcmag editor had the same problem.

Is this a limitation of ICS that is not yet working in 4.0.2 or 4.0.3?

Is this just a random hardware problem in my specific phone which would be fixed by replacing it?

note- I have the .09 version of the hardware, and don't know if this may have been fixed in .10 or not.
1 - 1 of 1 Posts