Android OS Forum banner

Well I did something wrong....

1825 Views 4 Replies 2 Participants Last post by  viper3two
Solved! by my self....

Well I am pretty versed in the messing up of things it seems... I messed around with ubuntu on the touchpad loved it for about a week now I have lost alot of the love and would love to get the space back from it... being"smart" I just ran webos doctor to restore to factory but that seems to have left me with about 300 mb of free space and about 720mb total space for the usb drive, now I have tried the step-by step process of removing the ext3fs partition its gone but I cant seem to assign the correct space to my dev/mapper/media partition it still hasnt changed even after running the resizefat partition maybe its because the /proc/partitions file says I have only 14895104k for it but I have deleted the 10gb (I know excessive) ext3fs partiton in lvdisplay its gone but media is still only 720mb... what am I doing wrong? any help? (yes I know one heck of a desperate first post)
1 - 5 of 5 Posts
I got it figured out nevermind, I had to umount /dev/mapper/media-store, then lvresize to the correct size then had to do resizefat to the size also cant believe I was that stupid with it....
Care to post what you did exactly? I found a site that has some info but got lost on the resizing part. Or maybe a link to where you found the info? Thanks
The bulk of the useful things I found were here But its a bit different I believe first I did "lvdisplay" and "df -kh" then i checked if ext3fs was gone and checked the size of store-media (mine was 720MB), then i did the command for unmount so I saw that the path was /dev/mapper/store-media (yours may be different double check that) so id did "umount /dev/mapper/store-media" then its important to do lvresize first so I did "lvresize -l (tells it to do by size) 1610 (this was the largest size I could get yous may be different again) /dev/mapper/store-media" it then says it was resized to about 12.93GB, then do "cat /proc/partitions and note the size there and then do the command "resizefat /dev/mapper/store-media 1489510 (that was my size)" then viola it was good now read through that link first before starting as its useful but it was done on pre and you NEED to do that lvresize first something that guide left out... ( one nice thing is that with the resizefat command you can err on the big size and it will automatically correct it to the biggest possible size)

Also the conditions on lvresize may be -l or -k its one of the two... still kinda getting the swing of things on linux (and loving it!)

Hope this helps from one frustrated newb to another:tongue3:
See less See more
Thank you thank you thank you!!!! Yep, frustrated is the word here too, this will get things straightened up though. Appreciate the reply and help!
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.