Android OS Forum banner

1 - 17 of 17 Posts

·
Save me from the Wipevangelists!
Joined
·
404 Posts
Discussion Starter · #1 ·
I'm not sure this is the right place for this, so forgive me, but I can not get BAMF ROMs (I've tried Sense 3.0 rc4.9 AND GingeRimix 2.1) to connect to wifi, when installed in a Boot Manager slot.

a) it fails on both my wifi and my neighbors
b) wifi works fine on OMFGB installed in a Boot Manager slot
c) I tried both ext2 and ext4
d) When I install Remix 2.1 directly onto the phone, wifi works fine

So I think I've isolated it to Boot Manager, and BAMF* ROMs. Everything seems to work fine except wifi won't connect.

ANY ideas, or at least, can anyone confirm I'm not crazy?

*I will try LGB and another Sense ROM. If it works on one but not the other, then I'll say "AOSP works, Sense doesn't" so far I've only tried BAMF.
 

·
Android Beginner
Joined
·
9 Posts
I am having the same issue. I have heard that slot 1 on boot manager can cause problems so I have put das bamf rc4.9 on slot 2 and it is doing the same thing. I have 3g (no 4g where I live) but the wifi will not connect at all. I tried CM7 and wifi worked.
 

·
Save me from the Wipevangelists!
Joined
·
404 Posts
Discussion Starter · #3 ·
"austinwilliams1980 said:
I am having the same issue. I have heard that slot 1 on boot manager can cause problems so I have put das bamf rc4.9 on slot 2 and it is doing the same thing. I have 3g (no 4g where I live) but the wifi will not connect at all. I tried CM7 and wifi worked.
Well that eliminates crazy. :)

I have OMFGB nightlies in slot 1. Seems fine. Slot 2 is also the one I'm trying with bamf. I'll keep trying ROMs to narrow down the problem unless / until someone has a brilliant idea.
 

·
Save me from the Wipevangelists!
Joined
·
404 Posts
Discussion Starter · #5 ·
By the way, I'm also not able to connect to wifi using Liquid Gingerbread 2.5, so it's not an aosp vs. Sense thing. Also slot 2, so that may be the trouble.

By the by the way, I used Imo's lean kernal on my LGB install, as the stock kernal hates my phone.
 

·
Android Apprentice
Joined
·
57 Posts
I was having trouble connecting to wifi on BAMF Sense 3.0 (also slot 2). I could hit my router, but would hang on "Obtaining IP address". Found if I used static IP to manually enter network info, I could connect fine.

Sent from my ThunderBolt using Tapatalk
 

·
Save me from the Wipevangelists!
Joined
·
404 Posts
Discussion Starter · #7 ·
"WishRyder said:
I was having trouble connecting to wifi on BAMF Sense 3.0 (also slot 2). I could hit my router, but would hang on "Obtaining IP address". Found if I used static IP to manually enter network info, I could connect fine.

Sent from my ThunderBolt using Tapatalk
Thanks for that. I will setup a static.
 

·
Android Apprentice
Joined
·
57 Posts
If I get ambitious, I might email the Boot Manager devs to see why this could be an issue. Maybe theres a certain script that certain roms run during install that Boot Manager doesn't like?

Sent from my ThunderBolt using Tapatalk
 

·
Android Apprentice
Joined
·
136 Posts
I have been using bootmanager to switch between BAMF Sense 3.0 RC4.9 and other roms ever since bootmanager came out and have had this happen a couple times. Slot 1 on bootmanager has been known to cause some issues, so ive stayed clear of it. I can assure you that it is not just one rom that's having issues. Its actually not a rom thing but a bootmanager thing. Its happened to me on CM, OMFGB, and bamf. Ive switched them all around in slots just to make sure and its still been happening every so often, not each time but it still happens =/

My phone is currently almost dead but im going to try manually wiping cache and dalvik when its charged after installing via bootmanager to see if that solves the issue. Or if somebody else wants to try that first... ;)

Its definitely a bootmanager issue and not a bamf thing :)
 

·
Save me from the Wipevangelists!
Joined
·
404 Posts
Discussion Starter · #10 ·
"Neverendingxsin said:
I have been using bootmanager to switch between BAMF Sense 3.0 RC4.9 and other roms ever since bootmanager came out and have had this happen a couple times. Slot 1 on bootmanager has been known to cause some issues, so ive stayed clear of it. I can assure you that it is not just one rom that's having issues. Its actually not a rom thing but a bootmanager thing. Its happened to me on CM, OMFGB, and bamf. Ive switched them all around in slots just to make sure and its still been happening every so often, not each time but it still happens =/

My phone is currently almost dead but im going to try manually wiping cache and dalvik when its charged after installing via bootmanager to see if that solves the issue. Or if somebody else wants to try that first... ;)

Its definitely a bootmanager issue and not a bamf thing :)
Are you referring to the "wifi won't get an address" issue? I had no issue with OMFGB in slot 1 or slot 2. I've tried three others in slots 2 or 3 with no luck. Could it have been chance?

So is Dalvik cache shared between boot manager ROMs? It doesn't have its own folder. If it's using and not wiping the same Dalvik when it switches, that could cause all kinds of problems. Could that be the culprit here?
 

·
Android Apprentice
Joined
·
57 Posts
Pupalei said:
Are you referring to the "wifi won't get an address" issue? I had no issue with OMFGB in slot 1 or slot 2. I've tried three others in slots 2 or 3 with no luck. Could it have been chance?

So is Dalvik cache shared between boot manager ROMs? It doesn't have its own folder. If it's using and not wiping the same Dalvik when it switches, that could cause all kinds of problems. Could that be the culprit here?
I had tried wiping dalvik (after booting into the sdcard rom) with no success. I have an email out to the devs, just waiting on a reply to see what they say. At least in my case, it seems to only affect sense based roms.

Sent from my ThunderBolt using Tapatalk
 

·
Save me from the Wipevangelists!
Joined
·
404 Posts
Discussion Starter · #12 ·
"WishRyder said:
I had tried wiping dalvik (after booting into the sdcard rom) with no success. I have an email out to the devs, just waiting on a reply to see what they say. At least in my case, it seems to only affect sense based roms.

Sent from my ThunderBolt using Tapatalk
Ok, appreciated.
 

·
Save me from the Wipevangelists!
Joined
·
404 Posts
WishRyder said:
I had tried wiping dalvik (after booting into the sdcard rom) with no success. I have an email out to the devs, just waiting on a reply to see what they say. At least in my case, it seems to only affect sense based roms.

Sent from my ThunderBolt using Tapatalk
Any word from the dev? I installed the latest OMFGB nightly over my existing slot 1, and... it broke wifi. I don't think there's a way for me to assign a static at this point. It simply says "error" on the menu item where I would turn on wifi. It will not let me check the wifi box.

If I give up and use 3G, everything else seems to work. Weird.

Edit: Full circle. Now my phone ROM (CM7) has broken wifi.
 

·
Android Apprentice
Joined
·
57 Posts
Pupalei said:
Any word from the dev? I installed the latest OMFGB nightly over my existing slot 1, and... it broke wifi. I don't think there's a way for me to assign a static at this point. It simply says "error" on the menu item where I would turn on wifi. It will not let me check the wifi box.

If I give up and use 3G, everything else seems to work. Weird.

Edit: Full circle. Now my phone ROM (CM7) has broken wifi.
I've traded some emails with the devs. They confirmed that once installed, the ROM shouldn't know (or care) that its on SD. As of Sunday, it sounded like they were going to crack open the ROM zip and see if something strage is going on during install.
 

·
Android Beginner
Joined
·
74 Posts
Check your kernel when you're running BAMF. I noticed mine is back at the stock HTC kernel and wont connect either.

Sent from my ADR6400L using RootzWiki Forums
 

·
Save me from the Wipevangelists!
Joined
·
404 Posts
"WishRyder said:
I've traded some emails with the devs. They confirmed that once installed, the ROM shouldn't know (or care) that its on SD. As of Sunday, it sounded like they were going to crack open the ROM zip and see if something strage is going on during install.
I think you're onto something with thinking something is going on during install. I will keep experimenting. I restored my nandroid and wifi is back on my phone ROM.

EDIT: So the wifi works fine on the restored nandroid (phone ROM). Even after a reboot. Then if I boot into the OMFGB slot 1 with the broken wifi, and then boot BACK to my phone ROM, wifi is broken on that, too.

We can't be the only ones the devs have heard of having this problem.
 

·
Android Apprentice
Joined
·
47 Posts
In addition, I have noticed that if you change kernels using boot manager on a rom that has been installed and has succesfully got wifi connection before the kernel change then the wifi will break after changing the kernel.
 
1 - 17 of 17 Posts
Top