Android OS Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Hey everyone,

I know that there are other threads out there about this, but they have become clogged up with other answers, discussion etc.
My issue is randomly my wifi just doesnt connect to my network and there is no pattern to when this happens. The other problem with that is, when i try to go into the settings to connect to a network, it freezes, and asks me to force close or wait. After about 3-5 times of making the touchpad forget and connect to the network, it finally works. Is there a clear cut fix to this? I tried changing the sleep policy to never, but this seems to drain my battery faster than i would like it to. Any suggestions? Thanks
 

·
Android Apprentice
Joined
·
42 Posts
When I was on CM7 Alpha 1/2/3... I had same problem as what you mentioned above.

However, currently im on [vB2][CM7 XRON-ified] and using Wi-Fi Manager Premium.I barely have issues with WiFi now..

(Not sure if Wi-Fi Manager app makes a difference, but its a simple widget on my mainscreen in order to connect to specific wifis I have set)

Links;
Xron http://forum.xda-developers.com/showthread.php?t=1321335
Wi-fi Mng https://market.android.com/details?id=org.kman.WifiManager&hl=en
Thread on Rootzwiki for Xron; http://rootzwiki.com/topic/11416-for-those-who-have-ignored-it-try-out-xronifieds-recent-updates/
 

·
Android Beginner
Joined
·
22 Posts
same scenerio here.almost no issues with xronified most recent build. once in awhile it will not reconnect when if wakes seems to be the only issue.
 

·
Registered
Joined
·
1 Posts
When I was on CM7 Alpha 1/2/3... I had same problem as what you mentioned above.

However, currently im on [vB2][CM7 XRON-ified] and using Wi-Fi Manager Premium.I barely have issues with WiFi now..

(Not sure if Wi-Fi Manager app makes a difference, but its a simple widget on my mainscreen in order to connect to specific wifis I have set)

Links;
Xron http://forum.xda-dev...d.php?t=1321335
Wi-fi Mng https://market.andro...fiManager&hl=en
Thread on Rootzwiki for Xron; http://rootzwiki.com...recent-updates/
is there any configuration i should do to wi fi mng to make it not drop the wifi or should i just leave it as is
 

·
Registered
Joined
·
2 Posts
Id say go through your router settings and disable anything fancy like QoS. Saw this mentioned somewhere but can't find the article now.
Also, I'm using a b/g/n router in mixed mode and I found that by fixing the bandwidth at 40Mhz instead of the default Auto the connection became a lot more stable. This is probably only relevant to mixed mode n routers though.
 

·
Registered
Joined
·
4 Posts
I had been having the problem of periodic disconnections with my wifi. Booting into WebOS confirmed it wasn't a hardware issue. But now all my woes are gone. I'm on Alpha 3.5. Here are the steps that worked for me:
  1. Pressing menu in Wi-Fi Settings, go to Advanced, and make sure you are NOT using a static IP.
  2. Download an app called Wi-Fi Analyzer from the market (free), and use it to find out which wifi channel is used least in your area. The app also has a rating system for the best wifi channel that uses the same "least used" method. For me, it turned out to be channel 11 (most of my neighbors use 4-6).
  3. Configure your router to use the "best channel" found in step 2.
  4. Back on the tablet, forget your current wifi connection.
  5. Now reconnect to your network, and cross thy fingers.
This MIGHT work for those experiencing those annoying disconnections. My wifi has been rock stable ever since *knocks on wood*. This is clearly not a solution for those who can't even connect to a wifi. Hope this helps?
 

·
Registered
Joined
·
5 Posts
so, i decided to factory reset cyanogenmod for the touchpad, the wifi settings got reset, which is a good thing and now after one night, the wifi has not lost connection so far which is a good thing.

Edit: after a few days with the xron build, it was great, and over night, it just doesnt work any more. The worst thing is, when i go into the wifi access points settings, it freezes and then prompts me to force close that part of the settings. I am going to wipe the touchpad today and then reinstall using the alpha 3.5 build. If that works then im going to keep it, otherwise, im going to switch back to the latest xron build.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #8 ·
so i wiped android completely off the touchpad and then installed it again with 3.5, and so far so good.
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top