Android OS Forum banner
61 - 80 of 121 Posts

·
Android Mechanic
Joined
·
203 Posts
Discussion Starter · #61 ·
Yes, what happens when you follow the guide (post #1). And I don't think it is power saving.

Sent from my DROIDX
 

·
Android Apprentice
Joined
·
26 Posts
Yes, what happens when you follow the guide (post #1). And I don't think it is power saving.

Sent from my DROIDX
i copied /pds/wifi/nvs_map.bin to /system/etc/wifi/nvs_map.bin

i then edited /init.mapphone_cdma.rc as you said
i then executed it
i powered off phone and then back on and here is what i got
http://pastebin.com/GNp9jHpL

i think it looks like same output dont it?
power save up and down every few seconds


  • <6>[ 32.496185] TIWLAN: 4198.179603: TrafficMonitor_ChangeDownTimerStatus: Going to power save, clear wake_lock!!

  • <7>[ 32.775604] turning off regulator

  • <6>[ 35.975830] TIWLAN: 4201.281316: TrafficMonitor_ChangeDownTimerStatus: Going to active, set wake_lock!!

  • <6>[ 37.472747] TIWLAN: 4202.778234: TrafficMonitor_ChangeDownTimerStatus: Going to power save, clear wake_lock!!

  • <7>[ 39.242340] turning off regulator

  • <7>[ 41.324188] tiwlan0: no IPv6 routers present

  • <3>[ 49.536621] binder: release proc 1946, transaction 7613, not freed

  • <6>[ 52.970336] TIWLAN: 4218.275792: TrafficMonitor_ChangeDownTimerStatus: Going to active, set wake_lock!!

  • <7>[ 54.045684] turning off regulator

  • <6>[ 54.972808] TIWLAN: 4220.278264: TrafficMonitor_ChangeDownTimerStatus: Going to power save, clear wake_lock!!

  • <6>[ 55.741943] TIWLAN: 4221.047399: TrafficMonitor_ChangeDownTimerStatus: Going to active, set wake_lock!!

  • <7>[ 56.787170] turning off regulator

  • <6>[ 57.001708] AUDIO_DRIVER:spkr1 = 0x20, spkr2 = 0x0

  • <7>[ 63.339385] turning off regulator

  • <6>[ 64.238800] TIWLAN: 4229.544256: TrafficMonitor_ChangeDownTimerStatus: Going to power save, clear wake_lock!!

  • <6>[ 66.250274] TIWLAN: 4231.555730: TrafficMonitor_ChangeDownTimerStatus: Going to active, set wake_lock!!

  • <6>[ 67.746582] TIWLAN: 4233.052038: TrafficMonitor_ChangeDownTimerStatus: Going to power save, clear wake_lock!!
 

·
Android Beginner
Joined
·
28 Posts
Awesome work blackadept!

Just did this on my CM7GB ROM and so far looks like I'm no longer limited to using 3g!

Thank you!

Sent from my DroidX running CM74GB using Tapatalk
 

·
Android Mechanic
Joined
·
203 Posts
Discussion Starter · #64 ·
Hey NP bud glad it helped!

For other poster, if you already have an nvs_map.bin are you still having an issue with your Mac address?

Sent from my DROIDX
 

·
Android Apprentice
Joined
·
26 Posts
Hey NP bud glad it helped!

For other poster, if you already have an nvs_map.bin are you still having an issue with your Mac address?

Sent from my DROIDX
do you see my message 2 posts above this one?
you dont see my quotes?
can you show your dmesg and some others too?
why am i the only one showing pastebin?

go on irc
im on freenode and in channel #cvpcs
im en1gma and we can talk there if you want
 

·
Android Mechanic
Joined
·
203 Posts
Discussion Starter · #66 ·
yeah I'm good, preciate the offer tho. Good luck with your wifi tho bud, I hope you get it working correctly.
 

·
Android Apprentice
Joined
·
26 Posts
yeah I'm good, preciate the offer tho. Good luck with your wifi tho bud, I hope you get it working correctly.
i knew that wasnt going to do anything.
this has to do with the power saving feature
if anyone wants to try and fix the problem you can see my pastebin 4 posts above this one.
there is a definately problem going to sleep and then active....it is going to sleep and then waking up alot

can someone do a dmesg and see if their droid-x running cm4dx GB is also doing this?
i gonna get my moms droid-x with stock vzw .605 rom and i will take a look at its dmesg and post it also
i could really use some help
 

·
Android Mechanic
Joined
·
203 Posts
Discussion Starter · #68 ·
That is due to your having wakelock issues. Check partial wakelocks and remove said app and you wont have those issues. Wakelocks and wifi aren't the same thing.....

Sent from my DROIDX
 

·
Android Apprentice
Joined
·
26 Posts
That is due to your having wakelock issues. Check partial wakelocks and remove said app and you wont have those issues. Wakelocks and wifi aren't the same thing.....

Sent from my DROIDX
yea thats what i mean the wakelocks
and they have something to do with losing wifi
when the wakelocks happen i can look on ly dd-wrt router and look at wireless clients and i can see the clients drops when that happens
not every single time but its close

so what exactly do i need to look for that can be causing this?
i think it has something to do with cm4dx

here are dmesgs of both my droid-x`s both had vzw .605 and both are rooted...only one then got cm4dx (latest as of this post)

http://pastebin.com/D952Q0kU = vzw stock .605 rooted

http://pastebin.com/vb8xPP32 = vzw stock .605 rooted then cm4dx GB

both phones were powered off
both phones turned on exactly same time
both phones on for 1hr and 5mins
both phones sent dmesg to email

they both look alot alike
Successfully put all powerdomains to target state
look for that in both links
 

·
Android Apprentice
Joined
·
26 Posts
is anyone gonna even look what i suggested and found about "Successfully put all powerdomains to target state" showing up in the original vzw rom (rooted) and not the cm4dx gb?
i know there are more differences thats just one that i noticed

also can you look out how many more lines are in the pastebin for the cm4dx then there is for the vzw rom?
note:
cm4dx gb only had background data enabled....no sync stuff
the vzw rom had all the google stuff (4 checks = on) and also a skype account.

how can the vzw rom have all this extra stuff on and be 1/2 the size of the cm4dx with only backgroud data enabled?

ok there is a problem somewhere guys im thinking it is on the phone sides and since i have two droid-x`s and the vzw rom stays connected more then the cm4dx gb rom i am thinking its has to do with cm4dx then vzw rom

if this isnt the thread to reply i dont know where is but this is definately a problem
 

·
Registered
Joined
·
4,241 Posts
tdbone1 said:
is anyone gonna even look what i suggested and found about "Successfully put all powerdomains to target state" showing up in the original vzw rom (rooted) and not the cm4dx gb?
i know there are more differences thats just one that i noticed

also can you look out how many more lines are in the pastebin for the cm4dx then there is for the vzw rom?
note:
cm4dx gb only had background data enabled....no sync stuff
the vzw rom had all the google stuff (4 checks = on) and also a skype account.

how can the vzw rom have all this extra stuff on and be 1/2 the size of the cm4dx with only backgroud data enabled?

ok there is a problem somewhere guys im thinking it is on the phone sides and since i have two droid-x`s and the vzw rom stays connected more then the cm4dx gb rom i am thinking its has to do with cm4dx then vzw rom

if this isnt the thread to reply i dont know where is but this is definately a problem
Tdbone you are starting to become a harrassment. Please refrain from this type of activity. This may be a problem, but it is more or less YOUR problem. Not a rom specific problem. Continuation of this action can result in user infractions.

Have yu tried sbfing? When I was running cmdx gB my wifi connected successfully. It may be the particular device that has the issue, thus meaning a warranty exchange could be an option if this occurs on stock 602 or 605
 

·
Android Beginner
Joined
·
28 Posts
Hi blackadept,

So I know I said things were going fine for a while, however, my Wifi quality seems to be deteriorating. my phone now says that it is connected, but will stop communicating with the router after a somewhat random amount of time. I have rebooted the phone several times, and have not made any changes to the phone since I ran through the nvs_map.bin creation process you put together. Do you have any ideas? Should I go through all the folders, delete any of the nvs_map.bin files I find and start over?

Thanks for any help
 

·
Android Mechanic
Joined
·
203 Posts
Discussion Starter · #74 ·
Ezy, I wouldn't do that just yet. First try cleaning out your internet browsers. Also you could try booting into recovery and wipe your cache (not your data remember). Then there is always the trick of forgetting the network and reconnecting, similarly you could reset the router itself either normally or unplugging its power cable and leaving it disconnected for ~30 secs and then plugging it back in.

Also, depending on what Rom, kernel, and what other mods you have installed it could be being caused by a bug on that end as there have been plenty seen over time. All in all there's lots you can try, including remaking the bin, however I'd save that for last.

Zek, glad you figured it out! Lil bastard can be pretty good at hide and go seek ... Haha.

Sent from my ADR6425LVW
 

·
Android Enthusiast
Joined
·
233 Posts
not gonna lie, this is probably beyond my skill set, but i have no idea how to even proceed after dmesg. haha, i iz special!
 

·
Android Beginner
Joined
·
28 Posts
Ezy, I wouldn't do that just yet. First try cleaning out your internet browsers. Also you could try booting into recovery and wipe your cache (not your data remember). Then there is always the trick of forgetting the network and reconnecting, similarly you could reset the router itself either normally or unplugging its power cable and leaving it disconnected for ~30 secs and then plugging it back in.

Also, depending on what Rom, kernel, and what other mods you have installed it could be being caused by a bug on that end as there have been plenty seen over time. All in all there's lots you can try, including remaking the bin, however I'd save that for last.

Zek, glad you figured it out! Lil bastard can be pretty good at hide and go seek ... Haha.

Sent from my ADR6425LVW
Cool thanks, will attempt those first

Sent from my DroidX running CM74GB using Tapatalk
 

·
Chief Molesting Officer
Joined
·
308 Posts
I'm trying to do this on MIUI 1.12.9 b/c my Wifi has been freaking out and I don't know why. I did in fact have the nvs_map.bin file appearing in my pds/wifi and my data/misc/wifi folders. I simply moved them outside of those folders and proceeded from step one in order to start from scratch.

I started by opening Terminal Emulator from the market, granting myself su permissions and proceeding from step 1. Everything occurred as advertised, but once I got to step 5, I ran into problems. When attempting to move the files using the commands listed, I got the following error: "cp: can't stat 'nvs_map.bin': No such file or directory". I went and looked in the root directory ('/') and saw that no such file existed. Is terminal emulator possibly creating the file somewhere else on my phone? I don't understand why it wouldn't have given me errors during the creation process if it didn't make one...
 

·
Registered
Joined
·
1 Posts
Hey blackadept - nice guide, but I still have an issue that hopefully you can help with:
On my DX running Liberty 3 v2.0 (previously Liquid 3.2, when I think the problem started), I can create the bin, place it where it's needed, run the script and all is well - until I reboot. Then I'm back to square one; my bin has vanished from /pds/wifi and hence no NVS. It does remain in the /system/etc/wifi dir however, so I try to point to that location instead in the init.mapphone_cdma.rc script. But again, when I reboot the script reverts to its original form, and no NVS. Similarly, any new files or folders I create in the / directory are gone after a reboot.

I notice on my 2nd DX, running Liberty v0.8 (flashed numerous ROMs prior) that the bins stay in both the /pds/wifi and /system/etc/wifi, but I still can't make any permanent changes to the init script.

Are these files/folder systems being re-loaded from somewhere on boot-up? If so, how can I prevent or control it?

Thanks for all your help!
 

·
Registered
Joined
·
73 Posts
Thanks for the guide! I was having problems with the MAC address changing with every reboot. Couldn't find nvs_map.bin anywhere, and so used your guide. It was successful, however I found my newly created nvs_map.bin file in /data/misc/wifi, not where expected. i copied the file from here and pasted it into /system/misc/wifi. Am I supposed to then go back to /data/misc/wifi and delete the original file? Everything seems to be working fine with my wifi and connections. Thanks again!
 
61 - 80 of 121 Posts
Top