Android OS Forum banner
1 - 13 of 13 Posts

·
Android Beginner
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi I just SBF'd back to 2.3.34 and for some reason z4root will not complete the root process. I need root so that I can setup CM7. Does anyone have any suggestions to make this work? I am open to using a different method to root the phone.

Thanks
 

·
Android Apprentice
Joined
·
33 Posts
Does it just continually run or does it stop and you are not rooted? If it runs for anything over five minutes or so stop Z4 and start it again normally works then. Also I believe gingerbreak will work on froyo as well if you are not having luck with Z4.
 

·
Android Nut
Joined
·
2,611 Posts
jgreenage said:
Hi I just SBF'd back to 2.3.34 and for some reason z4root will not complete the root process. I need root so that I can setup CM7. Does anyone have any suggestions to make this work? I am open to using a different method to root the phone.

Thanks
this is a common problem. just reboot and it should work.
 

·
Themer
Joined
·
282 Posts
I have the same issue, but iit never works no matter how many times I reboot. I just have to use the terminal emulator rageagainstthecage.zip method.

Sent from my DROIDX using Tapatalk
 

·
Android Lover
Joined
·
439 Posts
Put your phone in airplane mode before you start z4root, makes it go faster

Sent from my DROIDX using Tapatalk
 

·
Android Apprentice
Joined
·
66 Posts
I've been using GingerBreaker to "root".
Is there any reason I shouldn't ?
GingerBreaker works for me on all rom updates.

Thanks
 

·
Android Apprentice
Joined
·
41 Posts
cuccilover said:
I would like to know how to install z4root once downloaded. Any help will be great. Thank you.
Check unknown sources in the application menu of your settings. open the 'files' app and navigate to where you have it downloaded then click it and hit install.
 

·
I just hide here
Joined
·
2,237 Posts
interesting that, some of yall have had this problem. I literally have never had a problem with z4root. the only thing iv ever had a problem with, is accidently forgetting to turn on usb debugging.
 
G

·
I've always found that after a SBF, Z4Root will stick at the first phase unless I reboot my phone after SBFing and before running Z4Root. I've just gotten into the habit of rebooting it once it boots up after a SBF to prevent that from occurring. I was literally able to reproduce it every single time.
 
1 - 13 of 13 Posts
Top